Webhosting Umzug

Hier können Probleme und alles andere in Deutscher Sprache gelöst werden.
User avatar
refilix
Regular
Posts: 299
Joined: Sat Aug 01, 2009 12:39 am
Location: Berlin
Contact:

Re: Webhosting Umzug

Post by refilix » Sat Nov 16, 2019 8:48 am

Hallo,

phpmyadmin wird angezeigt das die Datenbank nicht mit SSL Verwendet wird.

Kann es was damit zu tun haben?
maria.png
maria.png (8.5 KiB) Viewed 688 times
Das Leben ist ein scheiss Spiel! Nur die Grafik ist geil!

User avatar
thh
Regular
Posts: 418
Joined: Thu Oct 26, 2006 2:38 pm
Location: Stuttgart, Germany
Contact:

Re: Webhosting Umzug

Post by thh » Sat Nov 16, 2019 9:30 pm

refilix wrote:
Sat Nov 16, 2019 8:19 am
Ist das soweit ok?
Ohne jetzt jede einzelne Zeile geprüft zu haben: ja - jedenfalls sieht das bei mir ebenso aus.

User avatar
erAck
Regular
Posts: 138
Joined: Mon Feb 16, 2015 1:20 am

Re: Webhosting Umzug

Post by erAck » Sat Nov 16, 2019 11:32 pm

yellowled wrote:
Fri Nov 15, 2019 9:28 pm
Dein Blog ist über https erreichbar, aber bestimmte Ressourcen (z.B. das Backend-Javascript) werden über http geladen.
Dazu fällt mir ein: sieh mal nach was unter Admin Settings -> Configuration, Paths, für URL to blog eingetragen ist, da sollte https://... statt http://... stehen.

User avatar
refilix
Regular
Posts: 299
Joined: Sat Aug 01, 2009 12:39 am
Location: Berlin
Contact:

Re: Webhosting Umzug

Post by refilix » Sun Nov 17, 2019 2:09 pm

Hallo,

ja das habe ich da auch so stehen. also https://

Wenn das Auf http:// steht wird zwar die Seite geladen aber Sie wird verzehrt angezeigt. teile vom Template, vermutlich Style.css wird nicht geladen.

Komme nicht weiter. Es wird weiterhin ein Fehler erzeugt und ich sehe nicht welchen.

Bisher war der Support nicht sehr hilfreich.

Ich hab keine andere Wahl und Probiere mich weiter aus....

mfg refi
Das Leben ist ein scheiss Spiel! Nur die Grafik ist geil!

User avatar
refilix
Regular
Posts: 299
Joined: Sat Aug 01, 2009 12:39 am
Location: Berlin
Contact:

Re: Webhosting Umzug

Post by refilix » Sun Nov 17, 2019 3:17 pm

Hallo,

wenn ich unter Konfiguration->Bildkonvertierung

ImageMagick zur Skalierung verwende, gibt es zwar eine Fehlermeldung da ich ImageMagick nicht installiert habe, aber es gibt kein Error 500. Auch wenn ich Bilder Löschen gibt es keine Fehlermeldung mehr.

Irgendeinen Zusammenhang gibt es da....
screen5.png
screen5.png (88.84 KiB) Viewed 653 times
Das Leben ist ein scheiss Spiel! Nur die Grafik ist geil!

User avatar
refilix
Regular
Posts: 299
Joined: Sat Aug 01, 2009 12:39 am
Location: Berlin
Contact:

Re: Webhosting Umzug

Post by refilix » Sun Nov 17, 2019 3:24 pm

Ok,

gleich Kotze ich. Habe es wieder umgestellt auf normal, also ohne ImageMagick. Jetzt Funktioniert es wie es soll. (Siehe Bild)
fertig.png
fertig.png (117.22 KiB) Viewed 651 times
Wie kann das sein?

mfg refi
Das Leben ist ein scheiss Spiel! Nur die Grafik ist geil!

User avatar
u1amo01
Regular
Posts: 273
Joined: Fri Sep 28, 2007 3:55 pm
Location: Kurpfalz, Germany
Contact:

Re: Webhosting Umzug

Post by u1amo01 » Tue Jul 07, 2020 9:52 am

Moin,
ich versuche mein Blog von uberspace zu all-inkl.com umzuziehen.

Habe alles herunter- und hochgeladen (ok, bei den Bilddateien lässt sich nicht alles kopieren - vermute ein Rechteproblem) und bekomme die Fehlermeldung

"Keine Schreibrechte für Verzeichnis /var/www/virtual/hyperion/html/blog/templates_c/. Bitte korrigieren"

Das ist aber der alte Pfad bei uberspace, nicht bei all-inkl.com. Hat jemand einen Tipp, welche Datei ich vergessen haben könnte anzupassen?

Ich sehe gerade den Wald vor lauter Bäumen nicht :-/

User avatar
onli
Regular
Posts: 2355
Joined: Tue Sep 09, 2008 10:04 pm
Contact:

Re: Webhosting Umzug

Post by onli » Tue Jul 07, 2020 11:13 am

Hast du die Datenbank angepasst? In serendipity_config wird der Dateipfad gespeichert. Ich habe meinen Entwicklungsblog bei uberspace und dort sieht das so aus:

Code: Select all

sqlite> select name, value from serendipity_config WHERE name = "serendipityPath";
serendipityPath|/var/www/virtual/onli2/html/s9y_dev/

User avatar
u1amo01
Regular
Posts: 273
Joined: Fri Sep 28, 2007 3:55 pm
Location: Kurpfalz, Germany
Contact:

Re: Webhosting Umzug

Post by u1amo01 » Tue Jul 07, 2020 7:42 pm

Guter Tipp! Vielen Dank. Habe kurzentschlossen mangels sql-Kentnissen im Dump im Texteditor mit Suchen und Ersetzen gewirkt.

Jetzt habe ich es immerhin soweit, dass die Meldung das richtige Verzeichnis anmeckert:
"Keine Schreibrechte für Verzeichnis /blog/templates_c/. Bitte korrigieren"

Habe über Filezilla die Rechte auf "0777" gesetzt, was aber nicht hilft. Seltsam eigentlich.

Vielleicht probiere ich eine Neuinstallation mit einer leeren Datenbank und importiere dann dort anschließend den alten Dump?

User avatar
onli
Regular
Posts: 2355
Joined: Tue Sep 09, 2008 10:04 pm
Contact:

Re: Webhosting Umzug

Post by onli » Tue Jul 07, 2020 8:12 pm

Ja, das kann man probieren. Eventuell wird dann bei der Installation das Rechteproblem behoben.

/blog/templates_c/ ist aber zu kurz, da fehlt der Pfad zum Webverzeichnis. Oder schneidet die Fehlermeldung das ab?

User avatar
u1amo01
Regular
Posts: 273
Joined: Fri Sep 28, 2007 3:55 pm
Location: Kurpfalz, Germany
Contact:

Re: Webhosting Umzug

Post by u1amo01 » Tue Jul 07, 2020 8:27 pm

Hm, es ist ja nicht uberspace. Ich versuchs mit einer Neuinstallation und dann schau ich mir an, was dabei passiert.

User avatar
u1amo01
Regular
Posts: 273
Joined: Fri Sep 28, 2007 3:55 pm
Location: Kurpfalz, Germany
Contact:

Re: Webhosting Umzug

Post by u1amo01 » Tue Jul 07, 2020 8:50 pm

Komplette Neuinstallation hat geklappt.

Ich mach davon einen Dump, damit ich die Pfade etc. nachsehen kann, pflege die in den Dump der alten Datenbank ein und importiere die dann.

Das mache ich aber lieber erst morgen in Ruhe. Jetzt bin ich guter Hoffnung :-)

Vielen Dank!

User avatar
u1amo01
Regular
Posts: 273
Joined: Fri Sep 28, 2007 3:55 pm
Location: Kurpfalz, Germany
Contact:

Re: Webhosting Umzug

Post by u1amo01 » Tue Jul 07, 2020 10:31 pm

Habs doch noch heute Abend probiert.

Habe einen Dump vom neu installierten Blog gemacht und nach dem Inhalt von serendiptyPath gesucht.

Dann im ursprünglichen, unveränderten Dump des alten Blogs den alten Dateipfad durch den neuen ersetzt.

Anschließend die neuen Datenbanktabellen auf dem Server gelöscht und den Dump des alten Blogs hochgeladen.

Das Theme hats irgendwie nicht überlebt; das war ein leicht angepasstes 2k11. Das kriege ich aber wieder hin. Das Verzeichnis "upload" muss ich noch füllen; das sind so viele Fotos, dass mir der Upload ständig abgebrochen ist. Mal sehen, wie ich das schrittweise mache.

Und die Plugins fehlen noch.

Die 1330 Einträge sind auf jeden Fall wieder da - seit 2005. Jippie! :-) :-D

Vielen Dank!

(Pro-Tipp: den alten Kram auf dem alten Server so lange behalten, bis das neue Blog rund läuft, könnte vieles vereinfachen. Mache ich das nächste Mal ganz bestimmt ;-)

Post Reply