does new PHP 7.X break anything?

Found a bug? Tell us!!
Post Reply
rootnl2k
Regular
Posts: 13
Joined: Tue Jul 17, 2012 7:15 am

does new PHP 7.X break anything?

Post by rootnl2k » Mon Mar 11, 2019 9:03 pm

Getting Your browser did not sent a valid HTTP-Referrer string. This may have either been caused by a misconfigured browser/proxy or by a Cross Site Request Forgery (XSRF) aimed at you. The action you requested could not be completed. and running Serendipity 2.1.4 and PHP 7.2.16 . phpinfo available from https://secure.nl2k.ab.ca/phpinfo.phtml . Tried to add an etnry just now and this error is baffling me.

User avatar
onli
Regular
Posts: 2243
Joined: Tue Sep 09, 2008 10:04 pm
Contact:

Re: does new PHP 7.X break anything?

Post by onli » Mon Mar 11, 2019 10:59 pm

In the current git master I fixed a bug in the "remember me" function. But I thought that bug got introduced when updating gow that autologin cookie works, and that should not be in 2.1.4 yet.

Try to logout and login again, this time without the "Remember Me" function being activated.

rootnl2k
Regular
Posts: 13
Joined: Tue Jul 17, 2012 7:15 am

Re: does new PHP 7.X break anything?

Post by rootnl2k » Fri Mar 22, 2019 5:52 pm

I never use the Remember Me function. What else could it be?

Post Reply