Could not install or upgrade plugins with 2.1.2

Found a bug? Tell us!!
Post Reply
User avatar
erAck
Regular
Posts: 58
Joined: Mon Feb 16, 2015 2:20 am

Could not install or upgrade plugins with 2.1.2

Post by erAck » Tue Mar 27, 2018 3:39 pm

After upgrading to 2.1.2, attempting to install or upgrade (in this case Spamblock (Bayes)) a plugin yielded the error
The URL /additional_plugins/serendipity_event_spamblock_bayes/img/spamblock_bayes.load.gif?revision=1.9999 (IP ) could not be opened. Maybe the Serendipity or SourceForge.net Server is down - we are sorry, you need to try again later.
Note that server and root path are missing from the URL. I do have set github.com in the Spartacus plugin as source for both, File/Mirror location (XML metadata) and File/Mirror location (files). After going to the Spartacus setup and intuitively ;-) clicking Save these informational messages were displayed:
Deleting file package_template.xml...
Deleting file package_sidebar_en.xml...
Deleting file package_event_en.xml...
And subsequently the plugin upgrade worked.

So it seems that the upgrade from 2.1.1 to 2.1.2 should had cleared those cache files. Probably manually removing templates_c/package_* should work as well.

MarioH
Regular
Posts: 228
Joined: Mon Jul 20, 2009 10:53 pm
Contact:

Re: Could not install or upgrade plugins with 2.1.2

Post by MarioH » Tue Mar 27, 2018 8:12 pm

Confirmed. I see this behavour in three of my blogs, too. You have to go to spartacus settings and save once, even without doing any changes. After that, plugin upgrade is working again.

thh
Regular
Posts: 232
Joined: Thu Oct 26, 2006 2:38 pm
Location: Stuttgart, Germany
Contact:

Re: Could not install or upgrade plugins with 2.1.2

Post by thh » Wed Mar 28, 2018 1:56 pm

Thanks for reporting (and debugging)!

I opened an issue at https://github.com/s9y/Serendipity/issues/548.

User avatar
robert
Regular
Posts: 1040
Joined: Mon May 09, 2005 9:17 pm
Location: Vienna, Austria
Contact:

Re: Could not install or upgrade plugins with 2.1.2

Post by robert » Fri Apr 06, 2018 7:48 pm

Did the same. But now I see (when I try to update the plugins) a blank page.

Delete the cache in "templates_c" didn't help.

Update I also deleted the s9y cookie on my Browser. Nothing: blank screen again when updating.
Nur ein Blog ...auf robertlender.info - natürlich mit S9y betrieben

S9y InfoCamp - der (inoffizielle) S9y-Podcast

User avatar
robert
Regular
Posts: 1040
Joined: Mon May 09, 2005 9:17 pm
Location: Vienna, Austria
Contact:

Re: Could not install or upgrade plugins with 2.1.2

Post by robert » Thu Oct 18, 2018 8:34 pm

Have installed 2.1.4 - Same problem...

Greetings
Robert
Nur ein Blog ...auf robertlender.info - natürlich mit S9y betrieben

S9y InfoCamp - der (inoffizielle) S9y-Podcast

User avatar
onli
Regular
Posts: 2160
Joined: Tue Sep 09, 2008 10:04 pm
Contact:

Re: Could not install or upgrade plugins with 2.1.2

Post by onli » Fri Oct 19, 2018 11:55 am

Roboert, I think this has to be a different issue then the one originally reported here. Blank screen -> do you see an error message in your webserver log?

User avatar
robert
Regular
Posts: 1040
Joined: Mon May 09, 2005 9:17 pm
Location: Vienna, Austria
Contact:

Re: Could not install or upgrade plugins with 2.1.2

Post by robert » Sun Oct 21, 2018 4:26 pm

Thx onli for reply.

I posted an Error Log here: viewtopic.php?f=10&t=24072

By the way: A klick on "Install Event Plugins" also create a blank Site, a click an "Install Sidebar Event" do what it should.

The "phenomenon" in different browsers:

Safari shows a blank site.
Chrome means "HTTP ERROR 500".
Firefox shows a blank site.
Nur ein Blog ...auf robertlender.info - natürlich mit S9y betrieben

S9y InfoCamp - der (inoffizielle) S9y-Podcast

User avatar
onli
Regular
Posts: 2160
Joined: Tue Sep 09, 2008 10:04 pm
Contact:

Re: Could not install or upgrade plugins with 2.1.2

Post by onli » Sun Oct 21, 2018 4:42 pm

The 500 error page confirms that this is a server side rror. The log in the other thread shows no error message. This must be something specific. Maybe you can recruit the help of your hoster?

User avatar
robert
Regular
Posts: 1040
Joined: Mon May 09, 2005 9:17 pm
Location: Vienna, Austria
Contact:

Re: Could not install or upgrade plugins with 2.1.2

Post by robert » Sun Oct 21, 2018 4:46 pm

Thx. I will try.
Nur ein Blog ...auf robertlender.info - natürlich mit S9y betrieben

S9y InfoCamp - der (inoffizielle) S9y-Podcast

Huhu
Regular
Posts: 105
Joined: Tue Oct 04, 2011 3:22 pm

Re: Could not install or upgrade plugins with 2.1.2

Post by Huhu » Thu Oct 25, 2018 2:52 pm

Same problem here (SPARTACUS set to GitHub). Strange thing is that it works with other installations, which are hosted by the same provider *and* are in the same server space (but with another domain). Blank page.

With the same installation, the "Submit" button for the media center (when trying to embed images in an article; select image -> submit) wouldn't work at all. The button doesn't react. Shouldn't be connected to the plug-in issue but ... who knows ...
Fan of post-apocalyptic Jugger: Free ebook on the sport

Post Reply