Multilanguage Plugin - autologin cookie

Found a bug? Tell us!!
Post Reply
stephanbrunker
Regular
Posts: 18
Joined: Sat Nov 25, 2017 1:08 am

Multilanguage Plugin - autologin cookie

Post by stephanbrunker » Sat Sep 14, 2019 12:34 am

I have updated to 2.3.1 from 2.1.2 and I have now serious issues with the multilanguage plugin: viewtopic.php?f=4&p=10452371&sid=1238f8 ... #p10452371

I did a quick look into the issue and started with what happens if you choose one of the languages in the dropdown. That submits and put a POST with 'user_language' and the value of the language. That POST leads to the generation of the cookie, and that part of the functions_config.inc.php file was changed massively between both versions. So, whoever did the changes didn't check the multilanguage plugin. In short: after a language change with the dropdown, the change is not persistent after any click on a link and jumps back to default while the POST with the different setting is still active. Please fix that asap, because it makes multilanguage effectively impossible.

You can see that also directly in my blog until i revert back to 2.1.2: http://www.intjblog.de
It is just that the newer posts aren't translated, but navigating to the posts in english only works if you first navigate to page 4 or so and then change language, and that only works for that one page.

thh
Regular
Posts: 315
Joined: Thu Oct 26, 2006 2:38 pm
Location: Stuttgart, Germany
Contact:

Re: Multilanguage Plugin - autologin cookie

Post by thh » Mon Sep 16, 2019 11:29 pm


Post Reply