imagemagick wird nicht erkannt

Hier können Probleme und alles andere in Deutscher Sprache gelöst werden.
Post Reply
MrChili
Regular
Posts: 8
Joined: Fri Aug 03, 2018 2:42 pm
Location: Salzgitter
Contact:

imagemagick wird nicht erkannt

Post by MrChili » Tue Apr 23, 2019 5:11 pm

Hallo,
ich habe einen CentOS7 VPS mit Plesk Onyx laufen.
auf dem habe ich nach dieser anleitung Imagemagick drauf installiert und auch eingerichtet.
https://grepitout.com/install-imagemagick-plesk-server/

Nur nach euren Tests von(viewtopic.php?f=10&t=6257) findet er es trotzdem nicht.

1. test.php

Code: Select all

<?php
echo `/usr/local/bin/convert -help`;
?>
Zeigt mir eine leere weiße Seite.
2.test.php

Code: Select all

<?php 
$dir = '/usr/local/bin'; 
if (function_exists('is_executable')) echo 'is_executable exists '; 
if (function_exists('is_executable') && is_executable($dir . '/convert')) { echo 'File is executable'; } else { echo 'File is NOT executable '; } 
if (is_file($dir . '/convert')) echo 'File IS_FILE ';
?> 
Zeigt mir:
is_executable exists File is NOT executable
3. testy.php

Code: Select all

<?php
$dir = '/usr/local/bin';
                if (!empty($dir) && (function_exists('is_executable') && is_executable($dir . '/convert')) || is_file($dir . '/convert')) {
                    echo "FOUND: " . $dir . '/convert';
                } else {
                    echo "NOT FOUND: " . $dir . '/convert';
                } 
?> 
Zeigt mir:
NOT FOUND: /usr/local/bin/convert
Ich bin ratlos :(

Liebe Grüße
Florian
Besucht mich! :
Homepage | Facebook | Twitter

User avatar
erAck
Regular
Posts: 93
Joined: Mon Feb 16, 2015 2:20 am

Re: imagemagick wird nicht erkannt

Post by erAck » Tue Apr 23, 2019 11:14 pm

Ist /usr/local/bin/convert denn executable fuer den webserver user?
Was mich wundert ist, dass in 2.test.php
if (is_file($dir . '/convert')) echo 'File IS_FILE ';
in deinem Beispiel keine Ausgabe liefert. Kann dann eigentlich nur noch ein Verzeichnis oder symbolic link sein wenn es überhaupt erreichbar ist, oder schon /usr/local/bin/ ist für den webserver user nicht durchsuchbar (keine 'x' permission).

MrChili
Regular
Posts: 8
Joined: Fri Aug 03, 2018 2:42 pm
Location: Salzgitter
Contact:

Re: imagemagick wird nicht erkannt

Post by MrChili » Thu May 16, 2019 5:35 pm

Ich konnte es nun lösen einfach cpanel installiert und nun geht es.
Besucht mich! :
Homepage | Facebook | Twitter

Post Reply