Kategorien anklicken klappt nicht

Hier können Probleme und alles andere in Deutscher Sprache gelöst werden.
Post Reply
HadleyB
Regular
Posts: 753
Joined: Sun Feb 12, 2006 12:47 am

Kategorien anklicken klappt nicht

Post by HadleyB » Sat Nov 24, 2018 7:22 pm

Hallo zusammen,

ich traue mich mal wieder eine Frage zu stellen. Für eine Kundin habe ich das Theme "Clean Blog" installiert und dort in die "Navigations-Optionen" die Links zu verschiedenen Kategorien eingetragen. Leider funktioniert das aber nicht, wenn ich die einzelnen Kategorien aufrufe, werden immer alle(!) Beiträge angezeigt, also auch die, die gar nicht zu der angeklickten Kategorie gehören. Das passiert auch, wenn ich im Archiv die Kategorien anklicke, es werden immer alle Artikel angezeigt.

Hat jemand einen Rat für mich?
mfg
Hadley

bernd_d
Regular
Posts: 464
Joined: Thu Jun 03, 2010 9:28 am
Contact:

Re: Kategorien anklicken klappt nicht

Post by bernd_d » Sat Nov 24, 2018 9:07 pm

Ein Link zu der Seite könnte vielleicht helfen. Geht es denn, wenn du auf der normalen Seite (überm/unterm Artikel, nicht in der Navigation) eine Kategorie anklickst?

HadleyB
Regular
Posts: 753
Joined: Sun Feb 12, 2006 12:47 am

Re: Kategorien anklicken klappt nicht

Post by HadleyB » Sun Nov 25, 2018 10:34 am

http://mainstory.de/cms/

Nein, dann geht es leider auch nicht. So machen die Kategorien in dem Theme leider keinen Sinn, oder mache ich (mal wieder) etwas falsch?
mfg
Hadley

HadleyB
Regular
Posts: 753
Joined: Sun Feb 12, 2006 12:47 am

Re: Kategorien anklicken klappt nicht

Post by HadleyB » Sat Dec 01, 2018 12:57 pm

Hm, hat denn niemand eine Lösung? Ich würde ungern das Theme ändern, der Kundin gefällt das sehr gut!
mfg
Hadley

User avatar
erAck
Regular
Posts: 58
Joined: Mon Feb 16, 2015 2:20 am

Re: Kategorien anklicken klappt nicht

Post by erAck » Sat Dec 01, 2018 1:38 pm

Funktioniert es denn mit einem anderen Theme? Oder funkt da ein .htaccess RewriteRule dazwischen? Gibt es die Kategorien wirklich? Das gleiche passiert nämlich auch, wenn eine nicht existierende Kategorie angegeben wird, z.B. http://mainstory.de/cms/index.php?/categories/lala

HadleyB
Regular
Posts: 753
Joined: Sun Feb 12, 2006 12:47 am

Re: Kategorien anklicken klappt nicht

Post by HadleyB » Mon Dec 03, 2018 11:29 am

Danke für Deine Antwort. Die Kategorien sind alle vorhanden:

Image

An der htaccess hab ich nichts verändert, das ist die von S9Y. Auch mit anderen Themes funktioniert es nicht!. Kann es sein, dass es an der Datenbank liegt, ich verwende PDO::SQLite. Oder hab ich vielleicht irgendwo ein Häkchen übersehen?
Attachments
katego.gif
katego.gif (6.05 KiB) Viewed 154 times
mfg
Hadley

User avatar
erAck
Regular
Posts: 58
Joined: Mon Feb 16, 2015 2:20 am

Re: Kategorien anklicken klappt nicht

Post by erAck » Mon Dec 03, 2018 9:16 pm

Mich wunderte eigentlich warum die ID-Ziffern (categoryid) mit in der URL auftauchen, aber wenn du jetzt sagst, dass du in der .htaccess nichts verändert hast, dann stimmt wahrscheinlich die RewriteBase nicht, die in deiner Demo /cms/ sein sollte.

HadleyB
Regular
Posts: 753
Joined: Sun Feb 12, 2006 12:47 am

Re: Kategorien anklicken klappt nicht

Post by HadleyB » Wed Dec 05, 2018 9:45 am

Das hier ist die htaccess, ich hab da nichts verändert:

Code: Select all

# BEGIN s9y
DirectoryIndex /cms/index.php

<Files *.tpl.php>
    deny from all
</Files>

<Files *.tpl>
    deny from all
</Files>

<Files *.sql>
    deny from all
</Files>

<Files *.inc.php>
    deny from all
</Files>

<Files *.db>
    deny from all
</Files>

# END s9y
Die Ziffern der Kategorien tauchen in all meinen installierten Blogs auf, daran kann es nicht liegen.
mfg
Hadley

User avatar
erAck
Regular
Posts: 58
Joined: Mon Feb 16, 2015 2:20 am

Re: Kategorien anklicken klappt nicht

Post by erAck » Thu Dec 06, 2018 1:39 am

Hmm.. (ich vergaß, dass der default vielleicht mit ID ist und ich den Permalink seit Urzeiten geändert hab) ... wenn das alles ist, ist unter Configuration -> Permalinks alles default und nichts geändert? Speziell, ist Permalink Category URL structure categories/%id%-%name% ? Vielleicht da einmal was ändern und speichern und wieder zurück ändern und speichern damit .htaccess neu geschrieben wird (die ist schreibbar, ja?) und eine <IfModule mod_rewrite.c> section bekommt. Sonst mal probieren, Permalink categories/%name% zu nehmen, Kategorien dürfen dann halt nicht den gleichen Namen haben, was bei ein-Autor Blogs leicht einzuhalten ist.

HadleyB
Regular
Posts: 753
Joined: Sun Feb 12, 2006 12:47 am

Re: Kategorien anklicken klappt nicht

Post by HadleyB » Mon Dec 10, 2018 3:09 pm

Ich hab leider kein einziges Wort verstanden....
mfg
Hadley

User avatar
erAck
Regular
Posts: 58
Joined: Mon Feb 16, 2015 2:20 am

Re: Kategorien anklicken klappt nicht

Post by erAck » Thu Dec 13, 2018 3:02 am

Dann noch mal gaaanz laaangsaaammm..

(ich hab mein Admin-Interface auf Englisch und werde das jetzt nicht umstellen, die Punkte zu uebersetzen ueberlasse ich also dir)
  1. gehe zu Settings -> Configuration
  2. klappe Permalinks auf
  3. suche Permalink Category URL structure (sollte das dritte Feld sein, hinter Entry URL und Author URL)
  4. da sollte categories/%id%-%name% im Edit-Feld stehen
  5. ändere das zu categories/%name%
  6. ganz unten am Ende des Formulars Check&Speichern klicken
Die /cms/.htaccess Datei sollte jetzt ein paar Einträge mit RewriteEngine On und RewriteBase /cms/ usw. haben. Wenn nicht, stimmt da was nicht, z.B. Datei nicht schreibbar fuer den web user. Wenn doch, dann sollten im Blog die Kategorien nicht mehr mit .../1-career sondern .../career verlinkt sein. Und nach Klick auch nur eine gezeigt werden.

Wenn in Ordnung (also die .htaccess geändert geschrieben wurde und die Anzeige stimmt) kannst du das dann entweder so lassen, oder falls du die ID-Nummer vor dem Kategorienamen erhalten willst den Permalink Category URL wieder auf categories/%id%-%name% ändern und speichern.

Die ID ist eindeutig und wird mit Aufnahme der Kategorie in die Datenbank vergeben. Kategorienamen können doppelt angelegt werden und müssen in dem Fall zusätzlich mit der ID verlinkt werden um eindeutig zu sein. Wie gesagt, ein einzelner Autor wird kaum zwei Kategorien mit gleichem Namen haben.

HadleyB
Regular
Posts: 753
Joined: Sun Feb 12, 2006 12:47 am

Re: Kategorien anklicken klappt nicht

Post by HadleyB » Sat Dec 15, 2018 6:50 pm

Danke Dir, das war gut und sehr verständlich. Es funktioniert aber nicht, die Werte werden nicht in die htacess geschrieben.

Ich habe mich entschlossen, die Datenbank nun doch auf MySQL zu ändern, vielleicht liegt das einfach an der PDO.

Daran liegt es nicht. Auch nach der Umstellung auf MySQL werden nach einem Klick auf die Kategorien immer noch alle Einträge angezeigt und nicht nur die angeklickte Kategorie!

http://www.mainstory.de/cms/
mfg
Hadley

Post Reply