Update von 1.79 auf 2.x - leere Seite, keine Änderung

Hier können Probleme und alles andere in Deutscher Sprache gelöst werden.
Post Reply
AndreasH
Regular
Posts: 5
Joined: Sat Nov 17, 2018 11:13 am

Update von 1.79 auf 2.x - leere Seite, keine Änderung

Post by AndreasH » Sat Nov 17, 2018 11:26 am

Hallo,

erstmal in Deutsch, in ausländisch frag ich später noch.

Ich dachte auch, ich müsste mal langsam updaten von 1.79. Autoupdater auf die Schnelle nicht gefunden also manuell. Backup gemacht, aktuelles s9y hoch geladen, alles außer htaccess und config überschrieben. Seite aufgerufen, Update startet schön, es gibt 3 grüne beschreibbar Felder und eine Liste von haufenweise Files die überschrieben und gelöscht werden sollen. Prima.
Nach Klick auf mach mal - kommt ein leeres Browserfenster. Es passiert nix mehr. Datenbankänderung war noch nicht durchgeführt - glaub ich mal.

Also erstmal alles wieder auf 179 zurückgespielt. Was mach ich jetzt sinnvoller weise ?

Danke.

User avatar
onli
Regular
Posts: 2160
Joined: Tue Sep 09, 2008 10:04 pm
Contact:

Re: Update von 1.79 auf 2.x - leere Seite, keine Änderung

Post by onli » Sat Nov 17, 2018 4:09 pm

Welche PHP-Version läuft auf dem Server?

Wenn es eine leere Seite gibt gab es wohl einen 500er, einen Serverfehler. Da wäre es dann am besten ins Severlog zu schauen um zu sehen, welcher Fehler zum Zeitpunkt des Seitenaufrufs protokolliert wurde.

AndreasH
Regular
Posts: 5
Joined: Sat Nov 17, 2018 11:13 am

Re: Update von 1.79 auf 2.x - leere Seite, keine Änderung

Post by AndreasH » Sun Nov 18, 2018 10:47 am

Hm, danke, sieht nach ner php5 config aus. Bißchen alt, was ? :mrgreen:
Ich habs jetzt mal auf 7 umgestellt und werd das Update heute noch mal probieren.

k a ob ich an die logs komme, liegt auf 'nem VirtualHost

Tja, auch mit php7 kein Erfolg, immer noch blanke Seite ... Sind vielleicht irgendwelche VHost Schalter notwendig ?

User avatar
onli
Regular
Posts: 2160
Joined: Tue Sep 09, 2008 10:04 pm
Contact:

Re: Update von 1.79 auf 2.x - leere Seite, keine Änderung

Post by onli » Sun Nov 18, 2018 12:24 pm

Es sollte eigentlich nichts am Server notwendig sein. Aber es könnte zum Beispiel sein, dass ein altes Plugin noch so alten Code hat, dass es mit PHP 7 nicht funktioniert.

PHP 7.2 wäre übrigens noch zu neu, wir hängen da etwas hintendran. PHP 7.0 oder 7.1 ist die richtige Version für die derzeitige Version.

AndreasH
Regular
Posts: 5
Joined: Sat Nov 17, 2018 11:13 am

Re: Update von 1.79 auf 2.x - leere Seite, keine Änderung

Post by AndreasH » Sun Nov 18, 2018 1:50 pm

Betrieben mit Serendipity 1.7.9 und PHP 7.0.27-0+deb9u1

und außer statische Seiten hab ich da nix wildes an plugins drin.

Serverfehler kann ich in den apache logs auch nicht erkennen außer "Request header read timeout" und das ist wohl eher ein allgemeiner Fehler ? Sieht so aus als würd gar nix passieren oder ich such an der falschen Stelle, kann auch sein.

Krieg ich das irgendwie über 'ne Neuinstallation von 2.1 repariert ?

User avatar
onli
Regular
Posts: 2160
Joined: Tue Sep 09, 2008 10:04 pm
Contact:

Re: Update von 1.79 auf 2.x - leere Seite, keine Änderung

Post by onli » Sun Nov 18, 2018 9:08 pm

Krieg ich das irgendwie über 'ne Neuinstallation von 2.1 repariert ?
Wahrscheinlich. A besten auf einer lokalen Installation testen, ob der Import des Exports deiner Einträge so gut funktioniert wie erhofft. Aber wenn es irgendwie an der alten Installation hängt würde eine Neuinstallation ja helfen.

AndreasH
Regular
Posts: 5
Joined: Sat Nov 17, 2018 11:13 am

Re: Update von 1.79 auf 2.x - leere Seite, keine Änderung

Post by AndreasH » Mon Nov 19, 2018 4:39 pm

tja, hab nur statische Seiten, da ist nix mit export. Die plugins werfen fehler aus
und irgendwas in der firewall verhindert das php updates laufen.

User avatar
erAck
Regular
Posts: 58
Joined: Mon Feb 16, 2015 2:20 am

Re: Update von 1.79 auf 2.x - leere Seite, keine Änderung

Post by erAck » Mon Nov 19, 2018 10:52 pm

Uralte Plugins? Siehe diesen Thread.

AndreasH
Regular
Posts: 5
Joined: Sat Nov 17, 2018 11:13 am

Re: Update von 1.79 auf 2.x - leere Seite, keine Änderung

Post by AndreasH » Tue Nov 20, 2018 12:28 pm

hatte ich gelesen, alle plugins waren für 179 und dafür aktuell wenn ich mich nicht irre.
Jetzt nölt das statische Seiten nach Update plugin rum das es für 2.0 ist, plugin kaputt, Seiten weg :?:

Lass mal... Wordpress Installation und texte/bilder reinkippen ist schneller als die Fehlersuche. :roll:

Post Reply