S9Y 2.1.3 and Plugin Piwik

Found a bug? Tell us!!
Post Reply
Bla
Regular
Posts: 22
Joined: Sat Feb 03, 2007 8:42 pm
Location: Germany
Contact:

S9Y 2.1.3 and Plugin Piwik

Post by Bla » Thu Sep 13, 2018 9:51 pm

As mentioned some weeks ago in the announcement board, I got an error when updating. Coming from 2.1.2 using the offered updater I got a 2.1.4-beta1 with this exception on PHP7.1:

Code: Select all

[…]
 == ERROR-REPORT (BETA/ALPHA-BUILDS) ==
Fatal Error: Uncaught ErrorException: Notice: Methods with the same name as their class will not be constructors in a future version of PHP; HTTP_Request has a deprecated constructor in /[…]/bundled-libs/HTTP/Request.php:61 Stack trace: #0 /[…]/plugins/serendipity_event_piwik/serendipity_event_piwik.php(2): errorToExceptionHandler(8192, 'Methods with th...', '/[…]...', 61, Array) #1
[…]
As a quick solution using PHP 5.6.x or disabling serendipity_event_piwik works well for sure.

User avatar
onli
Regular
Posts: 2160
Joined: Tue Sep 09, 2008 10:04 pm
Contact:

Re: S9Y 2.1.3 and Plugin Piwik

Post by onli » Fri Sep 14, 2018 12:13 am

Oh, where is that plugin coming from? viewtopic.php?f=4&t=19993 ? It might need an update.

The issue is like the issue that is tracked on https://github.com/s9y/Serendipity/issues/550. Some plugins still use an old library to make HTTP request. But the event_piwik plugin is not on our radar because it is not on spartacus, if I don't miss something right now.

Bla
Regular
Posts: 22
Joined: Sat Feb 03, 2007 8:42 pm
Location: Germany
Contact:

Re: S9Y 2.1.3 and Plugin Piwik

Post by Bla » Fri Sep 14, 2018 7:17 am

Thanks a lot, that was easy to fix. I changed line 2 of the plugin code to us the new library and it works well with PHP7.1.

Code: Select all

require_once S9Y_PEAR_PATH . 'HTTP/Request2.php';

Post Reply