Logo oder Hintergrundbild in index.tpl einfügen?

Hier können Probleme und alles andere in Deutscher Sprache gelöst werden.
Post Reply
einfachKeck
Posts: 1
Joined: Mon Jul 02, 2018 10:27 am

Logo oder Hintergrundbild in index.tpl einfügen?

Post by einfachKeck » Mon Jul 02, 2018 10:49 am

Hallo zusammen,
ich habe bisher zwar einige Beiträge dazu gefunden, wie man Bilder aus der Mediathek einbindet, aber leider löst das nicht mein Problem.

Ich Arbeite gerade an meinem eigenen Template anhand dieses Tutorials:
http://www.gurkcity.de/blog/Serendipity ... te-26.html und soweit funktioniert auch alles. Ich habe nun nur ein Problem: Um das Theme jetzt an meine Website anzupassen muss ich noch mein Logo und eine Art Header Bild einfügen.

Damit am Ende alles so funktioniert wie ich das will muss ich die jeweiligen Bilder via HTML in die dafür vorgesehenen div Boxen in meiner index.tpl integrieren.

Soweit so gut. Nur leider werden mir die Bilder nicht bzw. mit defektem Link angezeigt, obwohl der Dateipfad stimmen müsste. Die Bilder liegen im selben Template-Ordner wie die style.css und die index.tpl. Darum müssten sie doch eigentlich in der index.tpl über

Code: Select all

<img src="bild.png" />
eingebunden werden können, oder übersehe ich da etwas? Es ist ja eigentlich kein Ordner dazwischen, den ich beachten müsste...

Kurz zu mir: Ich beherrsche HTML und CSS, ansonsten bin ich nicht sehr versiert in Programmiersprachen. Es Reicht um hier und da kleine änderungen z.B. in java oder php vorzunehmen, aber hier bin ich laie. Für Serendipity habe ich mich als Alternative zu Wordpress entschieden, weil es mir zu überladen war. Jetzt versuche ich zum 1. Mal ein Template zu gestalten.

Vielleicht weiß ja jemand wie ich das Problem behebe (es ist sicher ganz einfach und ich hab irgendwas offensichtliches übersehen).

Viele Grüße

einfachKeck

thh
Regular
Posts: 212
Joined: Thu Oct 26, 2006 2:38 pm
Location: Stuttgart, Germany
Contact:

Re: Logo oder Hintergrundbild in index.tpl einfügen?

Post by thh » Tue Jul 03, 2018 9:44 pm

einfachKeck wrote:
Mon Jul 02, 2018 10:49 am
Soweit so gut. Nur leider werden mir die Bilder nicht bzw. mit defektem Link angezeigt, obwohl der Dateipfad stimmen müsste. Die Bilder liegen im selben Template-Ordner wie die style.css und die index.tpl. Darum müssten sie doch eigentlich in der index.tpl über <img src="bild.png" /> eingebunden werden können, oder übersehe ich da etwas?
Ja, Du übersiehst da etwas: aus dem Template wird ja die Webseite erzeugt, die dann dem Nutzer angezeigt wird. In dieser Webseite ist dann auch das HTML-Element <img src="bild.png" /> enthalten. Diese Webseite aber "liegt" nicht im Template-Ordner; es wird also eine Datei bild.png in dem Ordner bzw. Pfad gesucht, in dem die Webseite sich "befindet" - bei der /index.php also im Ordner /, dem Webroot. Da ist sie aber nicht. Der Browser weiß ja nicht, dass das HTML-Dokument, das ihm da ausgeliefert wird, durch den Server "im Hintergrund" aus Templates zusammengebaut wird, die ganz woanders gespeichert sind.

Erforderlich ist daher eine absolute Pfadangabe: <img src="/templates/meintemplate/bild.png" />

Grüße,
-thh

Post Reply