Could not install or upgrade plugins with 2.1.2

Found a bug? Tell us!!
Post Reply
User avatar
erAck
Regular
Posts: 44
Joined: Mon Feb 16, 2015 2:20 am

Could not install or upgrade plugins with 2.1.2

Post by erAck » Tue Mar 27, 2018 3:39 pm

After upgrading to 2.1.2, attempting to install or upgrade (in this case Spamblock (Bayes)) a plugin yielded the error
The URL /additional_plugins/serendipity_event_spamblock_bayes/img/spamblock_bayes.load.gif?revision=1.9999 (IP ) could not be opened. Maybe the Serendipity or SourceForge.net Server is down - we are sorry, you need to try again later.
Note that server and root path are missing from the URL. I do have set github.com in the Spartacus plugin as source for both, File/Mirror location (XML metadata) and File/Mirror location (files). After going to the Spartacus setup and intuitively ;-) clicking Save these informational messages were displayed:
Deleting file package_template.xml...
Deleting file package_sidebar_en.xml...
Deleting file package_event_en.xml...
And subsequently the plugin upgrade worked.

So it seems that the upgrade from 2.1.1 to 2.1.2 should had cleared those cache files. Probably manually removing templates_c/package_* should work as well.

MarioH
Regular
Posts: 228
Joined: Mon Jul 20, 2009 10:53 pm
Contact:

Re: Could not install or upgrade plugins with 2.1.2

Post by MarioH » Tue Mar 27, 2018 8:12 pm

Confirmed. I see this behavour in three of my blogs, too. You have to go to spartacus settings and save once, even without doing any changes. After that, plugin upgrade is working again.

thh
Regular
Posts: 220
Joined: Thu Oct 26, 2006 2:38 pm
Location: Stuttgart, Germany
Contact:

Re: Could not install or upgrade plugins with 2.1.2

Post by thh » Wed Mar 28, 2018 1:56 pm

Thanks for reporting (and debugging)!

I opened an issue at https://github.com/s9y/Serendipity/issues/548.

User avatar
robert
Regular
Posts: 1034
Joined: Mon May 09, 2005 9:17 pm
Location: Vienna, Austria
Contact:

Re: Could not install or upgrade plugins with 2.1.2

Post by robert » Fri Apr 06, 2018 7:48 pm

Did the same. But now I see (when I try to update the plugins) a blank page.

Delete the cache in "templates_c" didn't help.

Update I also deleted the s9y cookie on my Browser. Nothing: blank screen again when updating.
Nur ein Blog ...auf robertlender.info - natürlich mit S9y betrieben

S9y InfoCamp - der (inoffizielle) S9y-Podcast

Post Reply