No Mysql option for database type

Found a bug? Tell us!!
Post Reply
eabjoker
Posts: 4
Joined: Sat Aug 19, 2017 3:16 am

No Mysql option for database type

Post by eabjoker » Sat Aug 19, 2017 11:37 pm

What do I have to do to enable the Mysql database in the configuration?
Only options are PDO::SQLite and SQLIte3.
I am using PHP 7.0, Serendipity 2.1.1, new install.
serendipity_db_error.png
serendipity_db_error.png (16.72 KiB) Viewed 448 times

thh
Regular
Posts: 220
Joined: Thu Oct 26, 2006 2:38 pm
Location: Stuttgart, Germany
Contact:

Re: No Mysql option for database type

Post by thh » Mon Aug 21, 2017 6:44 pm

eabjoker wrote:What do I have to do to enable the Mysql database in the configuration?
Only options are PDO::SQLite and SQLIte3.
Do you have compiled or installed a PHP with mySQL extension?

You can check for that by using a file called, for example, phpinfo.php, containing only this:

Code: Select all

<?php phpinfo(); ?>
When viewing that file in your browser, look for sections called "mysql" or "mysqli".

eabjoker
Posts: 4
Joined: Sat Aug 19, 2017 3:16 am

Re: No Mysql option for database type

Post by eabjoker » Mon Aug 21, 2017 8:28 pm

Thanks for the reply.
Below is a screenshot of the relevant phpinfo section.
I have other php applications using mysql on this install without any issue.
mysql.png
mysql.png (16.5 KiB) Viewed 440 times

User avatar
yellowled
Regular
Posts: 6920
Joined: Fri Jan 13, 2006 12:46 pm
Location: Eutin, Germany
Contact:

Re: No Mysql option for database type

Post by yellowled » Mon Aug 21, 2017 8:39 pm

eabjoker wrote:Below is a screenshot of the relevant phpinfo section.
At the very top of that page, there's a section “Configure Command”. Does that contain '--with-mysqli' in your phpinfo()?

YL
amazon Wishlist - Serendipity-Podcast (German only, sorry)

eabjoker
Posts: 4
Joined: Sat Aug 19, 2017 3:16 am

Re: No Mysql option for database type

Post by eabjoker » Mon Aug 21, 2017 9:37 pm

That appears to be the issue.
I am recompiling with mysqli option.

Post Reply