Just curious: Next and IE11, Back-Button (Entries) missing

Skinning and designing Serendipity (CSS, HTML, Smarty)
Post Reply
User avatar
kybernator
Regular
Posts: 126
Joined: Sat Sep 22, 2012 10:15 pm

Just curious: Next and IE11, Back-Button (Entries) missing

Post by kybernator » Mon Oct 17, 2016 3:03 pm

Hi,

I am using the Next-theme, and some minutes ago was showing the site http://www.ev-ref-gladbeck.de to someone.
I noticed that the "show older entries" button at the end of the "Aktuelles"-page was not visible, and that also the lower line under the H1 ("in gladbeck...") was moved to the left and thus under the logo (which is not embedded by original Next-code, obviously).
I only had a moment to check the browser version, it was IE 11, but I could not take a closer look at the (de-)activated browser options.

Well, since the site works just fine in IE11 usually, I am certainly not reporting a bug or anything, but just out of curiosity: What could cause this behaviour?

Bernhard

P.S.: Also, I would like to ask about a particular CSS-Code for just styling the colours of the H1-link differently from the rest of the page in the user.css. May I post the relevant code snippet here, and ask for advice? It is not a S9Y-question, I know, but finding the correct syntax in CSS and adapting it for S9Y/Next would probably take me an hour or two, and I suppose someone here would have an answer in a minute or two - including the time to type it...

User avatar
yellowled
Regular
Posts: 6994
Joined: Fri Jan 13, 2006 12:46 pm
Location: Eutin, Germany
Contact:

Re: Just curious: Next and IE11, Back-Button (Entries) missi

Post by yellowled » Tue Oct 18, 2016 1:23 pm

kybernator wrote:I noticed that the "show older entries" button at the end of the "Aktuelles"-page was not visible
It is visible, but there is something wrong™ with your .htaccess. For some reason, all assets (like the icon font used for the next/prev links in Next) are loaded from the domain without the www. prefix. If you call the blog via the www. prefixed domain, you get a CORS error because “No 'Access-Control-Allow-Origin' header is present on the requested resource.” (see the error console in your browser).

I think you'll either need to enable CORS or redirect non-www URLs.
kybernator wrote:and that also the lower line under the H1 ("in gladbeck...") was moved to the left and thus under the logo (which is not embedded by original Next-code, obviously).
That smells as if you edited a tpl file and forgot to close a <div> or a <span> or something. But it's actually in your markup that way:

Code: Select all

<a id="identity" href="http://ev-ref-gladbeck.de/">
    <h1>Evangelisch-Reformierte Freikirche</h1>
    <span>in Gladbeck &mdash; www.ev-ref-gladbeck.de</span>
</a>
h1 is your {$blogTitle}, span is {$blogDescription} as set in the blog's configuration.
kybernator wrote:P.S.: Also, I would like to ask about a particular CSS-Code for just styling the colours of the H1-link differently from the rest of the page in the user.css.

Code: Select all

#identity,
#identity:visited {
    color: red;
}

#identity:hover,
#identity:focus {
    color: blue;
}
(And yes, obviously you can use that for other styles than just the color.)

YL
amazon Wishlist - Serendipity-Podcast (German only, sorry)

User avatar
kybernator
Regular
Posts: 126
Joined: Sat Sep 22, 2012 10:15 pm

Re: Just curious: Next and IE11, Back-Button (Entries) missi

Post by kybernator » Tue Oct 18, 2016 2:10 pm

Hi YL,

first, thanks for the CSS-help - will use it this afternoon. The "#identity" was mainly what I needed :-)

Regarding the info about the IE-11 problem: I (kind of) understand what you are saying, but I would have supposed that this would cause the problem in all browsers. It was only visible in this particular instance of IE-11 - I constantly see the site in different browsers, and right after I saw the problem, as in "about 15 minutes later", I opened the site also using a computer with IE11, and everything was fine. (both machines, the one where it worked without flaws and the one where it didn't had a Windows 7 install, I didn't mention that before).
That's why I thought it must rather be a problem with the local configuration of the client machine, otherwise my "second look" should also have been affected.

User avatar
yellowled
Regular
Posts: 6994
Joined: Fri Jan 13, 2006 12:46 pm
Location: Eutin, Germany
Contact:

Re: Just curious: Next and IE11, Back-Button (Entries) missi

Post by yellowled » Tue Oct 18, 2016 5:12 pm

kybernator wrote:I (kind of) understand what you are saying, but I would have supposed that this would cause the problem in all browsers. It was only visible in this particular instance of IE-11 - I constantly see the site in different browsers, and right after I saw the problem, as in "about 15 minutes later", I opened the site also using a computer with IE11, and everything was fine.
It depends on what exactly we're talking about. In my case (Chrome 54, Mac, opened http://www.ev-ref-gladbeck.de/index.php?/frontpage), the “Next page” link is technically visible, but the proper icon is not loaded, which results in the browser showing a blank square instead. It may very well be (haven't tested it) that IE11 instead shows nothing at all. If you open the page using http://ev-ref-gladbeck.de/index.php?/frontpage in Chrome instead, the icon works fine – it may very well be that IE11 does not display it even then.

It is, however, definitely not an IE-only issue since both Chrome 54/Mac and Firefox 49/Mac don't show the icon while Safari 10/Mac does show it. Both links for the .htaccess should fix the issue and I think you can even use both together.

YL
amazon Wishlist - Serendipity-Podcast (German only, sorry)

Post Reply