Page 1 of 1

Shout Box - Remove a comment

Posted: Fri Jan 21, 2005 7:58 am
by MidNiteRaver
I have a comment posted twice on my Shout Box. I tried deleting it after loggin by clicking on the "delete" that appears but no luck. What is wrong?

Latest versio Serendipity - jus d/loaded and installed.

Nice!

MidNiteRaver
Kingston,
Jamaica
www.jamhosp.com
www.jamhosp.com/serendipity/index.php

Posted: Sun Jan 23, 2005 10:29 pm
by MidNiteRaver
Still haven't figure this one out ...help :roll:

Posted: Sun Jan 23, 2005 10:55 pm
by Little Hamster
The comments are stored in a database table called serendipity_shoutbox. Use phpmyadmin, go to the browse page of the table, and delete the duplicated comment.

Posted: Mon Jan 24, 2005 4:30 am
by MidNiteRaver
thx :D

Posted: Mon Jan 24, 2005 7:48 pm
by MidNiteRaver
Strange, then why does it have "delete" under each comment when I log in as admin?


Anyone?? :roll:

Posted: Tue Jan 25, 2005 10:14 am
by garvinhicking
It seems you don't have the DirectoryIndex Directive specified in your .htaccess file - or you have some other way of using redirections for the serendipity directory

When I open up the URL http://www.jamhosp.com/serendipity/?serendipity[calendarZoom]=200502 it won't show the february link. If I call http://www.jamhosp.com/serendipity/inde ... erendipity[calendarZoom]=200502 it works.

The shoutbox plugin uses the same method of not specifying the index.php file, so it won't work either....

Regards,
Garvin

Posted: Tue Jan 25, 2005 2:37 pm
by MidNiteRaver
What can I do to fix this. I did not install s9y my webhost where kind enough to do this, as their system, prior to me asking, did not support the installation requirements.

Can you guide me please :lol: ? (I'm no coder) So that I can fix the problem or ask my webhost to fix it.

Besides having to edit via the database rather than the main screen as an admin and the shout not appearing by date what else functions incorrectly with the shout when the setting is as mine is?

Posted: Tue Jan 25, 2005 4:45 pm
by garvinhicking
I think you need to fix the .htaccess file and look at DirectoryIndex. There are about 100 possible solutions to this which all depend on the setup of your hoster and how/if it handles redirects. If, for example, they host using mod_rewrite virtual rewriting, then they need to fix those rules...

It's all about that the links I gave you need to both show the same result. That's what your hoster needs to fix, because it depends on their setup...

Regards,
Garvin