No editor shown when "use WYSiWYG-editor" activated

Creating and modifying plugins.
Post Reply
User avatar
kybernator
Regular
Posts: 126
Joined: Sat Sep 22, 2012 10:15 pm

No editor shown when "use WYSiWYG-editor" activated

Post by kybernator » Wed Sep 21, 2016 10:25 pm

When I activate the use of a graphical editor and try to edit an article, the content of the article flashes very shortly on screen, then the whole area where the editable text and the editor itself should be shown remains white.
CKEditor is installed, is the last in the event plugin list, serendipity_event_emoticate, serendipity_event_nl2br and serendipity_event_s9ymarkup are currently moved to inactive.
I already deinstalled and reinstalled the CKEditor plugin.

Any ideas what else to try?

User avatar
onli
Regular
Posts: 2229
Joined: Tue Sep 09, 2008 10:04 pm
Contact:

Re: No editor shown when "use WYSiWYG-editor" activated

Post by onli » Wed Sep 21, 2016 10:57 pm

What happens if you just uninstall the CKEditor plugin and use the builtin wysiwyg editor?

User avatar
yellowled
Regular
Posts: 7017
Joined: Fri Jan 13, 2006 12:46 pm
Location: Eutin, Germany
Contact:

Re: No editor shown when "use WYSiWYG-editor" activated

Post by yellowled » Wed Sep 21, 2016 11:02 pm

kybernator wrote:CKEditor is installed, is the last in the event plugin list, serendipity_event_emoticate, serendipity_event_nl2br and serendipity_event_s9ymarkup are currently moved to inactive. I already deinstalled and reinstalled the CKEditor plugin.

Any ideas what else to try?
CK Editor is now (I think since 2.0) bundled with the s9y core. I assume that you do use 2.0, did not know about the core version and just installed the plugin. In 2.0, the plugin is no longer required. Not sure if that requires to clean up anything, but I'd suggesting removing the CK editor plugin, but keeping the configuration set to use the WYSIWYG editor.

YL
amazon Wishlist - Serendipity-Podcast (German only, sorry)

User avatar
kybernator
Regular
Posts: 126
Joined: Sat Sep 22, 2012 10:15 pm

Re: No editor shown when "use WYSiWYG-editor" activated

Post by kybernator » Wed Sep 21, 2016 11:04 pm

That works. I was not aware of a builtin wysiwyg-editor, I thought one had to be installed.

It may well be that it fits my needs nicely, so thanks!

User avatar
kybernator
Regular
Posts: 126
Joined: Sat Sep 22, 2012 10:15 pm

Re: No editor shown when "use WYSiWYG-editor" activated

Post by kybernator » Thu Sep 22, 2016 12:46 pm

Thanks Matthias,

I hadn't seen your post yesterday, we posted nearly at the same time. And yes, that was the case :-)

Post Reply