Spam Protector Plugin

Creating and modifying plugins.
Post Reply
User avatar
grantluc
Regular
Posts: 5
Joined: Fri Nov 30, 2012 2:06 am
Location: Adelaide South Australia
Contact:

Spam Protector Plugin

Post by grantluc » Mon Oct 20, 2014 12:50 am

Hi,
Perhaps a problem with Spam Protector? I am not sure....Problem is a huge increase in individual web pages being viewed on my site this month. I only have a few hundred pages on my site and Normally my stats reflect a similar number of individual pages a month being accessed... around 190...yet my AWSTATS reads that I have this month so far had around 8000 individual URLs/pages being hit on my site. Not certain if it is the cause but I started using the Spam Protector Plugin a couple of months ago in my sy9 generated blog which is embedded in my site & for the first month everything was great. I finally lost all of those annoying comments such as "great site" with links back to some loan organisation or weight loss site. I expanded my AWSTATS list down to see what the URL names were that people were viewing and there were thousands of almost the same URL with slightly different number sequence at the end. typically something like /blogweb/plugin/captcha_0ebd5fc944c7e1d84a88de6ac84b80c2. There are typically 2 entries and no exit on these pages. Simultaneously there was also a huge increase in exits from a couple of my old blog entries from a year or so ago. One having around 500 exits but only 80 entries. Really wierd. Also a huge amount of viewed pages from Ukraine (17k) being my top country this month when normally my top views are from Australia. Am I being attacked or is this a bug in the spam protector plugin or is this actually the spam protector doing its job & getting rid of some automated program trying to log in? I would appreciate any thoughts.

User avatar
Timbalu
Regular
Posts: 4598
Joined: Sun May 02, 2004 3:04 pm

Re: Spam Protector Plugin

Post by Timbalu » Mon Oct 20, 2014 11:55 am

grantluc wrote:Am I being attacked or [...] or is this actually the spam protector doing its job & getting rid of some automated program trying to log in? I would appreciate any thoughts.
Both: Yes, I assume. These Bots try to send comments when they find a form. Some of them are just simple and dumb, some have learning databases which form page url promises success without too much effort. (These lists may be active tradet in the dark web.) http://www.s9y.org/155.html

To your site:
RvSitebuilder uses a special, embedded, very old (1.5.5) and because of that merge, rather buggy Serendipity Build, with internal code changes we don't know about. We cannot give any help in these cases, sorry!

Our standard answer: Install your own standalone copy of Serendipity - http://www.s9y.org/12.html - and do not use the RvSitebuilder or hosters one-click install, since this will definitely lead into trouble.
To embed a standalone Blog to your site read http://www.s9y.org/55.html

Even the spam plugin and some other spam fighters have been enhanced over time. You will only profit when using a Serendipity version being able to update, which leads back to not use one-click installs.
Regards,
Ian

Serendipity Styx Edition and additional_plugins @ https://ophian.github.io/ @ https://github.com/ophian

User avatar
grantluc
Regular
Posts: 5
Joined: Fri Nov 30, 2012 2:06 am
Location: Adelaide South Australia
Contact:

Re: Spam Protector Plugin

Post by grantluc » Tue Oct 21, 2014 12:50 am

Thanks Ian,
Sigh.... I may have to leave things as they are.... All a little beyond me at present. The problem is that when you start out even one click installation is daunting. The one click install made me choose and learn about serendipity. As you learn more you realise what other possibilities there are and what you are missing out on by the one click installation. Problem with starting fresh with a new clean Serendipity and embedding it is that it still looks a bit beyond me. Not only do I have to mess with a bit of code to insert the "wrapper"and then more code for my plugins, then I will still need to import all of my old blog info across from the old blog to the new. In addition my RVsitebuilder built site uses lots of templates from the RVsitebuilder end with call-backs & the files are .PHP so I cannot run & check them easily on my computer like I can with HTML code. I am seasoned enough to know that this is not something I can fix in an hour or two & so may just keep a close look at my stats to see if things get worse regarding these attacks and then assess what to do on the fly.

Post Reply