spamblog (Bayes) - Admin-area - display problem with IE 10

Creating and modifying plugins.
Post Reply
Czorneboh
Regular
Posts: 381
Joined: Tue Apr 08, 2008 7:17 pm
Location: Berlin
Contact:

spamblog (Bayes) - Admin-area - display problem with IE 10

Post by Czorneboh » Tue Aug 13, 2013 11:59 pm

From the menu in the admin area, 2nd row I can see only the text for the last button "Bewertung". The 3 others I see only the frame of the rectangles.
My system: s9y 1.72, PHP 5.3.23 (right after move of the blog to another hoster/server)

User avatar
yellowled
Regular
Posts: 7037
Joined: Fri Jan 13, 2006 12:46 pm
Location: Eutin, Germany
Contact:

Re: spamblog (Bayes) - Admin-area - display problem with IE

Post by yellowled » Wed Aug 14, 2013 11:42 am

I'm not sure I get what you mean (a screenshot would help), but I just tested the admin area in 1.7.2 in IE10 (Win 7, virtual machine) and it works just fine. Did try clearing your browser cache? Is this an IE10 on Win 8? (Yes, that might make a difference.)

YL
amazon Wishlist - Serendipity-Podcast (German only, sorry)

Czorneboh
Regular
Posts: 381
Joined: Tue Apr 08, 2008 7:17 pm
Location: Berlin
Contact:

Re: spamblog (Bayes) - Admin-area - display problem with IE

Post by Czorneboh » Wed Aug 14, 2013 7:52 pm

s9y-Adminbereich-Spamschutz-Bayes-Screenshot_130813.jpg
Screenshot vom Spamschutz (Bayes)-Plugin im Admin-Bereich, 13.08.13, 23:51
s9y-Adminbereich-Spamschutz-Bayes-Screenshot_130813.jpg (45.48 KiB) Viewed 6211 times
I have used IE 10 (before the monthly Windows-security-update today) on Win 7.
Usually I do not use IE, so I can - according to this plugin - say, that there was nothing in this browser cache. I did not tried to load this again with cleaned browser cache.

User avatar
yellowled
Regular
Posts: 7037
Joined: Fri Jan 13, 2006 12:46 pm
Location: Eutin, Germany
Contact:

Re: spamblog (Bayes) - Admin-area - display problem with IE

Post by yellowled » Wed Aug 14, 2013 8:16 pm

That is exactly how it looks in Chrome, Safari and Firefox, so it's not browser-specific. I never paid any attention to these, so I'm not sure if it's supposed to look like that. Fact is, the first three cells in the table head are empty.

onli should have a look at this.

YL
amazon Wishlist - Serendipity-Podcast (German only, sorry)

Czorneboh
Regular
Posts: 381
Joined: Tue Apr 08, 2008 7:17 pm
Location: Berlin
Contact:

Re: spamblog (Bayes) - Admin-area - display problem with IE

Post by Czorneboh » Wed Aug 14, 2013 8:36 pm

These 3 empty frames are invisible in my Seamonkey browser, but if I hoover on over that area, the cursor turns to a hand. I do not think, that this makes sense.

User avatar
onli
Regular
Posts: 2231
Joined: Tue Sep 09, 2008 10:04 pm
Contact:

Re: spamblog (Bayes) - Admin-area - display problem with IE

Post by onli » Thu Aug 15, 2013 12:48 pm

Ok, I had a look.

Those empty rectangles shall be there, but they should contain the title of what is shown below (like "Date"). Something went wrong when adding the translation constants and i got used to it.

You cursor becomes a hand on these because they are clickable. When using a modern browser supporting the detail/summary-element, the blue stuff below is toggleable and invisible at first.

I just pushed an update which should add the table headers. Thanks for the report.

User avatar
Timbalu
Regular
Posts: 4598
Joined: Sun May 02, 2004 3:04 pm

Re: spamblog (Bayes) - Admin-area - display problem with IE

Post by Timbalu » Thu Aug 15, 2013 1:05 pm

Onli, maybe you should commit the better jquery check also, before the sync is running...?! :wink:
Regards,
Ian

Serendipity Styx Edition and additional_plugins @ https://ophian.github.io/ @ https://github.com/ophian

User avatar
onli
Regular
Posts: 2231
Joined: Tue Sep 09, 2008 10:04 pm
Contact:

Re: spamblog (Bayes) - Admin-area - display problem with IE

Post by onli » Thu Aug 15, 2013 1:13 pm

I have n means to test it atm, my testinstallation uses the new db-layer ;)
It is a small change, if it works for you, could you change it for me?

User avatar
Timbalu
Regular
Posts: 4598
Joined: Sun May 02, 2004 3:04 pm

Re: spamblog (Bayes) - Admin-area - display problem with IE

Post by Timbalu » Thu Aug 15, 2013 2:55 pm

Not really ATM. See board.s9y.org/viewtopic.php?f=3&t=19463&p=10436385#p10436385
It has to get checked by you as the author, which kind of jquery includement (by plugin or tpl) you want to have set as priority and if going for the latter, if that does work on both smarties, since we had differing results, AFAIR.
Regards,
Ian

Serendipity Styx Edition and additional_plugins @ https://ophian.github.io/ @ https://github.com/ophian

Czorneboh
Regular
Posts: 381
Joined: Tue Apr 08, 2008 7:17 pm
Location: Berlin
Contact:

Re: spamblog (Bayes) - Admin-area - display problem with IE

Post by Czorneboh » Sat Aug 17, 2013 10:45 am

Now the words in the rectangles are visible, but ...
You cursor becomes a hand on these because they are clickable.
If clicking on the buttons, nothing happens, anyway, whether I make a tick into the box or not.
So there is for me still no meaning on what is shown on this page.

User avatar
onli
Regular
Posts: 2231
Joined: Tue Sep 09, 2008 10:04 pm
Contact:

Re: spamblog (Bayes) - Admin-area - display problem with IE

Post by onli » Sat Aug 17, 2013 12:51 pm

onli wrote:You cursor becomes a hand on these because they are clickable. When using a modern browser supporting the detail/summary-element, the blue stuff below is toggleable and invisible at first.
;-)

The tick on the box on the other hand is the selection whether the comment shall be deleted. If none is selected, all are deleted.

Czorneboh
Regular
Posts: 381
Joined: Tue Apr 08, 2008 7:17 pm
Location: Berlin
Contact:

Re: spamblog (Bayes) - Admin-area - display problem with IE

Post by Czorneboh » Sat Aug 17, 2013 1:24 pm

you mean, ... deleted, if I klick on "empty dustbin"?

So I have clicked not on "Papierkorb leeren" - and got a white page. In the browser address field I have "http://blog.ost-impuls.de/index.php?/pl ... esRecycler"

You see in the picture I have uploaded here only one comment. Maybe this maked it more difficult to understand, what I should do here. Cleaning the dustbin, how to decide, if I sea only one comment. Are there other spam comments in the dustbin? I do not know here.

User avatar
onli
Regular
Posts: 2231
Joined: Tue Sep 09, 2008 10:04 pm
Contact:

Re: spamblog (Bayes) - Admin-area - display problem with IE

Post by onli » Sat Aug 17, 2013 2:07 pm

If there is only one comment shown, there is no other in the recycler at the moment.

The white page means normally that there was an internal server error. The expected behavior is that the comment would be gone. You should check the error log of your webserver to see why that fails.

Post Reply