new WYSIWYG-Editor event Plugin: CKEDITOR!

Creating and modifying plugins.
User avatar
Timbalu
Regular
Posts: 4598
Joined: Sun May 02, 2004 3:04 pm

Re: new WYSIWYG-Editor event Plugin: CKEDITOR!

Post by Timbalu » Mon Oct 19, 2015 5:15 pm

5.4.0:
----- :!: Edit: I made a mistake and named the zip "ckeditor_5.4.3.0-plus.zip". It should be "ckeditor_4.5.4.0-plus.zip"! If you have already run the plugin upgrade, please rename it by hand and force a deflate per plugin (Force install process (in emergencies)) option. If not, please better wait for a mirror sync next night.

Edit2: OK, the sync was done!
Regards,
Ian

Serendipity Styx Edition and additional_plugins @ https://ophian.github.io/ @ https://github.com/ophian

User avatar
Timbalu
Regular
Posts: 4598
Joined: Sun May 02, 2004 3:04 pm

Re: new WYSIWYG-Editor event Plugin: CKEDITOR!

Post by Timbalu » Mon Dec 21, 2015 11:38 am

(4.)5.6.1:
-----
  • Allows to use the Serendipity 2.0+ built-in autosave(r) with this plugin instances, if set in "Personal Preferences" by option!
    Please hard refresh your browsers in your next editor instance once, to really load the changed js file!
    Please keep in mind: This autosaving will not work with existing entries, which you want to extend with text ... only for new entries and other nuggets!
    ....
  • Maintenance upgrade to CKEDITOR 4.5. Series, update 6 (http://ckeditor.com/whatsnew)
Regards,
Ian

Serendipity Styx Edition and additional_plugins @ https://ophian.github.io/ @ https://github.com/ophian

User avatar
Timbalu
Regular
Posts: 4598
Joined: Sun May 02, 2004 3:04 pm

Re: new WYSIWYG-Editor event Plugin: CKEDITOR!

Post by Timbalu » Sat Mar 12, 2016 6:19 pm

Tomorrow on Spartacus! Please do not forget to upgrade your Plugin as soon as possible!

This version tries to internally set back the plugin version from 5.7.0 to 4.5.7.0 in the database, to follow CKEditors versioning, which gets relevant with upcoming next major versions.
Since this internal "set back" of version has the lack, that you seem to never really upgrade, since Spartacus will always mean the 5.7.0 is ready to update, I will push another update in about a week, in the hope, that all of you did upgrade in the meanwhile. Then the next real version is 4.5.7.1 or even 4.5.8.0. You can always make sure you have the last available version already, when you click the toolbar [?] button, which should say 4.5.7! (Do not forget to hard reload your Browser by [Ctrl]-[r]-[F5] before!)

(4).5.7.0:
-----
  • Allow the font awesome i(con) tag markup which also needed a little more
    care in procurator (plugin) to prevent kursive replacements.
  • Some minor internal cleanup and modernising.
  • The Plugin versioning will change to 4.5.7.0 to follow ckeditor versioning
    with next update!!
  • Upgrade to CKEDITOR 4.5. Series, update 7 (http://ckeditor.com/whatsnew).
Regards,
Ian

Serendipity Styx Edition and additional_plugins @ https://ophian.github.io/ @ https://github.com/ophian

User avatar
Timbalu
Regular
Posts: 4598
Joined: Sun May 02, 2004 3:04 pm

Re: new WYSIWYG-Editor event Plugin: CKEDITOR!

Post by Timbalu » Sun Mar 13, 2016 12:37 pm

Hm..., bad news, my try did not help, sorry! I have to set this elsewhere.
So I will update the plugin again to 5.7.1 and will set it back to 4.5.7.1, available online tomorrow.
The rest is like I said already in my last post. (Next will then be 4.5.7.2 or even 4.5.8.0)
Regards,
Ian

Serendipity Styx Edition and additional_plugins @ https://ophian.github.io/ @ https://github.com/ophian

User avatar
Timbalu
Regular
Posts: 4598
Joined: Sun May 02, 2004 3:04 pm

Re: new WYSIWYG-Editor event Plugin: CKEDITOR!

Post by Timbalu » Sat Mar 19, 2016 1:03 pm

Reminder:
Please hurry up with your upgrade to 5.7.1. I'll push the new one today or tomorrow.
Regards,
Ian

Serendipity Styx Edition and additional_plugins @ https://ophian.github.io/ @ https://github.com/ophian

Czorneboh
Regular
Posts: 380
Joined: Tue Apr 08, 2008 7:17 pm
Location: Berlin
Contact:

Re: new WYSIWYG-Editor event Plugin: CKEDITOR!

Post by Czorneboh » Sat Mar 19, 2016 8:00 pm

Done.

But if someone do not follows here and gets informed about the next update without having taken this step (update 4.5.7.1.)? Perhaps should get a warning, when clicking on Plugin updates in blog backend and sees then "update 4.5.7.2." or "update 4.5.8"? Would this be possible to show such notice?

User avatar
Timbalu
Regular
Posts: 4598
Joined: Sun May 02, 2004 3:04 pm

Re: new WYSIWYG-Editor event Plugin: CKEDITOR!

Post by Timbalu » Sun Mar 20, 2016 10:55 am

No we can't show such notice - but we will see how things go.

At the very end, when this operation on a living object has settled down, I will have to announce to everybody not having followed here to uninstall the CKEDITOR plugin in the Plugin section, remove it physically afterwards, do this and that and then install the current version. This should do then.

So if you register not getting any updates on CKEDITOR Plugin in the next half year or so via Spartacus, you should be worried to have not been operated to the downgrade version. :!:

4.5.7.2 is committed and ready by Spartacus tomorrow.
Regards,
Ian

Serendipity Styx Edition and additional_plugins @ https://ophian.github.io/ @ https://github.com/ophian

MarioH
Regular
Posts: 228
Joined: Mon Jul 20, 2009 10:53 pm
Contact:

Re: new WYSIWYG-Editor event Plugin: CKEDITOR!

Post by MarioH » Sun Mar 20, 2016 3:08 pm

Hi,

I get 4.5.7.2 today but the included ckeditor_4.5.7.1-plus.zip has only 9 bytes?

What's going wrong?

Edit: I downloaded the ckeditor_4.5.7.2-plus.zip from Github manually and unzipped it over the plugin settings. Seemed to work.


Regards
Mario

User avatar
Timbalu
Regular
Posts: 4598
Joined: Sun May 02, 2004 3:04 pm

Re: new WYSIWYG-Editor event Plugin: CKEDITOR!

Post by Timbalu » Sun Mar 20, 2016 3:33 pm

MarioH wrote:I get 4.5.7.2 today but the included ckeditor_4.5.7.1-plus.zip has only 9 bytes?
:roll: This can't be! Today and before you would get 5.7.1 via Spartacus from last week, which then internally changes to 4.5.7.1. The zip is 1.52 MB. Maybe you would get something saying it just changed name from ckeditor_4.5.7.1-plus.zip to ckeditor_4.5.7.2-plus.zip, which I needed to do to force the upgrade and downgrade routines. Tomorrow you will get the announced 4.5.7.2 version from my todays commit, which then finalizes the downgrade to properly be ready for other near future maintenance or the upcoming major upgrades in future.

MarioH wrote: Edit: I downloaded the ckeditor_4.5.7.2-plus.zip from Github manually and unzipped it over the plugin settings. Seemed to work.
Seems to work is not the question... It is a question what now is written to your pluginlist table, as the current and prior version of serendipity_event_ckeditor.
Regards,
Ian

Serendipity Styx Edition and additional_plugins @ https://ophian.github.io/ @ https://github.com/ophian

MarioH
Regular
Posts: 228
Joined: Mon Jul 20, 2009 10:53 pm
Contact:

Re: new WYSIWYG-Editor event Plugin: CKEDITOR!

Post by MarioH » Sun Mar 20, 2016 5:00 pm

This is the version displayed in the backend:
ckedit1.jpg
ckedit1.jpg (22.67 KiB) Viewed 7596 times
Last edited by MarioH on Sun Mar 20, 2016 5:03 pm, edited 1 time in total.

MarioH
Regular
Posts: 228
Joined: Mon Jul 20, 2009 10:53 pm
Contact:

Re: new WYSIWYG-Editor event Plugin: CKEDITOR!

Post by MarioH » Sun Mar 20, 2016 5:02 pm

And the database table:
ckedit2.jpg
ckedit2.jpg (14.35 KiB) Viewed 7596 times

User avatar
Timbalu
Regular
Posts: 4598
Joined: Sun May 02, 2004 3:04 pm

Re: new WYSIWYG-Editor event Plugin: CKEDITOR!

Post by Timbalu » Sun Mar 20, 2016 6:12 pm

MarioH wrote:This is the version displayed in the backend:
Yeah now after you downloaded it manually. Spartacus hasn't synced yet after my commit this morning and will run tonight. The files though may have been mirrored already.
MarioH wrote:And the database table:
Looks good.
Regards,
Ian

Serendipity Styx Edition and additional_plugins @ https://ophian.github.io/ @ https://github.com/ophian

User avatar
Timbalu
Regular
Posts: 4598
Joined: Sun May 02, 2004 3:04 pm

Re: new WYSIWYG-Editor event Plugin: CKEDITOR!

Post by Timbalu » Sun Apr 03, 2016 10:55 am

The CKE spartacus version 4.5.8.0 by tomorrow (~24h), will now follow the upgrade principles as described and had before. So this is just the normal update to the current released CKEditor version.
If you register to not get any update from tomorrow by Spartacus, please read about being worried and not operated to the downgrade of version and HOWTO solve this manually some POST before. Thanks.

4.5.8.0:
----- ________________________________________________________________________________

Since CKEditor 4.5.8.1, in April 2016, you can get all further versions via the Serendipity Styx Edition, which is a fully supported Serendipity Next installation and the Styx additional_plugins @ https://ophian.github.io/. Please regard the s9y Spartacus announced version CKEditor 4.9.0.0 as not supported and not fully synced, giving you anything, but not the announced and required version!
________________________________________________________________________________

See you at Styx!
Ian
_____________________________________________________________________

Seit CKEditor 4.5.8.1, im April 2016, werden alle folgenden Versionen mit der Serendipity Styx Edition, einer gepflegten und voll unterstützten Serendipity Next Installation und den Styx additional_plugins @ https://ophian.github.io/ ausgeliefert. Betrachtet die per s9y Spartacus ausgelieferte CKEditor 4.9.0.0 Version als nicht von mir supported und als unvollständige Synchronisierung, die euch irgendetwas, aber nicht die versprochene Version ausliefert!
________________________________________________________________________________
Last edited by Timbalu on Sat Apr 07, 2018 4:39 pm, edited 1 time in total.
Regards,
Ian

Serendipity Styx Edition and additional_plugins @ https://ophian.github.io/ @ https://github.com/ophian

Czorneboh
Regular
Posts: 380
Joined: Tue Apr 08, 2008 7:17 pm
Location: Berlin
Contact:

Re: new WYSIWYG-Editor event Plugin: CKEDITOR!

Post by Czorneboh » Wed Oct 05, 2016 12:45 pm

Hi all!

CKE version 4.5.10.5. was shown in the blog backend page "plugins" (I noticed it on 26.09.16).
I wanted to update from version 4.5.9 and have got an error message after the click on update-button:
Installer Error[1]: Extracting the zip to /var/home/schaefer/www/blog/plugins/serendipity_event_ckeditor directory failed!
Please extract ckeditor_4.5.10.3-plus.zip by hand.
Where do I get the zip file with 4.5.10.3?
What is the real last version now?
Do I need really (first) to install version 4.5.10.3, before I can install 4.5.10.5?

Has Timbalu quit support for CKEDITOR meanwhile?

I have s9y version 2.0.3 with PHP 5.6.24
Last edited by Czorneboh on Wed Oct 05, 2016 2:49 pm, edited 2 times in total.

User avatar
yellowled
Regular
Posts: 6959
Joined: Fri Jan 13, 2006 12:46 pm
Location: Eutin, Germany
Contact:

Re: new WYSIWYG-Editor event Plugin: CKEDITOR!

Post by yellowled » Wed Oct 05, 2016 2:38 pm

Disclosure: I have never used the CKE plugin myself, I'm guessing here.
Czorneboh wrote:Where do I get the zip file with 4.5.10.3?
I assume it has already been downloaded, but could not be extracted, so it should be somewhere™ in your /plugins/serendipity_event_ckeditor/.
Czorneboh wrote:What is the real last version now?
The current version of serendipity_event_ckeditor is 4.5.10.5. The current version of CK editor that this plugin installs is 4.5.10.3. I don't know if these should be equal or not, but they are different.
Czorneboh wrote:Do I need really (first) to install version 4.5.10.3, before I can install 4.5.10.5?
Again, different version numbers. Version 4.5.10.5 of the s9y plugin should install version 4.5.10.3 of CK editor. Apparently, installing that automagically did not work in your case, which is why you need to (as far as I can tell) manually unzip the zip file of CK editor. (Yes, I realize this is highly confusing.)

At this point, the best recommendation we can give is to use the version of CK editor bundled with s9y's core, which means to uninstall the plugin. I assume you're using the plugin because you want some of the extended functionality that the plugin offers, but as far as I can tell currently, the core version is more reliable and easier to use.

YL
amazon Wishlist - Serendipity-Podcast (German only, sorry)

Post Reply