Board index Plugins problem with oembed and zend.ze1

Creating and modifying plugins.
stm999999999
Regular
 
Posts: 1517
Joined: Wed Mar 08, 2006 12:25 am
Location: Berlin, Germany

Postby stm999999999 » Fri Dec 23, 2011 4:11 pm

Hi,

I installed the serendipity_event_oembed. Trying to config it, I get:

Code: Select all
Fatal error: Cannot clone object of class SimpleXMLElement due to 'zend.ze1_compatibility_mode' in /xxx/s9y/plugins/serendipity_event_oembed/oembed/ProviderList.php on line 5


any ideas?
Ciao, Stephan

User avatar
garvinhicking
Core Developer
 
Posts: 29927
Joined: Tue Sep 16, 2003 9:45 pm
Location: Cologne, Germany

Postby garvinhicking » Fri Dec 23, 2011 8:02 pm

Hi!

For what do you require the zend.ze_1_compatibility_mode setting of your PHP installation? Seems to be non compatible with many PHP applications from what I read: http://www.google.de/search?sourceid=ch ... lity_mode'

Best would be to turn that off?

Regards,
Garvin
# Garvin Hicking (s9y Developer)
# Did I help you? Consider making me happy: http://wishes.garv.in/
# or use my PayPal account "paypal {at} supergarv (dot) de"
# My "other" hobby: http://flickr.garv.in/

stm999999999
Regular
 
Posts: 1517
Joined: Wed Mar 08, 2006 12:25 am
Location: Berlin, Germany

Postby stm999999999 » Fri Dec 23, 2011 8:37 pm

I dunno why this is enabled, but i put

php_flag zend.ze1_compatibility_mode Off

in my s9y .htaccess

worked ...
Ciao, Stephan



Return to Plugins

Who is online

Users browsing this forum: No registered users and 1 guest

cron