popfetcher plugin - won't install

Creating and modifying plugins.
Post Reply
pshock
Regular
Posts: 11
Joined: Fri Apr 29, 2005 2:00 am

popfetcher plugin - won't install

Post by pshock » Tue May 10, 2005 9:17 pm

Hi,
I've just spent ages downloading every file for the popfetcher plugin.
Saving them, uploading them to the plugins directory (in the correct folder) and then trying to install the plugin.

If I understand things correctly, s9y should see that it has a new folder in the plugins directory called 'serendipity_event_popfetcher', find the php file (and others) and then give me the option to install the plugin via 'configure plugins'

It's not.

I even downloaded the complete plugin package, re-uploaded and still nothing.

Then I did a complete new-install on a spare account - and still no joy.

I guess it must be broken because two other plugins install fine.

Can anyone help please.

thanks
Kev

User avatar
garvinhicking
Core Developer
Posts: 30020
Joined: Tue Sep 16, 2003 9:45 pm
Location: Cologne, Germany
Contact:

Re: popfetcher plugin - won't install

Post by garvinhicking » Wed May 11, 2005 10:32 am

Where did you download the popfetcher files from?

Try to use those from http://www.netmirror.org/mirror/serendi ... lugins.tgz

Regards,
Garvin
# Garvin Hicking (s9y Developer)
# Did I help you? Consider making me happy: http://wishes.garv.in/
# or use my PayPal account "paypal {at} supergarv (dot) de"
# My "other" hobby: http://flickr.garv.in/

pshock
Regular
Posts: 11
Joined: Fri Apr 29, 2005 2:00 am

Post by pshock » Wed May 11, 2005 12:43 pm

Hi Garvin,
Just downloaded the plugin collection from that link you sent.
Uploaded the the popfetcher plugin folder and still no joy.

I'm not given the option to install popfetcher. It's like it doesn't exist.

regards
Kev

User avatar
garvinhicking
Core Developer
Posts: 30020
Joined: Tue Sep 16, 2003 9:45 pm
Location: Cologne, Germany
Contact:

Post by garvinhicking » Wed May 11, 2005 12:46 pm

You do have Serendipity 0.8 installed, right?

And in the list of plugins (on the page for "Click here to install a new event plugin") you don'T see it? Are you sure you click on the "Event Plugin" installation link and not the "Sidebar Plugin" link?

Regards,
Garvin
# Garvin Hicking (s9y Developer)
# Did I help you? Consider making me happy: http://wishes.garv.in/
# or use my PayPal account "paypal {at} supergarv (dot) de"
# My "other" hobby: http://flickr.garv.in/

pshock
Regular
Posts: 11
Joined: Fri Apr 29, 2005 2:00 am

Post by pshock » Wed May 11, 2005 2:08 pm

You do have Serendipity 0.8 installed, right?
- You are correct.

And in the list of plugins (on the page for "Click here to install a new event plugin") you don'T see it?
- Correct again - There is nothing called 'popfetcher' - even in a brand new installation.
Are you sure you click on the "Event Plugin" installation link and not the "Sidebar Plugin" link?
- I'm 100% certain.

Could you try it or would you like me to PM you some access details so you can see for yourself.

I may be missing something but I can't work out what.

rgds
Kev

User avatar
garvinhicking
Core Developer
Posts: 30020
Joined: Tue Sep 16, 2003 9:45 pm
Location: Cologne, Germany
Contact:

Post by garvinhicking » Wed May 11, 2005 2:10 pm

Pshock, actually yes this would be the easiest way if you could give me FTP access and a serendipity account to your blog, then I can look after it. Please send the details via PM! :)

Regards,
Garvin
# Garvin Hicking (s9y Developer)
# Did I help you? Consider making me happy: http://wishes.garv.in/
# or use my PayPal account "paypal {at} supergarv (dot) de"
# My "other" hobby: http://flickr.garv.in/

pshock
Regular
Posts: 11
Joined: Fri Apr 29, 2005 2:00 am

Post by pshock » Wed May 11, 2005 2:29 pm

Details PM'd over - many Thanks
Kev

User avatar
garvinhicking
Core Developer
Posts: 30020
Joined: Tue Sep 16, 2003 9:45 pm
Location: Cologne, Germany
Contact:

Post by garvinhicking » Wed May 11, 2005 3:39 pm

I was able to find the bug!

The cause was a wrong version requirement comparison because the popfetcher plugin did not specify a PHP version requirement, and your PHP version crashed on the version_compare() logic.

This means there were two sad coincidences (a PHP bug and a Serendipity bug) which interfered here. I patched your installation so that it works, and committed the patch for our upcoming 0.8.1 version as well :)

Regards,
Garvin
# Garvin Hicking (s9y Developer)
# Did I help you? Consider making me happy: http://wishes.garv.in/
# or use my PayPal account "paypal {at} supergarv (dot) de"
# My "other" hobby: http://flickr.garv.in/

pshock
Regular
Posts: 11
Joined: Fri Apr 29, 2005 2:00 am

Post by pshock » Wed May 11, 2005 3:45 pm

Garvin,
As always a superb service. Thank you so much.
If only MS could match it life would be a breeze.
I'm so glad you're there.

Thanks again

Kev

Post Reply