Nach Update auf 0.8-alpha9 keine Plugins installierbar

Found a bug? Tell us!!
Post Reply
User avatar
Oliver
Regular
Posts: 178
Joined: Mon Jan 10, 2005 7:43 pm
Location: Herne, Germany
Contact:

Nach Update auf 0.8-alpha9 keine Plugins installierbar

Post by Oliver » Tue Jan 11, 2005 2:31 am

Hallo,

habe vorhin mit Ach und Krach (!) das Update auf die 0.8-alpha9 gemacht, erst ging nichts mehr (konnte Dateien nicht schreiben), nach einer knappen Stunde Arbeit funktionierte mein Blog aber dafür mein Template nicht mehr, was ich mit dem Löschen der Layout.php aber beheben konnte. Trackback- und Kommentar-Popups gehen auch nicht mehr (liegt wohl an meinem Template). Dann funktionierte das Date List Plugin nicht mehr, also habe ich das (über das ACP) entfernt. Nun versuche ich irgend ein anderes Plugin zu installieren und bekomme jedesmal folgenden Fehler:

Code: Select all

Fehler: 
Notice: Undefined index: customURI in /is/htdocs/bzz/www.*****.de/mods/s9y/include/admin/plugins.inc.php on line 562
@serendipity_archives_plugin:aa96eca8801959b18c07a87ececabcca ()

Fatal error: Call to a member function on a non-object in /is/htdocs/bzz/www.*****.de/mods/s9y/include/admin/plugins.inc.php on line 614


Rufe ich dann die Plugin-Liste wieder auf, wird das letzte funktionierende Plugin (ein HTML-Nugget) doppelt angezeigt, einmal mit der Unterschrift Fehler!. Das passiert auch nur bei diesen 'Sidebar-Plugins'.

Gehe ich dann auf die Blog-Index-Seite, erhalte ich in der rechten Spalte folgende Meldung:

Code: Select all

Fehler
Serendipity Fehler: Kann Datei
Notice: Undefined index: customURI in /is/htdocs/bzz/www.*****.de/mods/s9y/include/admin/plugins.inc.p nicht einbinden - wird beendet.


Was ist schief gelaufen?

Noch zur Info: Ich habe nicht gewusst, daß Dateien auf CHMOD777 stehen müssen, damit ich ein Update von 0.7.1 auf 0.8-alpha9 machen kann. Die Meldung bekam ich nach Abschluss des Updatevorgangs sowie den Hinweis, daß die DB jedoch korrekt aktualisiert wurde.

Nachdem der erste Ärger verraucht war, habe ich sämtliche Dateien auf meinem Webspace gelöscht, also Dateien meiner 0.7.1-Installation sowie des Upgrades, funktionierte ja nichts mehr. Habe dann die Dateien der 0.8-alpha9 hochgeladen und mein Blog erneut aufgerufen, es startete der Installationsvorgang, die Software erkannte, daß die DB nicht mehr aktualisiert werden muss. Und nun scheint mein Blog bis auf oben genannten Fehler zu laufen.


Ich krieg' Hörner :twisted: :wink:

[EDIT] Habe GSD Backups gemacht, werde meine Version 0.7.1 wieder zurückspielen :) [/EDIT]

Viele Grüße,

- Oliver

Ps.: Habe nichts über die Suche gefunden, daher ein neues Topic.
Image

User avatar
garvinhicking
Core Developer
Posts: 30020
Joined: Tue Sep 16, 2003 9:45 pm
Location: Cologne, Germany
Contact:

Re: Nach Update auf 0.8-alpha9 keine Plugins installierbar

Post by garvinhicking » Tue Jan 11, 2005 12:13 pm

Hallo Oliver!

Der Fehler mit den Plugins lag an einem undefinierten Index; üblicherweise werden solche Fehlermeldungen nicht gezeigt, da ist dein PHP-Setup wohl sehr "untolerant" eingestellt. Den Fehler habe ich im CVS jedenfalls gerade beheben können.

Da sich von 0.7.1 auf 0.8 im Template-Bereich einiges geändert hat (gerade bei "eigenen" Templates, kann es schon sein, dass dadurch Aufwand entsteht. Vor dem 0.8 final release werden wir ein "HowTo"-Dokument vorbereiten. Könntest Du Deine layout.php mal vorzeigen, dann kann ich sehen was davon Probleme verursachen könnte und das vor dem Release noch verbessern.

Das Update von 0.7.1 auf 0.8 braucht nicht zwangsläufig Schreibrechte auf alle Dateien. Es werden nur überflüssige Dateien gelöscht, wenn das nicht klappt, ist es nicht tragisch diese Dateien noch zu haben.

Tut mir sehr leid, dass Du mit dem Update so viele Probleme gehabt hast. Wir können aus den Erfahrungen jedoch die Software noch verbessern und hoffen, dass wir das gemeinsam in den Griff kriegen. :)

Viele Grüße,
Garvin
# Garvin Hicking (s9y Developer)
# Did I help you? Consider making me happy: http://wishes.garv.in/
# or use my PayPal account "paypal {at} supergarv (dot) de"
# My "other" hobby: http://flickr.garv.in/

User avatar
Oliver
Regular
Posts: 178
Joined: Mon Jan 10, 2005 7:43 pm
Location: Herne, Germany
Contact:

Re: Nach Update auf 0.8-alpha9 keine Plugins installierbar

Post by Oliver » Tue Jan 11, 2005 4:01 pm

garvinhicking wrote:Das Update von 0.7.1 auf 0.8 braucht nicht zwangsläufig Schreibrechte auf alle Dateien. Es werden nur überflüssige Dateien gelöscht, wenn das nicht klappt, ist es nicht tragisch diese Dateien noch zu haben.

Tut mir sehr leid, dass Du mit dem Update so viele Probleme gehabt hast. Wir können aus den Erfahrungen jedoch die Software noch verbessern und hoffen, dass wir das gemeinsam in den Griff kriegen. :)


Ich werde Ende der Woche nochmal ein Update versuchen, genauso, wie ich es heute morgen bzw. gestern abend gemacht habe, dann kann ich Dir die Fehlermeldung nennen, die ich bekommen habe und nach der nichts mehr ging, leider habe ich dummerweise vergessen, die aufzuschreiben, so daß ich Dir noch nichteinmal mehr sagen, was schief gelaufen ist.

Die Layout.php werde ich heute abend bzw. morgen einmal hier als *.txt oder *.phps verlinken, dann kannst Du mal schauen :-)

Danke für Deine Hilfe :-)

Viele Grüße,

Oliver
Image

User avatar
garvinhicking
Core Developer
Posts: 30020
Joined: Tue Sep 16, 2003 9:45 pm
Location: Cologne, Germany
Contact:

Re: Nach Update auf 0.8-alpha9 keine Plugins installierbar

Post by garvinhicking » Tue Jan 11, 2005 4:08 pm

Hi Oliver!

Okay, dann mach das mal. Die diversen Meldungen dass eine Datie nicht gelöscht/geschrieben werden konnte, ist die, die ich als unerheblich empfinde. :)

Und deine layout.php schaue ich mir dann gerne an, und hoffe, dass ich da
helfen kann.

Viele Grüße,
Garvin
# Garvin Hicking (s9y Developer)
# Did I help you? Consider making me happy: http://wishes.garv.in/
# or use my PayPal account "paypal {at} supergarv (dot) de"
# My "other" hobby: http://flickr.garv.in/

zERo
Regular
Posts: 7
Joined: Sat Jan 08, 2005 10:22 am
Location: Tokyo, Japan
Contact:

Post by zERo » Wed Jan 26, 2005 10:53 am

Hey ho,

habe auch mal das Update auf 0.8 beta 9 gemacht.

Beim Hinzufügen von Plugins und auch Events bekomme ich
keine Fehlermeldung und es wird angezeigt, dass es ordnungsgemäß
gespeichert wurde.

Allerdings erscheint dann nichts der neu hinzugefügten Sachen in den Listen
und floglich auch nicht auf der Seite.

Bekomme aber wie gesagt keine Error-Message oder sonstiges ...

User avatar
garvinhicking
Core Developer
Posts: 30020
Joined: Tue Sep 16, 2003 9:45 pm
Location: Cologne, Germany
Contact:

Post by garvinhicking » Wed Jan 26, 2005 11:28 am

Vermutlich sind bei dem Upgrade von Dir ein paar SQL Dateien nicht ausgeführt worden.

Bitte prüfe mal, ob Deine Datenbank Tabellenstruktur so aussieht, wie in der sql/db.sql beschrieben. Eventuell fehlt der "serendipity_plugins" tabelle die "path" Zeile?

Grüße,
Garvin
# Garvin Hicking (s9y Developer)
# Did I help you? Consider making me happy: http://wishes.garv.in/
# or use my PayPal account "paypal {at} supergarv (dot) de"
# My "other" hobby: http://flickr.garv.in/

Post Reply