Page 1 of 1

Trackbacks to own blog no longer working

Posted: Mon May 25, 2020 9:33 am
by brucecy92
Hi!

In my blog, I often refer (and link) to older blogposts such that these get a trackback entry to a follow-up post.

However, this is no longer working: I always get a "trackback successful", but in the Comments section of the backend nothing new shows up. How can I debug this?

I have problems with this since a long time already, and I always thought it might have something to do with using https on the backend (writing and publishing articles) vs. http on the frontend. I often tried to switch to http before publishing an article, and sometimes this fixed that behavior. I tried a lot recently, disabling anti-spam plugins, moving the trackback control up in the list, changing settings, adding URLs in the Trackback Control section. I won't provide a load of config lists/settings here unless requested, as I wouldn't know where to start. What details should I provide?

Thanks

Re: Trackbacks to own blog no longer working

Posted: Mon May 25, 2020 6:45 pm
by onli
That's likely the spamblock plugin eating the trackback. Make sure that the setting "Spamblock -> Trackbacks -> IP Validation" is not set to reject, but to moderate. Also API-comments should not be rejected, and the IP-Block Intervall could be set to 0. Go through the settings a bit, that's likely it. To debug you could activate the log file of the spamblock plugin and see whether future trackbacks are mentioned in there.
brucecy92 wrote:
Mon May 25, 2020 9:33 am
it might have something to do with using https on the backend (writing and publishing articles) vs. http on the frontend
Regardless of the trackback issue, not using https in the whole blog is a security risk and it will lead to worse rankings in Google. Maybe you could change that? And maybe it even helps with the trackbacks?