Internal Server Error after upgrade to 2.3.4

Found a bug? Tell us!!
Post Reply
Niclas
Regular
Posts: 61
Joined: Fri Aug 29, 2008 3:54 pm
Location: Frankfurt / Germany

Internal Server Error after upgrade to 2.3.4

Post by Niclas » Wed Apr 01, 2020 11:02 pm

I had upgraded from 2.1.4 to 2.3.2 because off having issues with the non working "Submit" button. As a result I wasn't able to logon to the backend anymore while the frontend was still fully operable. Today I made an upgrade to 2.3.4 and the upgrade assistant recognized that and showed everything in green. Thus I executed it and now receive an error message:

"Internal Server Error. The server encountered an internal error or misconfiguration and was unable to complete your request."

I already overwrote everything with my 2.3.2 backup but that didn't change a thing. I also edited the serendipity_config.inc.php since it still said 2.3.2. But after having entered 2.3.4 to it the error stays the same.

I don't have any access to server logs, PHP configuration and so, but only to my user's FTP directory and so am not able to check for logged errors.

*EDIT* After having deleted everything from the directory and having uploaded my backup I now see:

Index of /blogbox

and a list of directories, showing only "templates".
When I click on it, it says: Keine Schreibrechte für Verzeichnis /home/.../blogbox/templates_c/. Bitte korrigieren

But when I check "templates_c" I see that I do have permissions and the directory contains all files as my backup does.

User avatar
onli
Regular
Posts: 2388
Joined: Tue Sep 09, 2008 10:04 pm
Contact:

Re: Internal Server Error after upgrade to 2.3.4

Post by onli » Wed Apr 01, 2020 11:49 pm

Sorry, but without the error log it's very unlikely we will find the issue. 500 error just says that something went wrong, but gives no hint to what exactly failed. Are you sure the hoster will not give you access to logs or tell you the error message?

What you can try is to delete all plugins, the files under plugins/. That way, if the error comes from a plugin it won't get executed and the error may be avoided. Might be good to have a backup of them, if it does not help I'd restore the plugins and ask your hoster to tell you the error message.

Niclas
Regular
Posts: 61
Joined: Fri Aug 29, 2008 3:54 pm
Location: Frankfurt / Germany

Re: Internal Server Error after upgrade to 2.3.4

Post by Niclas » Wed Apr 01, 2020 11:57 pm

I will contact them, but I just saw a severe mistake of mine! I accidentially copied everything back into the only remaining folder "template". This way it cannot work. :)
Just deleting everything again and will then copy my backup into the empty directory - again.

Niclas
Regular
Posts: 61
Joined: Fri Aug 29, 2008 3:54 pm
Location: Frankfurt / Germany

Re: Internal Server Error after upgrade to 2.3.4

Post by Niclas » Thu Apr 02, 2020 12:19 am

Lustig! Nach dem Leeren des kompletten Verzeichnisses und dem Einspielen meiner Sicherung, klappt jetzt alles wieder - einschließlich der Anmeldung am Backend!! Das ging wie erwähnt davor nicht! Was auch immer das jetzt ermöglicht hat?! Es befinden sich ja jetzt wieder 1 zu 1 dieselben Daten im Verzeichnis. :?: :roll:

Werde dann morgen nochmal ein Upgrade auf 2.3.4 testen.

User avatar
onli
Regular
Posts: 2388
Joined: Tue Sep 09, 2008 10:04 pm
Contact:

Re: Internal Server Error after upgrade to 2.3.4

Post by onli » Fri Apr 03, 2020 1:39 pm

Well, at least it works :) Keep us posted whether the 2.3.4 upgrade works now!

Niclas
Regular
Posts: 61
Joined: Fri Aug 29, 2008 3:54 pm
Location: Frankfurt / Germany

Re: Internal Server Error after upgrade to 2.3.4

Post by Niclas » Mon Apr 06, 2020 2:38 pm

Hi all, nearly the same story again.

- Adding images to blogposts failed again, because off submit buttons not working (like before)
- Upgrade to 2.3.4 fails again. Integrity check shows all green and cofirms a complete setup. Afterwards the page stays white. No error message, no content, nothing.

User avatar
onli
Regular
Posts: 2388
Joined: Tue Sep 09, 2008 10:04 pm
Contact:

Re: Internal Server Error after upgrade to 2.3.4

Post by onli » Mon Apr 06, 2020 4:10 pm

White page -> Internal 500 error that does not get reported. No way around getting the error message, sorry.

Post Reply