Page 1 of 1

does new PHP 7.X break anything?

Posted: Mon Mar 11, 2019 9:03 pm
by rootnl2k
Getting Your browser did not sent a valid HTTP-Referrer string. This may have either been caused by a misconfigured browser/proxy or by a Cross Site Request Forgery (XSRF) aimed at you. The action you requested could not be completed. and running Serendipity 2.1.4 and PHP 7.2.16 . phpinfo available from https://secure.nl2k.ab.ca/phpinfo.phtml . Tried to add an etnry just now and this error is baffling me.

Re: does new PHP 7.X break anything?

Posted: Mon Mar 11, 2019 10:59 pm
by onli
In the current git master I fixed a bug in the "remember me" function. But I thought that bug got introduced when updating gow that autologin cookie works, and that should not be in 2.1.4 yet.

Try to logout and login again, this time without the "Remember Me" function being activated.

Re: does new PHP 7.X break anything?

Posted: Fri Mar 22, 2019 5:52 pm
by rootnl2k
I never use the Remember Me function. What else could it be?