Break inserter before table

Found a bug? Tell us!!
Post Reply
Huhu
Regular
Posts: 115
Joined: Tue Oct 04, 2011 3:22 pm

Break inserter before table

Post by Huhu » Fri Apr 29, 2016 11:30 am

Again, a strange thing: When inserting a plain HTML table in the standard plaintext editor, it inserts a huge number of .br tags. No idea why ...
The code is quick-pasted from a Joomla editor entry, not handwritten.
Anyone?
Skärmavbild 2016-04-29 kl. 11.29.49.jpg
Skärmavbild 2016-04-29 kl. 11.29.49.jpg (31.1 KiB) Viewed 1387 times
Skärmavbild 2016-04-29 kl. 11.31.00.jpg
Skärmavbild 2016-04-29 kl. 11.31.00.jpg (50.79 KiB) Viewed 1386 times
Last edited by Huhu on Fri Apr 29, 2016 1:00 pm, edited 1 time in total.
Fan of post-apocalyptic Jugger: Free ebook on the sport

User avatar
onli
Regular
Posts: 2229
Joined: Tue Sep 09, 2008 10:04 pm
Contact:

Re: Break inserter before table

Post by onli » Fri Apr 29, 2016 12:34 pm

That's the nl2br plugin. Set it in its configuration to the p-mode or deactivate it with the advanced settings in the entry editor (provided by the entryproperties-plugin) for that specific entry to workaround that.

Huhu
Regular
Posts: 115
Joined: Tue Oct 04, 2011 3:22 pm

Re: Break inserter before table

Post by Huhu » Fri Apr 29, 2016 1:00 pm

That has been it! Great. Thanks!
Now I even understand why it behaves so :)
Fan of post-apocalyptic Jugger: Free ebook on the sport

User avatar
Timbalu
Regular
Posts: 4598
Joined: Sun May 02, 2004 3:04 pm

Re: Break inserter before table

Post by Timbalu » Fri Apr 29, 2016 3:13 pm

There are even some more options for this sort of problem:
  • If using the PLAIN TEXT Editor, you can also use the NoBr Button to surround text parts, which shall not react on NL2BR (like tables).
  • The other option is using the WYSIWYG-Editor (CKEditor), which will not run NL2BR automatically with Serendipity 2.0.1+ versions.
Regards,
Ian

Serendipity Styx Edition and additional_plugins @ https://ophian.github.io/ @ https://github.com/ophian

Post Reply