2.0 Syndication issues

Found a bug? Tell us!!
Post Reply
User avatar
Timbalu
Regular
Posts: 4598
Joined: Sun May 02, 2004 3:04 pm

2.0 Syndication issues

Post by Timbalu » Sun Jan 25, 2015 2:21 pm

For upgraders - the new syndication plugin uses subtome.com as default. Why is that forced to all?
If you do not want this, return to the plugins configuration.

I btw found this
http://blog.s9y.org/feeds/index.rss2
working well,
but the atom does not, or only partial.
http://blog.s9y.org/feeds/atom10.rss

Is that somehow buggy, maybe ...? In prior times I found the atom feed was quite usefull .. and not too strict...
Regards,
Ian

Serendipity Styx Edition and additional_plugins @ https://ophian.github.io/ @ https://github.com/ophian

User avatar
yellowled
Regular
Posts: 7083
Joined: Fri Jan 13, 2006 12:46 pm
Location: Eutin, Germany
Contact:

Re: 2.0 Syndication issues

Post by yellowled » Sun Jan 25, 2015 3:31 pm

Timbalu wrote:Why is that forced to all?
http://board.s9y.org/viewtopic.php?p=10439716#p10439716
Timbalu wrote:Is that somehow buggy, maybe ...? In prior times I found the atom feed was quite usefull .. and not too strict...
Seems like there's a stray < or a missing > in the markup which leads to this atom validation error. However, I don't see it.

http://validator.w3.org/feed/check.cgi? ... atom10.rss

The W3C atom validator says:
The most common cause is encoding errors. There are several basic approaches to solving this: escaping problematic characters (< becomes <, & becomes &, etc.), escaping entire blocks of text with CDATA sections, or putting an encoding declaration at the start of the feed.
Hmmm. There is

Code: Select all

<?xml version="1.0" encoding="utf-8" ?>
at the start of the feed …

YL
amazon Wishlist - Serendipity-Podcast (German only, sorry)

User avatar
yellowled
Regular
Posts: 7083
Joined: Fri Jan 13, 2006 12:46 pm
Location: Eutin, Germany
Contact:

Re: 2.0 Syndication issues

Post by yellowled » Sun Jan 25, 2015 3:32 pm

Interestingly enough, http://yellowled.de/feeds/atom.xml produces the same error, so I guess it's highly unlikely that this is related to the blog's content but rather a formal error in all atom feeds generated by s9y blogs …

YL
amazon Wishlist - Serendipity-Podcast (German only, sorry)

User avatar
Timbalu
Regular
Posts: 4598
Joined: Sun May 02, 2004 3:04 pm

Re: 2.0 Syndication issues

Post by Timbalu » Sun Jan 25, 2015 3:53 pm

yellowled wrote:
Timbalu wrote:Why is that forced to all?
http://board.s9y.org/viewtopic.php?p=10439716#p10439716
Is that an answer? I remember to have read this, and thought the image to be used as the default and using the subtome link only for new installations. But currently this silently just updates the old. And I at least wanted to note this here for our users, in case anyone does not check all there is to come.
yellowled wrote:Interestingly enough, http://yellowled.de/feeds/atom.xml produces the same error, so I guess it's highly unlikely that this is related to the blog's content but rather a formal error in all atom feeds generated by s9y blogs …

Yes, I also checked different sites for atom, thats why I wrote "partial or not"...
Regards,
Ian

Serendipity Styx Edition and additional_plugins @ https://ophian.github.io/ @ https://github.com/ophian

User avatar
yellowled
Regular
Posts: 7083
Joined: Fri Jan 13, 2006 12:46 pm
Location: Eutin, Germany
Contact:

Re: 2.0 Syndication issues

Post by yellowled » Sun Jan 25, 2015 4:55 pm

Timbalu wrote:Is that an answer?
Technically, it is a link to the discussion about it, more specifically to a post in which Garvin states that he is fine with making the subtome button a default. Which practically answers your original question why this is active by default since 2.0.

Although one could of course argue that the more correct answer would be “because no one wanted to argue about it any longer as long as people would be able to deactivate it”. However, I chose not to state that in my last post since it seemed like a biased opinion which often leads to misunderstandings in technical discussions on the web.
Timbalu wrote:Yes, I also checked different sites for atom, thats why I wrote "partial or not"...
You actually wrote “not, or only partial”, which I interpreted as “the atom feed does not work or only works up to a certain point”.

Anyway, examples for the Atom 1.0 format state that

Code: Select all

<?xml version="1.0" encoding="utf-8"?>
is okay to have, so that's probably not it. Another guess could be that the <img> element in the feed is not in XML syntax (which would be <img … />, self-closing tag). My atom feed, however, fails to validate because it includes a non-XHTML-element (<figcaption>), so I suppose that's not the common source of error here.

YL
amazon Wishlist - Serendipity-Podcast (German only, sorry)

bernd_d
Regular
Posts: 466
Joined: Thu Jun 03, 2010 9:28 am
Contact:

Re: 2.0 Syndication issues

Post by bernd_d » Sun Jan 25, 2015 5:16 pm

yellowled wrote:Another guess could be that the <img> element in the feed is not in XML syntax (which would be <img … />, self-closing tag). My atom feed, however, fails to validate because it includes a non-XHTML-element (<figcaption>), so I suppose that's not the common source of error here.
I've tried it now for my own because first i got this error too after the img-tag. After setting the slash, the error jumps to another line, now it matches an iframe. So, seems to be another problem.

User avatar
yellowled
Regular
Posts: 7083
Joined: Fri Jan 13, 2006 12:46 pm
Location: Eutin, Germany
Contact:

Re: 2.0 Syndication issues

Post by yellowled » Sun Jan 25, 2015 6:28 pm

Here's a thought: I can subscribe to both the s9y and my blog's atom feeds in a feed reader just fine. No errors, the content of both entries is displayed fully – in the feed reader.

RSS or Atom feeds are not really “meant” to be opened in a browser. Also, with HTML5 (related to the issue with my feed in the validator), the spec would often evolve quicker than even the W3C validators were updated. At times, things that were perfectly valid HTML5 would be flagged by the HTML validator just because it didn't know about the new element yet.

So maybe (just thinking out loud here) there's nothing really wrong with these Atom feeds?

YL
amazon Wishlist - Serendipity-Podcast (German only, sorry)

User avatar
onli
Regular
Posts: 2260
Joined: Tue Sep 09, 2008 10:04 pm
Contact:

Re: 2.0 Syndication issues

Post by onli » Mon Jan 26, 2015 12:54 pm

I think we are doing the atom feed wrong. We are saying the content shall be xhtml, but it is of course not. We should set it to encoded html like with RSS2. However, as long as it is working in feed readers, I personally won't dare to touch that area.

We just made the atom feed a bit less visible anyway.

Carl @ ATS
Regular
Posts: 55
Joined: Fri Jun 07, 2013 11:41 am
Location: Fürstenfeldbruck, Germany
Contact:

Re: 2.0 Syndication issues

Post by Carl @ ATS » Sun Jun 07, 2015 12:49 pm

Dear all,

I installed version 2.0.1 of Serendipity yesterday and everything went smoothly - thanks very much for that. There seems to be a small bug in the syndication plugin, however, as what visitors can now see has changed and is not what it ought to be - the feed image is repeated twice for each feed rather than just once (see the attached screen shot). The other screen shot shows my current settings. What needs to be changed, please?

Regards,

Carl
Attachments
syndication_plugin_settings.png
my current plug-in settings
syndication_plugin_settings.png (39.12 KiB) Viewed 3564 times
syndication_plugin_appearance.png
appearance on the blog
syndication_plugin_appearance.png (7.31 KiB) Viewed 3564 times

User avatar
Timbalu
Regular
Posts: 4598
Joined: Sun May 02, 2004 3:04 pm

Re: 2.0 Syndication issues

Post by Timbalu » Sun Jun 07, 2015 4:12 pm

Yepp true, this hasn't been checked for bulletproof needs yet.
Temporary disable both styles in blue_style.css and change "img/xml.png" to "img/blue_xml.png" in the syndication plugin config. (Though this would not allow to switch themes. Or stick to have them coloured orange like the origin.)

Code: Select all

.serendipity_xml_icon {
    background: url('img/blue_xml.png') center center no-repeat;
    padding: 10px 0;
    margin: 0;
    visibility: visible;
}

 .serendipity_xml_icon img {
    visibility: hidden;
}
Regards,
Ian

Serendipity Styx Edition and additional_plugins @ https://ophian.github.io/ @ https://github.com/ophian

User avatar
yellowled
Regular
Posts: 7083
Joined: Fri Jan 13, 2006 12:46 pm
Location: Eutin, Germany
Contact:

Re: 2.0 Syndication issues

Post by yellowled » Mon Jun 08, 2015 10:25 am

I have tried to reproduce this with your settings for the syndication plugin in my dev blog, which runs on a current git checkout of 2.x. So it's a tad newer than your 2.0.1 installation, but I don't think there have been any significant updates to the syndication plugin since the 2.0.1 release.

I can't reproduce your issue, neither in a current theme nor in BP. Also, your blog seems to emit markup for the syndication plugin that the current version does not. That leads me to believe that you may have a 2.0.1 update which did not update the syndication plugin properly.

First of all, please go to the plugins page in your backend and click on the little arrow icon for the syndication plugin. Which version does it state there?

YL
amazon Wishlist - Serendipity-Podcast (German only, sorry)

User avatar
yellowled
Regular
Posts: 7083
Joined: Fri Jan 13, 2006 12:46 pm
Location: Eutin, Germany
Contact:

Re: 2.0 Syndication issues

Post by yellowled » Mon Jun 08, 2015 10:41 am

yellowled wrote:I have tried to reproduce this with your settings for the syndication plugin in my dev blog, which runs on a current git checkout of 2.x.
Nevermind, I'm dumb. My dev blog does not run on 2.x. Sorry. Monday. :roll:

YL
amazon Wishlist - Serendipity-Podcast (German only, sorry)

Carl @ ATS
Regular
Posts: 55
Joined: Fri Jun 07, 2013 11:41 am
Location: Fürstenfeldbruck, Germany
Contact:

Re: 2.0 Syndication issues

Post by Carl @ ATS » Mon Jun 08, 2015 3:54 pm

Hi Ian,

Thanks for your advice, but I'm only a novice when it comes to PHP, so I need a bit more clarity, please. If I change "visible" to "hidden" in blue_style.css in my bulletproof template, then the blue images and the descriptions (obviously) disappear from view. I don't think that's what you meant...

.................

CODE: SELECT ALL
.serendipity_xml_icon {
background: url('img/blue_xml.png') center center no-repeat;
padding: 10px 0;
margin: 0;
visibility: hidden;
}

.serendipity_xml_icon img {
visibility: hidden;
}

.................

What do I need to do to get a single feed image to appear in my blog? I don't mind what colour it is - blue, orange or whatever - as long as it gets displayed properly. Ideally regardless of the skins used on an s9y blog, but that will take a while to sort out, I gather.

(As an aside, has a time frame been set yet to adapt and/or debug all the old plug-ins so they all work smoothly with version 2 of serendipity?)

User avatar
Timbalu
Regular
Posts: 4598
Joined: Sun May 02, 2004 3:04 pm

Re: 2.0 Syndication issues

Post by Timbalu » Mon Jun 08, 2015 5:12 pm

The solution I posted above was only meant temporary. It suggested to wrap /* ... */ around the two stylesheet rules I posted, in the blue_style.css file.

But I think it is better to fix the real cause of this issue:

Open up /plugins/serendipity_plugin_syndication/serendipity_plugin_syndication.php file, scroll down to the function generateFeedButton(.... on line 204 and replace it with this:

Code: Select all

    function generateFeedButton($feed, $label, $onclick, $icon) {
        $link    = 'href="'.$feed.'" '. $onclick;
        $xmlicon = $icon ? $icon : serendipity_getTemplateFile($this->get_config('iconURL', 'img/xml.gif'));
        $output  = "<li>\n";
        $output .= '<a class="serendipity_subtome serendipity_xml_icon" ' . $link . '><img src="' . $xmlicon . '" alt="XML" style="border: 0px" /></a>'."\n";
        if (! empty($label)) {
            $output .= " <a $link>$label</a>\n";
        }
        return $output .= "</li>\n";
    }
If that helps, we'll fix syndication for 2.0.2
Carl @ ATS wrote:(As an aside, has a time frame been set yet to adapt and/or debug all the old plug-ins so they all work smoothly with version 2 of serendipity?)
Apart from staticpages, what do you have in mind?
Regards,
Ian

Serendipity Styx Edition and additional_plugins @ https://ophian.github.io/ @ https://github.com/ophian

Carl @ ATS
Regular
Posts: 55
Joined: Fri Jun 07, 2013 11:41 am
Location: Fürstenfeldbruck, Germany
Contact:

Re: 2.0 Syndication issues

Post by Carl @ ATS » Tue Jun 09, 2015 10:08 am

Morning Ian,

Thanks very much for your advice. It's worked - now the feed titles are displayed with a single icon in the Bulletproof skin. :D

Best regards,

Carl

Post Reply