[resolved] [2.0-beta6] Media Library broken

Found a bug? Tell us!!
Post Reply
User avatar
Dergln
Regular
Posts: 54
Joined: Thu Jun 23, 2011 8:18 pm
Location: Hessen
Contact:

[resolved] [2.0-beta6] Media Library broken

Post by Dergln » Mon Nov 17, 2014 9:13 pm

Hi,

don't know what I might be doing wrong, but I can't get it to work as expected.
Directories like
/
/uploads
777 doesn't change behaviour (-r 777 doesn't too).
Powered by Serendipity 2.0-beta6 and PHP 5.4.34-nmm1
Call "Go" under "Add Media"

Code: Select all

Fatal error:  Uncaught exception 'ErrorException' with message 'escapeshellcmd() has been disabled for security reasons' in /www/htdocs/***************/s9y/include/compat.inc.php:126
Stack trace:
#0 [internal function]: errorToExceptionHandler(2, 'escapeshellcmd(...', '/www/htdocs/w00...', 677, Array)
#1 /www/htdocs/***************/s9y/include/functions_images.inc.php(677): escapeshellcmd('/usr/bin/conver...')
#2 /www/htdocs/***************/s9y/include/admin/images.inc.php(330): serendipity_makeThumbnail('6-12748012723e7...', '', '400', 'serendipityThum...')
#3 /www/htdocs/***************/s9y/serendipity_admin.php(126): include('/www/htdocs/w00...')
#4 {main}
  thrown in /www/htdocs/***************/s9y/include/compat.inc.php on line 126
Call it again, same error.
File is added on the FS though !

Call "Media Library"

Code: Select all

Fatal error:  Uncaught exception 'ErrorException' with message 'escapeshellcmd() has been disabled for security reasons' in /www/htdocs/***************/s9y/include/compat.inc.php:126
Stack trace:
#0 [internal function]: errorToExceptionHandler(2, 'escapeshellcmd(...', '/www/htdocs/***...', 677, Array)
#1 /www/htdocs/***************/s9y/include/functions_images.inc.php(677): escapeshellcmd('/usr/bin/conver...')
#2 /www/htdocs/***************/s9y/include/functions_images.inc.php(1567): serendipity_makeThumbnail('129169617562464...', '2014/11/')
#3 /www/htdocs/***************/s9y/include/admin/images.inc.php(715): serendipity_displayImageList(1, 2, true, NULL, false, NULL, Array)
#4 /www/htdocs/***************/s9y/include/admin/images.inc.php(678): showMediaLibrary()
#5 /www/htdocs/***************/s9y/serendipity_admin.php(126): include('/www/htdocs/***...')
#6 {main}
  thrown in /www/htdocs/***************/s9y/include/compat.inc.php on line 126
Call it another time, ok.

Still it does not find any images anywhere ! Folder navigation is fine on the other hand.

Greetings
Oliver
Last edited by Dergln on Tue Nov 18, 2014 9:49 pm, edited 1 time in total.

User avatar
Timbalu
Regular
Posts: 4598
Joined: Sun May 02, 2004 3:04 pm

Re: [2.0-beta6] Media Library broken

Post by Timbalu » Tue Nov 18, 2014 9:42 am

Solutions for PHP fatal errors mentioning "'escapeshellcmd() has been disabled for security reasons":

In order to eliminate this error message you need to do one of the following things:
  • Remove the escapeshellcmd string from the disable_functions in the php.ini file.
  • Ask your ISP to remove the string for you, if you don't have any access to the php.ini file.
  • Change the hosting provider which allows to run the escapeshellcmd function for ImageMagick.
  • ...
  • Or, do not use ImageMagick and use the GDLib in S9y instead.
Regards,
Ian

Serendipity Styx Edition and additional_plugins @ https://ophian.github.io/ @ https://github.com/ophian

User avatar
Dergln
Regular
Posts: 54
Joined: Thu Jun 23, 2011 8:18 pm
Location: Hessen
Contact:

Re: [2.0-beta6] Media Library broken

Post by Dergln » Tue Nov 18, 2014 9:42 pm

Heyho,

thanks for the tips - made me try the only alternative I could arrange on a quick matter:

Code: Select all

AddHandler php56-cgi .php
Fixes the error, but meh, CGI 8). (My hoster also offers fastCGI of course, but...continue reading :))

I therefore simply disabled ImageMagick.
Is it normal that I don't notice any difference as a user after changing this ?
Resize works like before, no notable performance difference.

PS: Since I stumbled upon something others might also stumble upon:
Depending on your hoster you might run into problems when using GDLib over ImageMagick.
> https://bernd.distler.ws/archives/175-I ... l.com.html
This shouldn't bother small sites though I think.

User avatar
Dergln
Regular
Posts: 54
Joined: Thu Jun 23, 2011 8:18 pm
Location: Hessen
Contact:

Re: [resolved] [2.0-beta6] Media Library broken

Post by Dergln » Tue Nov 18, 2014 10:15 pm

Stupid question:
Did I overlook something or has the recreated media library just not been featured that much yet ?
[I saw the one screenshot in the news, and watched the video (by yellowled I think)...is there more ?? forums didn't show too.]

I am seriously amazed by the insert popup because it replaces most functions of a tool I built myself at some point*.
As long as you don't have to tell me "the old lib offered the same functionality already !?" I really think this is an underrated feature at the moment.

Meaning: Most people would have to use the image insert popups of the editors otherwise, which all suck really hard in my opinion.

* It basically builds me the whole img div, can add CC info with a single click etc. etc.
Attachments
2014-11-18 21_59_45-.png
2014-11-18 21_59_45-.png (48.27 KiB) Viewed 3879 times

User avatar
Timbalu
Regular
Posts: 4598
Joined: Sun May 02, 2004 3:04 pm

Re: [resolved] [2.0-beta6] Media Library broken

Post by Timbalu » Wed Nov 19, 2014 9:25 am

Dergln wrote:I therefore simply disabled ImageMagick.
Is it normal that I don't notice any difference as a user after changing this ?
Resize works like before, no notable performance difference.
I assume Yes for normal images and normal operations. ImageMagick has some more and better features (like pdf thumbnail creation and others, which you only find in details of image manipulations) and uses less memory altogether.
Dergln wrote:Did I overlook something or has the recreated media library just not been featured that much yet ?
The ImageLibrary was not recreated in general, only new designed and modernized, which fixed some old issues and brought-in some features.
Regards,
Ian

Serendipity Styx Edition and additional_plugins @ https://ophian.github.io/ @ https://github.com/ophian

User avatar
Dergln
Regular
Posts: 54
Joined: Thu Jun 23, 2011 8:18 pm
Location: Hessen
Contact:

Re: [resolved] [2.0-beta6] Media Library broken

Post by Dergln » Wed Nov 19, 2014 11:09 pm

Timbalu wrote:The ImageLibrary was not recreated in general, only new designed and modernized, which fixed some old issues and brought-in some features.
I really wonder what made me not use the old one then :?

Maybe it didn't have the thumb-to-hires-linking automatically, I don't quite remember.
Or I was just missing a little eyecandy :lol:

After fiddling with the iframe css a few times it now also uses way more than the default 900xY/2, which is a little low in my opinion (but easily adjustable, like I did).

Really neat and beautiful tool now, and definitely no need for an additional plugin like we had been talking about in the other thread.
Gosh I love 2.0 so much already I can't stress that enough 8)

Post Reply