1.7.7: Comments not shown

Found a bug? Tell us!!
Post Reply
User avatar
rowi
Regular
Posts: 77
Joined: Fri Mar 16, 2007 9:10 pm
Location: Flensburg / Germany
Contact:

1.7.7: Comments not shown

Post by rowi » Sat Feb 08, 2014 2:45 pm

Since I've updated to 1.7.7 comments are not shown at the bottom of an entry. They exist and are shown in the sidebar but not at the article :-(
As you can see for example at this entry http://rowi.standardleitweg.de/archives ... l#comments there should be 2 comments as stated in the footer and partly visible at the left sidebar but they're not even within the HTML source at the article itself.
I tried to remove several Plug-Ins without success :-(

User avatar
Timbalu
Regular
Posts: 4598
Joined: Sun May 02, 2004 3:04 pm

Re: 1.7.7: Comments not shown

Post by Timbalu » Sat Feb 08, 2014 3:52 pm

Is that an un-(changed/touched) entry with 1.7.7? Does that happen with every entry?
(Did you read http://board.s9y.org/viewtopic.php?f=10&t=19727? - seems related, but not directly)

Edit: Question 2 has its answer, see http://rowi.standardleitweg.de/comments/ :(
Edit2: But this does not not happen everywhere. I have 3 different server sites with no issues there...
Regards,
Ian

Serendipity Styx Edition and additional_plugins @ https://ophian.github.io/ @ https://github.com/ophian

User avatar
garvinhicking
Core Developer
Posts: 30020
Joined: Tue Sep 16, 2003 9:45 pm
Location: Cologne, Germany
Contact:

Re: 1.7.7: Comments not shown

Post by garvinhicking » Sat Feb 08, 2014 4:08 pm

Hi!

From the top of my head I wouldn't see what change in 1.7.7 would have caused this. What was your previous version, 1.7.5?

If so, could you try downgrading to 1.7.5 and see if comments then work again?

Maybe its also related to the template, maybe you'll try to switch to another template to see if that works? The bug that Timbalu mentioned in the other thread does not seem related to this to me, too.

We'll need to investigate this before a possible 1.7.8...

Regards,
Garvin
# Garvin Hicking (s9y Developer)
# Did I help you? Consider making me happy: http://wishes.garv.in/
# or use my PayPal account "paypal {at} supergarv (dot) de"
# My "other" hobby: http://flickr.garv.in/

User avatar
yellowled
Regular
Posts: 7092
Joined: Fri Jan 13, 2006 11:46 am
Location: Eutin, Germany
Contact:

Re: 1.7.7: Comments not shown

Post by yellowled » Sat Feb 08, 2014 5:37 pm

garvinhicking wrote:Maybe its also related to the template, maybe you'll try to switch to another template to see if that works?
I can not confirm this with any of the three 1.7.7 blogs I have access to, including one using 2k11 (like rowi's blog does).

I would still suggest trying to switch the template here, but if that fixes it, I think it's more likely a plugin is causing the comments issue. My dev blog with 1.7.7 and 2k11 has not lost its comments.

YL
amazon Wishlist - Serendipity-Podcast (German only, sorry)

User avatar
rowi
Regular
Posts: 77
Joined: Fri Mar 16, 2007 9:10 pm
Location: Flensburg / Germany
Contact:

Re: 1.7.7: Comments not shown

Post by rowi » Sat Feb 08, 2014 7:03 pm

the previous Version was 1.7.4, i'll try a downgrade

User avatar
rowi
Regular
Posts: 77
Joined: Fri Mar 16, 2007 9:10 pm
Location: Flensburg / Germany
Contact:

Re: 1.7.7: Comments not shown

Post by rowi » Sat Feb 08, 2014 7:12 pm

I've switched the theme and now the comments are shown again.
So it's 2k11 related (also without my user.css).

Edit: I've uploaded the 2k11 from s9y 1.7.5 and now everything is back to normal :-)
I'd like to help and test what's causing this if it helps yellowled.

User avatar
yellowled
Regular
Posts: 7092
Joined: Fri Jan 13, 2006 11:46 am
Location: Eutin, Germany
Contact:

Re: 1.7.7: Comments not shown

Post by yellowled » Sat Feb 08, 2014 8:45 pm

rowi wrote:Edit: I've uploaded the 2k11 from s9y 1.7.5 and now everything is back to normal :-)
I'd like to help and test what's causing this if it helps yellowled.
I wouldn't know what to test here. The only change in 2k11 between 1.7.5 and 1.7.5 was related to the template chooser plugin, see f23743. (Which is code by Garvin since it's related to the actual plugin.)

What might be important: Is this (apart from your user.css) a vanilla 2k11 from the 1.7.5 core or does it include any changes (especially to the .tpl files) made by you? Again, the vanilla 2k11 from 1.7.7 works just fine in my test blog … :?

YL
amazon Wishlist - Serendipity-Podcast (German only, sorry)

User avatar
rowi
Regular
Posts: 77
Joined: Fri Mar 16, 2007 9:10 pm
Location: Flensburg / Germany
Contact:

Re: 1.7.7: Comments not shown

Post by rowi » Sat Feb 08, 2014 9:01 pm

I've uploaded the vanilla 2k11 directory from the s9y 1.7.5 tgz I just downloaded.
I've never cleaned the directory on server side, so it might contain old files from all other versions of 2k11, though. OTH all files used by 2k11 are within the 1.7.7 archive and would be overwritten. And everything is fine after I uploaded the 1.7.5 Version into this directory.

User avatar
yellowled
Regular
Posts: 7092
Joined: Fri Jan 13, 2006 11:46 am
Location: Eutin, Germany
Contact:

Re: 1.7.7: Comments not shown

Post by yellowled » Sat Feb 08, 2014 9:58 pm

rowi wrote:And everything is fine after I uploaded the 1.7.5 Version into this directory.
Hrml. I have no idea what this might be. My next suggestion would be to upload the 2k11 from 1.7.7 to i.e. /templates/2k11-newer/, change the template name in /templates/2k11/info.txt and see if that works.

But frankly, this would just poking around. Even if that works or doesn't, I wouldn't know where to even suspect issues. Maybe Garvin sees some kind of connection to the latest changes in 1.7.7 …

YL
amazon Wishlist - Serendipity-Podcast (German only, sorry)

User avatar
rowi
Regular
Posts: 77
Joined: Fri Mar 16, 2007 9:10 pm
Location: Flensburg / Germany
Contact:

Re: 1.7.7: Comments not shown

Post by rowi » Sat Feb 08, 2014 10:12 pm

yellowled wrote:Hrml. I have no idea what this might be. My next suggestion would be to upload the 2k11 from 1.7.7 to i.e. /templates/2k11-newer/, change the template name in /templates/2k11/info.txt and see if that works.
That worked.
So I've renamed the old working 2k11 folder to 2k11-1.7.5 and the 2k11-new back to 2k11 so that it will be updated by future versions.

strange problem, not a bug. Solved :-)

User avatar
yellowled
Regular
Posts: 7092
Joined: Fri Jan 13, 2006 11:46 am
Location: Eutin, Germany
Contact:

Re: 1.7.7: Comments not shown

Post by yellowled » Sat Feb 08, 2014 10:15 pm

rowi wrote:strange problem, not a bug. Solved :-)
Hmmmmmmmmmmmm.

Maybe just a cache fu? You didn't by any chance clean out /templates_c/ at any point?

YL
amazon Wishlist - Serendipity-Podcast (German only, sorry)

User avatar
rowi
Regular
Posts: 77
Joined: Fri Mar 16, 2007 9:10 pm
Location: Flensburg / Germany
Contact:

Re: 1.7.7: Comments not shown

Post by rowi » Sat Feb 08, 2014 10:38 pm

no, I haven't cleaned templates_c

Post Reply