Little "bug" in Shared Install (httpd.conf) SOLVED.

Found a bug? Tell us!!
Post Reply
pedroluizdias
Posts: 2
Joined: Mon Nov 22, 2010 3:24 pm

Little "bug" in Shared Install (httpd.conf) SOLVED.

Post by pedroluizdias » Mon Nov 22, 2010 7:09 pm

Hi guys!

My name is Pedro, from Brazil and I'm very glad to be here... :D
I've suffer a lot of headache with a little detail with Shared Installation. :cry:

Every file, no matters the size or type cannot be uploaded... The server response page indicating something wrong concerning file size upload in php.ini but the value was set to 20M!!!

In my "/etc/apache2/httpd.conf" , notice the absence of :/tmp/ in php_admin_value open_basedir...

--httpd.conf--
NameVirtualHost 192.168.254.20:80
<VirtualHost 192.168.254.20:80>
ServerName newuser.lab.com
DocumentRoot /var/www/newuser/htdocs
<Directory "/var/www/newuser/htdocs">
AllowOverride All
</Directory>
php_value include_path ".:/usr/local/lib/php/:/usr/local/lib/php/s9y/:/usr/local/lib/php/s9y/bundled-libs/"
php_admin_value open_basedir "/usr/local/bin/:/usr/local/lib/php/:/usr/local/lib/php/s9y/:/var/www/newuser/"
</VirtualHost>

Just adding /tmp in the path list, everything works fine since then...

php_admin_value open_basedir "/usr/local/bin/:/usr/local/lib/php/:/usr/local/lib/php/s9y/:/var/www/newuser/:/tmp/"

Well, problem solved...

Since the article <http://www.s9y.org/41.html> is mentioned as experimental, please Gravin, accept my humble contribution. :)

My work still in progress. I have a lot of things to test yet before porting my company's internal blog to the shared server among others ...

Bye!
Pedro L. Dias

Post Reply