Posting problem

Found a bug? Tell us!!
Post Reply
ccc00a
Posts: 2
Joined: Mon Jun 21, 2010 6:08 am

Posting problem

Post by ccc00a » Tue Jun 22, 2010 5:57 am

When I try to save a new entry, this shows up above the entry box:

"Serendipity is now saving your entry, creating trackbacks and performing possible XML-RPC calls. This may take a while.."

The entry never gets posted on my blog. The same thing happened when trying to edit a previous entry. Please advise.

User avatar
garvinhicking
Core Developer
Posts: 30020
Joined: Tue Sep 16, 2003 9:45 pm
Location: Cologne, Germany
Contact:

Re: Posting problem

Post by garvinhicking » Tue Jun 22, 2010 10:09 am

Hi!

Which serendipity version are you using?

When s9y hangs at this place it might usually mean that your server's firewall is blocking outgoing access. If that is the case you would need to disable trackbacks and xmlrpc-pings.

Another problem could be that PHP is showing fatal errors, and your server is configured to not display them. You can verify that by creating a test "error.php" file with some random code in it like:

Code: Select all

<?php
echo invalid:func(


and execute that in the browser to see if you get an error. If not, you could try to edit your .htaccess file and insert a line "php_value display_errors On" to the top of the file.

HTH,
Garvin
# Garvin Hicking (s9y Developer)
# Did I help you? Consider making me happy: http://wishes.garv.in/
# or use my PayPal account "paypal {at} supergarv (dot) de"
# My "other" hobby: http://flickr.garv.in/

solraun
Regular
Posts: 6
Joined: Thu Oct 29, 2009 5:18 pm

Re: Posting problem

Post by solraun » Thu Jun 24, 2010 1:06 pm

Hallo Garvin

I experience the same Problem, it started in the last days, after I made some change to the server.
I cannot tell you all the changes, there were a lot. But I updated to the latest version of Serendipity along the way.

http://www.striking.ch/

I tried your advice to test if PHP is showing fatal errors, but it just gives me a HTTP 500 Internal Server Error.
How do I enable IIS to display fatal errors? I tried what you said, but it wont change anything.
The preview Button works, but after clicking save, the preview window shows a rendering of the administrator page. If I click preview again, it still shows the rendering of the administrator page.

I dont think it has to do with the firewall, I didnt change anything related to it.
Do you have an idea how to resolve this?

User avatar
garvinhicking
Core Developer
Posts: 30020
Joined: Tue Sep 16, 2003 9:45 pm
Location: Cologne, Germany
Contact:

Re: Posting problem

Post by garvinhicking » Thu Jun 24, 2010 2:16 pm

Hi!

Then you probably migrated to PHP/CGI. You must then check your error_log (it's called like this for Apache. I have no IIS knowledge), this one will contain your PHP scripting errors. Those errors can give us a clue what's happening. Probably some RAM-overuser or network failage.

How do I enable IIS to display fatal errors? I tried what you said, but it wont change anything.
The preview Button works, but after clicking save, the preview window shows a rendering of the administrator page. If I click preview again, it still shows the rendering of the administrator page.


This error usually means that PHP sessions are not properly enabled. Check your php.ini and see that session.save_path is a valid, writable directory.

Regards,
Garvin
# Garvin Hicking (s9y Developer)
# Did I help you? Consider making me happy: http://wishes.garv.in/
# or use my PayPal account "paypal {at} supergarv (dot) de"
# My "other" hobby: http://flickr.garv.in/

solraun
Regular
Posts: 6
Joined: Thu Oct 29, 2009 5:18 pm

Re: Posting problem

Post by solraun » Thu Jun 24, 2010 2:38 pm

Thank you very much for your fast reply!

I just checked php-errors.log
It shows following errors:

[24-Jun-2010 14:23:40] PHP Warning: Module 'mbstring' already loaded in Unknown on line 0
[24-Jun-2010 14:23:40] PHP Warning: PHP Startup: Unable to load dynamic library 'C:\Program Files (x86)\PHP\ext\php_mssql.dll' - The specified module could not be found.
in Unknown on line 0

No Idea about the first one, the second one is strange, since the file and the directory exist.
But they must be completely unrelated, since they show up pretty much since I launched the Blog.

About the PHP sessions, I changed the php.ini in the installation folder of php, and it changes nothing about the error. I have a lot of sess_XXXXXXXXXXXXXXXXXXXXXXXXXX files.

If it would be a Problem with Trackbacks and XMLRPC-calls, how can I disable both? I found no correlating setting.

Cheers,
Nate



EDIT: I just did some more testing: The behaviour is absolutely random. When I click on save multiple Time, it will save eventually. The same goes for the preview button. :shock:

EDIT2: Seems you are right, it might have something to do with the sessions. When I log out of serendipity, and log in again with the "save infromation" unmarked, it wont keep the session. As soon as I click something, he wants to log me in again.

EDIT3: This happens just on one Blog of the several I have on this server, why didnt I think of it! I'll just check that installation.

User avatar
garvinhicking
Core Developer
Posts: 30020
Joined: Tue Sep 16, 2003 9:45 pm
Location: Cologne, Germany
Contact:

Re: Posting problem

Post by garvinhicking » Thu Jun 24, 2010 8:14 pm

Hi!

You seem a bit more experienced, so maybe you can use the LiveHTTPHeader Firefox extension to log the HTTP-Cookie output you get. Check the session cookie, if it changes its contents on every page request. See if your brwoser sents the proper cookie; sometimes it might not get set if your php session.cookie_domain mismatches the actual domain the blog runs under!

HTH,
Garvin
# Garvin Hicking (s9y Developer)
# Did I help you? Consider making me happy: http://wishes.garv.in/
# or use my PayPal account "paypal {at} supergarv (dot) de"
# My "other" hobby: http://flickr.garv.in/

solraun
Regular
Posts: 6
Joined: Thu Oct 29, 2009 5:18 pm

Re: Posting problem

Post by solraun » Wed Jul 07, 2010 10:46 am

It seems it was as you said.
I just changed (for a different reason) the Blog to http://blog.striking.ch and adjusted the different values accordingly. Now it works like a charm. Thank you very much for your effort and time!

Wanted to gift you Just Cause 2, but it seems your address is not linked with you wishlist. Or I'm too dumb. Whatever, write me you address to nate@striking.ch or something.

Cheers, nate

LazyBadger
Regular
Posts: 176
Joined: Mon Aug 25, 2008 12:25 pm
Location: Russia
Contact:

Re: Posting problem

Post by LazyBadger » Mon Jul 12, 2010 5:39 pm

Garvin,I want to continue thread somehow, because I see the same effects on my (different by server and versions used) blogs - "Serendipity is now saving your entry..." etc for Opera and Safari (also QTWeb), and not for FF
no problems with sessions (I can do all except publishing texts), firewalls (FF works without problems),fatal errors, probably- no problems with trackbacks (texts without any trackback give me problems, text with trackback in FF - no problems)
Quis custodiet ipsos custodes?

User avatar
garvinhicking
Core Developer
Posts: 30020
Joined: Tue Sep 16, 2003 9:45 pm
Location: Cologne, Germany
Contact:

Re: Posting problem

Post by garvinhicking » Tue Jul 13, 2010 12:49 pm

Hi!

LazyBadger wrote:Garvin,I want to continue thread somehow, because I see the same effects on my (different by server and versions used) blogs - "Serendipity is now saving your entry..." etc for Opera and Safari (also QTWeb), and not for FF
no problems with sessions (I can do all except publishing texts), firewalls (FF works without problems),fatal errors, probably- no problems with trackbacks (texts without any trackback give me problems, text with trackback in FF - no problems)


Did you check HTTP-Headers to inspect whether the same PHP Session-ID is sent/used like on all other page requests? Check php.ini for session.* and cookie-settings, if all paths and directories and domain names are proper.

Regards,
Garvin
# Garvin Hicking (s9y Developer)
# Did I help you? Consider making me happy: http://wishes.garv.in/
# or use my PayPal account "paypal {at} supergarv (dot) de"
# My "other" hobby: http://flickr.garv.in/

Post Reply