style breaks w https-login/autodetect_hostname/mod_rewrite

Found a bug? Tell us!!
Post Reply
lama
Regular
Posts: 13
Joined: Tue Jan 19, 2010 7:35 am

style breaks w https-login/autodetect_hostname/mod_rewrite

Post by lama » Thu Jan 21, 2010 5:32 am

i had a rather annoying problem for some days now, i wasnt able to track down.
my host is reachable over http and https
i enabled https-login in the superuser-plugin.

if you do this, you have the problem, that you get redirected to the https-blog after logout. i dont like that, because you cant copy&paste links then anymore, people dont like https-links, because they have to accept a certificate etc, and there are 4 virtualhosts linking to my blog, and i dont want 10% of the ppl use ble.com, 10% https://ble.com, 10% blablupps.de, 10% blog.bli.net and so on.
so i want every user to use http://ble.com when not in the admin-interface

"fine!", i thought, theres this option "autodetect_baseURL", lets turn this off, then the links get hardcoded on the page and everyone gets the same url.
but in this configuration something _terrible_ happens:
not only the option "autodetect_baseURL" is activated, but the baseURL gets autodetected before saving and the autodetected value is filled in.
and with the next click your stylesheet is gone, for blog and admin, for http- and https-access!

i first thought it was a rewrite-rule, but i dont know.
i spent hours with only tracking down the problem to this point and getting a working stylesheet back.
the only solution was to access the admin-interface over http://, deactivate autodetect_baseURL and activate it again. this fixed it.

but i want to give you the information, this behaviour is reproduceable in my configuration and if you dont get the idea of accessing the admin over htp, because you are used to https-logins, you will have a really hard day with it.

greetz
Lama

Post Reply