Board index Bugs PHP 7 - No Sidebar

Found a bug? Tell us!!
sjj1805
 
Posts: 4
Joined: Mon Jan 23, 2012 3:17 am

Postby sjj1805 » Sat Aug 19, 2017 6:25 pm

If I use PHP 5.4 my sidebar displays correctly
Using PHP 7.1 I have No Sidebar.
Any Ideas? Thank you.
Image Image

User avatar
yellowled
Regular
 
Posts: 6815
Joined: Fri Jan 13, 2006 12:46 pm
Location: Eutin, Germany

Postby yellowled » Sat Aug 19, 2017 11:21 pm

sjj1805 wrote:Using PHP 7.1 I have No Sidebar.
Any Ideas? Thank you.

I think there are still issues with PHP 7.1, s9y 2.1.x officially supports only PHP 7.0. That being said, you could try the same comparison with an up-to-date theme like 2k11 – that's usually the first test for theme-related issues, to try and reproduce the issue with the default theme.

YL
amazon Wishlist - Serendipity-Podcast (German only, sorry)

sjj1805
 
Posts: 4
Joined: Mon Jan 23, 2012 3:17 am

Postby sjj1805 » Sun Aug 20, 2017 1:28 am

Thanks for the suggestions yellowled. Never thought of trying that but gave it a go inside a Virtual Box machine. I used the Web Platform Installer and installed PHP 7.0.2. Serendipity version is 2.1.1 .
I also tried the suggested 2k11 theme.
Unfortunately still no sidebar. I think I will have to stick with PHP 5.4
Thanks again.
Image

User avatar
yellowled
Regular
 
Posts: 6815
Joined: Fri Jan 13, 2006 12:46 pm
Location: Eutin, Germany

Postby yellowled » Mon Aug 21, 2017 8:15 pm

sjj1805 wrote:Unfortunately still no sidebar.

That is incredibly odd because I can't think of anything that would affect the way your sidebars are displayed other than the theme, and I know for a fact that sidebars work with 2k11 and PHP 7.x.

Your theme does not, by any chance, use custom sidebars (i.e. other than left, hidden, right)? Do you use any “exotic” plugins (sidebar or event) that might be related to the sidebars (sidebarhider comes to mind)? Do you have access to your web server's error logfile? Are all your plugins up to date?

About the only other way to debug this that I can think of is to disable (i.e. set to hidden) all sidebar plugins any try to activate only single ones, maybe starting with something simple like an HTML nugget. I guess it might be that you're using an exotic sidebar plugins that malfunctions with PHP7 and blocks the rest of them or something like that, but it's a long shot …

YL
amazon Wishlist - Serendipity-Podcast (German only, sorry)

sjj1805
 
Posts: 4
Joined: Mon Jan 23, 2012 3:17 am

Postby sjj1805 » Tue Aug 22, 2017 5:49 pm

The Plug ins are all standard using the install a new sidebar plug in button in the ACP.
THe plug ins installed are:
Quicksearch
Coppermine Thumbnails
Archives
Link List
Categories
Links in this article
Syndication

Following your suggestion I moved them all to "Hidden"
I then individually moved each one back to the Right Hand column.
It seems to be a problem with "Coppermine Thumbnails" - If I leave that one out then the rest are all displayed.

Thanks again for your help with this. I will now play about with the Coppermine plug in settings and if necessary simply leave it out.

sjj1805
 
Posts: 4
Joined: Mon Jan 23, 2012 3:17 am

Postby sjj1805 » Tue Aug 22, 2017 7:28 pm

I have been able to create the same effect by installing a HTML Nugget in the sidebar then simply putting a small table in that nugget containg the photographs and links to the gallery.

Please consider this as resolved and once again, many thanks

User avatar
yellowled
Regular
 
Posts: 6815
Joined: Fri Jan 13, 2006 12:46 pm
Location: Eutin, Germany

Postby yellowled » Wed Aug 23, 2017 9:18 pm

sjj1805 wrote:It seems to be a problem with "Coppermine Thumbnails" - If I leave that one out then the rest are all displayed.

I have zero experience with that plugin (or Coppermine, for that matter), but I know that at least some of these external media gallery applications are not maintained very well. Might very well be that the plugin is incredibly outdated and thus doesn't work with PHP7.

Glad you could figure that out, though.

YL
amazon Wishlist - Serendipity-Podcast (German only, sorry)



Return to Bugs

Who is online

Users browsing this forum: No registered users and 2 guests