Update to PHP 5.6 from 5.3 planned. Anyone with experience?

Random stuff about serendipity. Discussion, Questions, Paraphernalia.
Post Reply
Czorneboh
Regular
Posts: 384
Joined: Tue Apr 08, 2008 7:17 pm
Location: Berlin
Contact:

Update to PHP 5.6 from 5.3 planned. Anyone with experience?

Post by Czorneboh » Wed Aug 31, 2016 11:10 pm

Hi all!

I want to update to PHP 5.6.

There are already questions in the forum according to version 7, but for me would be fine to run PHP 5.6.
Since my last move to the current provider my blog runs with PHP 5.3.3.7. This version do not gets any more security patches, even 5.6.

Here is the overview about support:
https://secure.php.net/supported-versions.php

Has anybody a blog running with PHP 5.6? all fine with it?

User avatar
yellowled
Regular
Posts: 7111
Joined: Fri Jan 13, 2006 11:46 am
Location: Eutin, Germany
Contact:

Re: Update to PHP 5.6 from 5.3 planned. Anyone with experien

Post by yellowled » Thu Sep 01, 2016 11:42 am

Czorneboh wrote:Has anybody a blog running with PHP 5.6? all fine with it?
Yes. Has been running on PHP 5.6.x (fast-cgi) for months.

Seems to have worked well for most people considering there's only one issue on GitHub clearly related to 5.6, and that has been closed months ago.

Which, I guess, does not guarantee that your transition from 5.3 to 5.6 will be flawless, but if not that would most likely be related to the server setup at your web host.

You should not switch to PHP7 yet, there are still things to test and iron out.

YL
amazon Wishlist - Serendipity-Podcast (German only, sorry)

User avatar
onli
Regular
Posts: 2363
Joined: Tue Sep 09, 2008 10:04 pm
Contact:

Re: Update to PHP 5.6 from 5.3 planned. Anyone with experien

Post by onli » Wed Sep 07, 2016 1:52 pm

Note that you want to run a current version of serendipity to have compatibility with php 5.6. I assume the serendipity version you run is quite old, otherwise I'd think there should have been problems caused by the old php version.

Czorneboh
Regular
Posts: 384
Joined: Tue Apr 08, 2008 7:17 pm
Location: Berlin
Contact:

Re: Update to PHP 5.6 from 5.3 planned. Anyone with experien

Post by Czorneboh » Wed Sep 07, 2016 3:10 pm

Which problems for users of latest s9y using old PHP-version do you know or where are those reported?

I have s9y 2.03 installed already for a while.

User avatar
onli
Regular
Posts: 2363
Joined: Tue Sep 09, 2008 10:04 pm
Contact:

Re: Update to PHP 5.6 from 5.3 planned. Anyone with experien

Post by onli » Wed Sep 07, 2016 3:31 pm

If you have 2.0.3 you will be fine. For 2.0 the official requirement is still php 5.3+. I formulated that too strong.
Czorneboh wrote:Which problems for users of latest s9y using old PHP-version do you know
We - specifically, I - simply do not test for compatibility problems with PHP versions that old. Everything could break, or nothing.
Czorneboh wrote:where are those reported?
You would find them in the changelog: https://github.com/s9y/Serendipity/blob ... /docs/NEWS. Stuff like this would also be in the announcement blog post.

However, just use a PHP version modern enough to get security fixes. Then you can be sure of compatibility, and if something would not work because of the PHP version we will fix it. Currently that is PHP 5.6 – 5.5 as well, because it was still supported when 2.0 was released (not guaranteed for 2.1, but most likely still working). PHP 7 will be supported by s9y 2.1.

Post Reply