Page 1 of 1

Unresponsive S9Y sites

Posted: Mon Oct 27, 2014 4:31 pm
by nimdadada
Greetings,

I'm having issues with my Serendipity sites where they do not respond after a certain amount of time. I'm not sure if it's because our Nagios server checks it every five minutes or if it's an issue with s9y or SQLite (all of them run on SQLite flat files). I've checked the Apache error logs and they don't generate anything when the sites become unresponsive. It sounds like a DB issue, but I'm not sure exactly how to troubleshoot the issue or if anyone else had this problem before.

Thanks

Renato

Re: Unresponsive S9Y sites

Posted: Thu Oct 30, 2014 10:24 am
by garvinhicking
Hey,

that really sounds odd. Do the sites simply timeout, or is there any output? Maybe create a test.php file just containing this:

Code: Select all

<?php
include 'serendipity_config.inc.php';
echo "The Api is there.";
this could give us a clue if already the DB connection fails somehow. How is the load of the server, is it normal? Any hanging processes?

HTH,
Garvin

Re: Unresponsive S9Y sites

Posted: Thu Oct 30, 2014 3:41 pm
by nimdadada
Thanks Garvin,
I ran the code and it returned with The Api is there. The site works fine, it's just that several times throughout the day, Nagios will tell us that the site is unresponsive. At this point, I think it's a DB thing. Especially since the Apache and Serendipity logs don't say anything. I don't even get access log activity when the site goes down like that.

Re: Unresponsive S9Y sites

Posted: Thu Oct 30, 2014 8:12 pm
by nimdadada
I encountered the issue again a minute ago and this is the symptom from Chrome:
Unable to load the webpage because the server sent no data.
Error code: ERR_EMPTY_RESPONSE