Page 1 of 1

Solved: Number of entries shown - strange behaviour

Posted: Wed Jun 25, 2014 12:44 am
by sph
Hi community,

i've got some strange behaviour when it comes to the number of entries shown on the blog.

In the configuration, i specified to show 5 entries per page. When visiting the blog, there are this 5 entries listed. On every other page, 5 entries are shown - except on the second page. There are only 2 entries shown.

Not page number two - the next to current page. The one after the page shown when you visit the website.

I can navigate through the pages back and forth, always getting the wanted 5 entries, but not on this page. It doesn't matter in which month the entries were written or if there are extended entries or something like that - first page always 5, next page always 2, all other pages always 5.

I don't even know where to look for this issue, i mean - the template files i use are being used everywhere, right?

What kind of "bug" or just mistake is leading to this? What can i do to get this fixed, where to look for this error?

Any idea is welcome, thanks in advance,


Re: Number of entries shown - strange behaviour

Posted: Wed Jun 25, 2014 1:01 am
by onli
This is neither a bug nor a mistake, it is just a bit unusual.

Responsible is the "stable archive" option. The idea of this is that you have always the same articles on the same archive page - for example, your first 5 written articles should always be on page 1. To achieve this, there needs to be one page which has a varying number of articles, as no longer the "last" page can have this function. The first page is the frontpage and should have a fixed amount, so the next page was the logical choice.

It helps search engines index the blog better, and visitor can easier find what they search when coming from a search engine that showed an archive page as search result.

Re: Solved: Number of entries shown - strange behaviour

Posted: Wed Jun 25, 2014 1:20 am
by sph
Hi onli,

thank you for your quick answer!

So, this is done on purpose! Oh my... i'd never have guessed this :lol:

Well, my site is more a "private" thingy. Nothing big, mostly visited by friends. So i really don't care about search engines and indexing, i found that "stable archive" option, turned it off - and i'm happy with the result. Problem solved.

Thank you for this information,