Page 1 of 1

Adding Scripts to Blog Header

Posted: Fri May 28, 2010 2:39 pm
by meritweb
I have recently decided to try a live chat feature for our company website. This requires that we add a script to every page, just before </head>.

Is there a way I can do this within wordpress to include the script on all blog posts?

Thanks!

Re: Adding Scripts to Blog Header

Posted: Fri May 28, 2010 2:55 pm
by kleinerChemiker
If you want to include it in Wordpress, you have to ask in a Wordpress forum.

Re: Adding Scripts to Blog Header

Posted: Fri May 28, 2010 3:00 pm
by meritweb
Sorry, I am not using Wordpress... I am using Serendipity. I have WordPress on a separate blog!

Re: Adding Scripts to Blog Header

Posted: Fri May 28, 2010 3:29 pm
by kleinerChemiker
there is an event plugin: page nugget (or somethimg like that)

Re: Adding Scripts to Blog Header

Posted: Fri May 28, 2010 4:24 pm
by meritweb
I found the HTML Nugget, but that holds a nugget of HTML in the sidebar... is that what I need?

I am looking to hide a <script> right before the </head>.

Please advise. And thanks for your help, kleinerChemiker.

Re: Adding Scripts to Blog Header

Posted: Fri May 28, 2010 4:28 pm
by meritweb
The HTML - Head - Nugget is what I am using... but I can't get it to hide the HTML... it shows it at the top of the page!

I obviously don't want it visibile!

Re: Adding Scripts to Blog Header

Posted: Fri May 28, 2010 5:14 pm
by kleinerChemiker
If you use the wysiwyg-editor you have to switch to the html-modus or turn the wysiwyg-editor off.

Re: Adding Scripts to Blog Header

Posted: Fri May 28, 2010 5:53 pm
by meritweb
I opened the "HTML-Code inside head (HTML-Head Nugget)" plugin. It brought up the Content / WYSIWYG editor. I toggled to the HTML Source to Text Mode, and entered my script. However, this did not save the script, or include it on the pages.

Do I just give up?

Re: Adding Scripts to Blog Header

Posted: Fri May 28, 2010 6:09 pm
by Don Chambers
Not sure why it is not working. Try this: go to "Personal Settings" and turn off the wysiwyg editor.... Then try again.

Re: Adding Scripts to Blog Header

Posted: Fri May 28, 2010 6:11 pm
by meritweb
Don Chambers wrote:Not sure why it is not working. Try this: go to "Personal Settings" and turn off the wysiwyg editor.... Then try again.


THAT DID IT! Thanks Don!

kleinerChemiker - I appreciate all of your help. You at least got me going in the right direction.

Thank you both so much.