Adding Movies to posts??

Random stuff about serendipity. Discussion, Questions, Paraphernalia.
g0dfather

Adding icon for video?

Post by g0dfather » Fri Apr 08, 2005 7:18 pm

Garvin,
How hard would it be to add the option of an icon to use for the video? Is that a difficult addition?

I have a windows media player icon that I usually add by hand to all video links.

By the way, I am really glad I chose serendipity.. Its nice that we can talk directly to the developer and you respond and change things and the product gets better and better!! Keep it up!

Thanks,
John

User avatar
garvinhicking
Core Developer
Posts: 30020
Joined: Tue Sep 16, 2003 9:45 pm
Location: Cologne, Germany
Contact:

Re: Adding icon for video?

Post by garvinhicking » Sat Apr 09, 2005 1:07 am

godfather,

the addition of an icon to use would not be hard, but would take some time. To implement it properly I'd estimate 3-4 hours worth of work - and it may need even more work as I have not yet thought it through. For instance you'd need a new place where you define the icon - where and how would you configure which icon you like? Just by creating special named image files, or by having an option with a dropdown on a page similar to the "choose thumbnail adjustment" page and so on.

That means, if I'd put my own price tag on that function, it would cost 200 Euro (about 230$). Of course I don't charge for Serendipity development, but I'm just outlining that I do not have the time currently for that rather small enhancement which I personally couldn't use.

Thus, please add a Feature Request on our SF.Net Tracker, and hopefully someone will take care of it. It may even be me, but don't hold your breath for that, it may take some weeks or even months til I could get down to it.

Usually function for which there's a great need, or which I personally use, or to which someone bribes me get implemented faster - I only have so much time to dedicate to s9y, so I often have to make compromises which features to implement quick, and which don't. Of course there are other developers which may read this or our Request Tracker, so maybe someone other could take on the job...

This now got a rather lengthy posting, but I just wanted to tell you my side of this. I'm always eager taking care of things and helping people, but sometimes issues which seem small to the user are a hard piece of work.

If you go enter the feature request, it would be great if you can think of as much user interaction as possible: Exactly outline where you want to how specify an image for the media icon (on upload, on media insertion, a special button in the WYSIWYG editor, ...). The more work you do to describe the function, the less we developers have to make it up. :-)

If you come up with a maybe easier solution to all this than I am making it up, I'll try to get down to it. If it's a matter of 1-2 hours, I'll code it for you. :)

Regards,
Garvin
# Garvin Hicking (s9y Developer)
# Did I help you? Consider making me happy: http://wishes.garv.in/
# or use my PayPal account "paypal {at} supergarv (dot) de"
# My "other" hobby: http://flickr.garv.in/

Jr Prod
Regular
Posts: 18
Joined: Thu Jul 14, 2005 12:18 pm

Post by Jr Prod » Wed Jul 27, 2005 11:55 am

Hi,
Is there a way to add directly a movie or a song in the S9Y ? I mean : I don't want to add a link that targets a movie or a song.
I would like a movie or a song to start to play as soon as the blog is completely loaded... (ie : to add it with the media player in the weblog).

Is there a way to do this ?

(The reason is, that I would like to add some lyrics of songs and I would like a song to be played while people are reading the lyrics...)

Thanks !!!

Jr Prod
Regular
Posts: 18
Joined: Thu Jul 14, 2005 12:18 pm

Post by Jr Prod » Wed Jul 27, 2005 12:04 pm

OK, I've found the solution !

For those who are interested, the code can be this :

<object width="240" height="196">
<param name="src" value="movie.avi">
<param name="controller" value="true">
<param name="autoplay" value="true">
<embed src="movie.avi" width="240" height="196">
</embed>
</object>

Jr Prod
Regular
Posts: 18
Joined: Thu Jul 14, 2005 12:18 pm

Post by Jr Prod » Wed Jul 27, 2005 12:24 pm

Hum... the only problem is that the video allways starts automaticaly.
I haven't found a mean to insert it but without autoplay.
Even with the <param name="autoplay" value="false"> it starts - I've tested it with IE & Mozilla...

So if you'd like to insert several movies or several songs, they'll all start to play as soon as they load completely...

Does anyone have an idea how to avoid this ?

Thanks :D

User avatar
.g@sp.
Regular
Posts: 50
Joined: Thu Apr 20, 2006 2:01 pm
Location: Brussels, Belgium

Post by .g@sp. » Tue Apr 25, 2006 1:25 pm

this trouble comes from mozilla, it doesn't take care of autoplay... i don't really know why (maybe because it's wmplayer)

it's a real mess to have a media player compatible with moz & IE...
Sorry for my poor english ;)

Post Reply