GoDaddy Says My CPU Usage Was Too High

Random stuff about serendipity. Discussion, Questions, Paraphernalia.
Post Reply
petersreviews
Regular
Posts: 28
Joined: Thu Oct 27, 2005 7:51 pm
Location: Sunny California
Contact:

GoDaddy Says My CPU Usage Was Too High

Post by petersreviews » Mon Aug 27, 2007 4:47 am

So I get this from GoDaddy after they transferred my domain to a temp server (which I can't access at this time). Is this caused by Serendipity? Do I have too many old entries (several thousand) that should be deleted or archived? Hopefully, they haven't ruined the website by the transfer to a new server.

Peter

Our system administrators have determined that you have overutilized resources on your hosting account, petersreviews.com, and as such we have migrated your hosting account to an isolated server. Please note that you have 30 days to review and resolve the high utilization issue. We will review your CPU utilization, and if it appears that the issue has been resolved, your account will be migrated back to the shared hosting environment. If you have not resolved the issue, you will need to move to a full dedicated server.
Please take a minute to visit my web site: http://www.petersreviews.com

User avatar
garvinhicking
Core Developer
Posts: 30020
Joined: Tue Sep 16, 2003 9:45 pm
Location: Cologne, Germany
Contact:

Re: GoDaddy Says My CPU Usage Was Too High

Post by garvinhicking » Mon Aug 27, 2007 11:22 am

Hi!

That depends on which event plugins you use on your s9y install. The more you have, the harder the performance might get.

HOWEVER, high CPU usages like this is mostly caused by massive spammers. If they try to spam your blog, they cause very much performance. Sadly there's no way to circument this, since you'd have the same problem with other blog applications. Spammers suck. :(

Regards,
Garvin
# Garvin Hicking (s9y Developer)
# Did I help you? Consider making me happy: http://wishes.garv.in/
# or use my PayPal account "paypal {at} supergarv (dot) de"
# My "other" hobby: http://flickr.garv.in/

petersreviews
Regular
Posts: 28
Joined: Thu Oct 27, 2005 7:51 pm
Location: Sunny California
Contact:

Post by petersreviews » Mon Aug 27, 2007 4:47 pm

Hi Garvin,

I've been running the same configuration for months so I wonder if it was spammers. I had the "e-mail entry" plugin installed and noticed that spammers will occasionally bomb that one sending out entries to anonymous people, although I'm not sure why they do that? I removed that one and I'll list the rest I have installed:

Markup: Serendipity
Markup: Emoticate
Markup: NL2BR
Browser Compatibility
Spam Protector
Spartacus
HTML Validator
Polls - (none running)
Statistics
HTML Nugget

I also use "SnapShots" http://www.snap.com/about/shots.php, Google Analytics, and Google Adsense so I wonder if those have any effect on CPU utilization.

Thanks again Garvin!
Peter
Please take a minute to visit my web site: http://www.petersreviews.com

User avatar
garvinhicking
Core Developer
Posts: 30020
Joined: Tue Sep 16, 2003 9:45 pm
Location: Cologne, Germany
Contact:

Post by garvinhicking » Mon Aug 27, 2007 5:20 pm

Hi!

Spammers always come in bot-waves, so it might very well be that you were the target of one. Your access logfiles should indicate which accesses got served during the timespan where godaddy accused you of abusing their resources?

Your event plugins are quite harmless apart from the "Statistics" plugin. If you have enabled the visitor tracking this might make your database very huge. So either truncate your serendipity_visitors table or maybe even deactivate that functionality?

External services like google adsense do not influence your performance on the server.

Regards,
Garvin
# Garvin Hicking (s9y Developer)
# Did I help you? Consider making me happy: http://wishes.garv.in/
# or use my PayPal account "paypal {at} supergarv (dot) de"
# My "other" hobby: http://flickr.garv.in/

vincem
Regular
Posts: 59
Joined: Sat Mar 05, 2005 6:01 am
Contact:

Post by vincem » Mon Sep 03, 2007 10:57 pm

Hello Peter,

I'm having the same issue with GoDaddy, they've suspended my account after a one week warning. I'm hoping they'll let me back in so that I can do something about it... How did you get your issue fixed?

Cheers,

Vince

petersreviews
Regular
Posts: 28
Joined: Thu Oct 27, 2005 7:51 pm
Location: Sunny California
Contact:

Post by petersreviews » Thu Sep 06, 2007 4:56 am

vincem wrote:Hello Peter,

I'm having the same issue with GoDaddy, they've suspended my account after a one week warning. I'm hoping they'll let me back in so that I can do something about it... How did you get your issue fixed?

Cheers,

Vince


After only one week? That seems overly harsh. I've been running Serendipity for over a year and a half with millions of hits before they yanked me. What scripts are you using? I was using SnapShots but I got rid of that one. GoDaddy is incredibly unhelpful when it comes to letting me know what my current CPU usage is now. They tell me that I'm under review for a month and they'll let me know then. So far I "think" my CPU usage is lower but there's really no way for me to tell.

Peter
Please take a minute to visit my web site: http://www.petersreviews.com

vincem
Regular
Posts: 59
Joined: Sat Mar 05, 2005 6:01 am
Contact:

Post by vincem » Sat Sep 08, 2007 7:13 am

Hi Peter,

Yeah, they locked me out without even giving me chance to fix it, not even a final warning. They said the spamming was making even the isolation server blip. So I got the hell out of there and onto an different hosting provider, with a different URL for the blog. I had much trouble reinstalling Serendipity because of my own error but it's all back to normal.

Scripts I was running, in addition to Serendipity: Viper X Guestbook, Lightbox, Greybox and some other small things. But they said the guilty parties were Serendipity's comment.php file, under serious spam attack (it still is, I'm getting thousands of 404's), and also possibly the mod-rewrite rules of the .htaccess file (for Serendipity's pretty URL's) which supposedly make the server work hard.

Hope that can help, and good luck with GoDaddy!

Cheers,

Vince

chickens
Regular
Posts: 192
Joined: Wed Dec 06, 2006 12:15 am
Location: Vegas
Contact:

Post by chickens » Mon Sep 10, 2007 7:30 pm

My two cents: disable the statistics plugin.

I ran that plugin for quite a while and I soon noticed my site running slower and slower. I didnt really realize what was going on until one day I went to my site and it was taking 5 seconds to load the page.

Since I have full root access to the server I went investigating and found nothing of interest on the server side. I started slowly disabling non-essential plugins. After removing the statistics plugin my site was back to loading at under half a second.

I bet that truncating the table like Garvin said would fix the problem, but it was easier for me to just remove it completely. That way you do not have to remember to truncate the table all the time.

atiensivu
Regular
Posts: 5
Joined: Wed Oct 11, 2006 7:01 pm
Location: Michigan - USA
Contact:

Post by atiensivu » Sun Sep 30, 2007 3:45 am

If the same zombie networks are attacking my site that were attacking your site, the work around is very easy! They all never report a valid User-Agent which makes blocking them a snap. It took my server load down close to zero.

I wrote about it here - http://blog.tiensivu.com/aaron/archives/1303-Four-things-you-can-do-to-protect-your-blog-from-comment-spam-without-resorting-to-CAPTCHAs.html

Overall, the thing to do is this (a cut and paste from my site):

Serendipity specific spam zombie network workaround involving comments.php:

Many years ago, around the 0.7 revision level of s9y, there was a bug in comments.php that script kiddies latched on to. Version 0.7-rc1 patched this bug, and any newer version cannot be exploited this way.

With that said, my site typically receives about ten exploit attempts per minute from IPs around the world. To help lighten the load on your web server and SQL server, your best bet is to make use of a custom .htaccess entry in your blog directory.

Assuming you are running Apache with mod_setenvif enabled, add these lines to the bottom of your .htaccess:

SetEnvIf user-agent ^$ commentexploit
Deny From env=commentexploit

If your site had been pegging the CPU from all the invalid requests before, it should handle the load much better now.

You will most likely see entries in your HTTP error log like this:
[Sat Sep 29 20:59:38 2007] [error] [client x.x.x.x] client denied by server configuration: /yoursite/comment.php

Post Reply