[2.0] Smartifying the backend

Mark threads with "[2.0]" for discussions about features in the longer-term future, "[1.6]" is for short-term. This is not the place for general discussions or plugin or template requests. Only features that are approved to happen by the core team should be listed here for better structuring.
User avatar
Timbalu
Regular
Posts: 4598
Joined: Sun May 02, 2004 3:04 pm

Re: [2.0] Smartifying the backend

Post by Timbalu » Tue Apr 10, 2012 8:50 am

We could close that here as well.
As far as I understood Grischas last post, it it is necessary to go via advanced installation, since you can set the root directory of the blog there successfully. Do not use the simple install in uberspace subdomain cases.

At this place we could stick to what we have or build some sort of test to exclude installings in subdomains with simple install button and to fall back to advanced.

The case of missing plugins was there while having an unfinished setup before, we assumed.
Regards,
Ian

Serendipity Styx Edition and additional_plugins @ https://ophian.github.io/ @ https://github.com/ophian

User avatar
yellowled
Regular
Posts: 7002
Joined: Fri Jan 13, 2006 12:46 pm
Location: Eutin, Germany
Contact:

Re: [2.0] Smartifying the backend

Post by yellowled » Tue Apr 10, 2012 12:42 pm

Timbalu wrote:As far as I understood Grischas last post, it it is necessary to go via advanced installation, since you can set the root directory of the blog there successfully.
In advanced install mode, I can set

* Full path
* Relative path
* URL to blog

In case of an install on an Uberspace subdomain, these are autodetected as

* /var/www/virtual/myusername/html/
* /
* http://subdomain.domain.tld

/var/www/virtual/myusername/html/ is the DOCUMENT_ROOT of myusername's Uberspace, i.e. the root domain – it's not the directory created for the subdomain, so that's the value which needs to be changed to /var/www/virtual/myusername/subdomain.domain.tld on Uberspaces.

As far as I can tell, at least, which brings me back to 2.0.

If I do this, the installation goes fine (again, as far as I can tell), but clicking "Visit your new blog" after the complete installation first tells me I need to upgrade from 1.6 to 1.7-alpha1 (it's a 2.0), which basically mean log into the admin backend. Doing so gives me
Parse error: syntax error, unexpected ':' in /var/www/virtual/myusername/subdomain.domain.tld/include/admin/upgrader.inc.php on line 212
EDIT: Other than that, the installation at least doesn't seem to mess with my main blog installation on the same Uberspace.



YL
amazon Wishlist - Serendipity-Podcast (German only, sorry)

User avatar
Timbalu
Regular
Posts: 4598
Joined: Sun May 02, 2004 3:04 pm

Re: [2.0] Smartifying the backend

Post by Timbalu » Tue Apr 10, 2012 1:05 pm

good catch!
fixed now.
Regards,
Ian

Serendipity Styx Edition and additional_plugins @ https://ophian.github.io/ @ https://github.com/ophian

User avatar
yellowled
Regular
Posts: 7002
Joined: Fri Jan 13, 2006 12:46 pm
Location: Eutin, Germany
Contact:

Re: [2.0] Smartifying the backend

Post by yellowled » Tue Apr 10, 2012 1:34 pm

Next try:

Code: Select all

Fatal error: Uncaught exception 'SmartyCompilerException' with message 'Syntax Error in template "/var/www/virtual/myuser/foo.bar.tld/include/admin/tpl/upgrader.inc.tpl" on line 2 "{'Calling %s ...<br />'|sprintf:(is_array($task['function']) ? $task['function'][0] . '::'. $task['function'][1] : $task['function'])}" - Unexpected " ? "' in /var/www/virtual/myuser/foo.bar.tld/bundled-libs/Smarty/libs/sysplugins/smarty_internal_templatecompilerbase.php:627 Stack trace: #0 /var/www/virtual/myuser/foo.bar.tld/bundled-libs/Smarty/libs/sysplugins/smarty_internal_templateparser.php(3154): Smarty_Internal_TemplateCompilerBase->trigger_template_error() #1 /var/www/virtual/myuser/foo.bar.tld/bundled-libs/Smarty/libs/sysplugins/smarty_internal_templateparser.php(3219): Smarty_Internal_Templateparser->yy_syntax_error(54, ' ? ') #2 /var/www/virtual/myuser/foo.bar.tld/bundled-libs/Smarty/libs/sysplugins/smarty_internal_smartytemplatecompiler.php(105): Smarty_Internal_Templateparser->doParse(54, ' ? ') #3 /var/www/v in /var/www/virtual/myuser/foo.bar.tld/bundled-libs/Smarty/libs/sysplugins/smarty_internal_templatecompilerbase.php on line 627
YL
amazon Wishlist - Serendipity-Podcast (German only, sorry)

User avatar
Timbalu
Regular
Posts: 4598
Joined: Sun May 02, 2004 3:04 pm

Re: [2.0] Smartifying the backend

Post by Timbalu » Tue Apr 10, 2012 1:52 pm

Oops, could you try this in the upgrader.tpl instead, please?

Code: Select all

{if $is_callable_task}
    {'Calling %s ...<br />'|sprintf:(is_array($call_tasks['function']) ? ("$call_tasks['function'][0]::$call_tasks['function'][1]") : "$call_tasks['function']")}
{/if}
Regards,
Ian

Serendipity Styx Edition and additional_plugins @ https://ophian.github.io/ @ https://github.com/ophian

User avatar
garvinhicking
Core Developer
Posts: 30014
Joined: Tue Sep 16, 2003 9:45 pm
Location: Cologne, Germany
Contact:

Re: [2.0] Smartifying the backend

Post by garvinhicking » Tue Apr 10, 2012 2:27 pm

Hi!

I'm too stupid to switch from "master" branch to "2.0" in my installation, "git branch 2.0" doesn't work.

Anyhow. The serendipity_config.inc.php still has version = 1.7-alpha1 set for the 2.0 branch, that should probably be changed to "2.0-alpha1".

Regards,
Garvin
# Garvin Hicking (s9y Developer)
# Did I help you? Consider making me happy: http://wishes.garv.in/
# or use my PayPal account "paypal {at} supergarv (dot) de"
# My "other" hobby: http://flickr.garv.in/

User avatar
Timbalu
Regular
Posts: 4598
Joined: Sun May 02, 2004 3:04 pm

Re: [2.0] Smartifying the backend

Post by Timbalu » Tue Apr 10, 2012 2:35 pm

Garvin, its

Code: Select all

git checkout 2.0
- then git pull origin 2.0 etc...
The version might be a good catch too :D
Anyhow this smarty ternary doesn't work at all, I am going to change it to something more simple.
Regards,
Ian

Serendipity Styx Edition and additional_plugins @ https://ophian.github.io/ @ https://github.com/ophian

User avatar
yellowled
Regular
Posts: 7002
Joined: Fri Jan 13, 2006 12:46 pm
Location: Eutin, Germany
Contact:

Re: [2.0] Smartifying the backend

Post by yellowled » Tue Apr 10, 2012 2:38 pm

Timbalu wrote:Oops, could you try this in the upgrader.tpl instead, please?
Yay, another error:

Code: Select all

Fatal error: Uncaught exception 'SmartyCompilerException' with message 'Syntax Error in template "/var/www/virtual/user/foo.bar.tld/include/admin/tpl/upgrader.inc.tpl"  on line 2 "{'Calling %s ...<br />'|sprintf:(is_array($call_tasks['function']) ? ("$call_tasks['function'][0]::$call_tasks['function'][1]") : "$call_tasks['function']")}"  - Unexpected " ? "' in /var/www/virtual/user/foo.bar.tld/bundled-libs/Smarty/libs/sysplugins/smarty_internal_templatecompilerbase.php:627
Stack trace:
#0 /var/www/virtual/user/foo.bar.tld/bundled-libs/Smarty/libs/sysplugins/smarty_internal_templateparser.php(3154): Smarty_Internal_TemplateCompilerBase->trigger_template_error()
#1 /var/www/virtual/user/foo.bar.tld/bundled-libs/Smarty/libs/sysplugins/smarty_internal_templateparser.php(3219): Smarty_Internal_Templateparser->yy_syntax_error(54, ' ? ')
#2 /var/www/virtual/user/foo.bar.tld/bundled-libs/Smarty/libs/sysplugins/smarty_internal_smartytemplatecompiler.php(105): Smarty_Internal_Templ in /var/www/virtual/user/foo.bar.tld/bundled-libs/Smarty/libs/sysplugins/smarty_internal_templatecompilerbase.php on line 627
YL
amazon Wishlist - Serendipity-Podcast (German only, sorry)

User avatar
Timbalu
Regular
Posts: 4598
Joined: Sun May 02, 2004 3:04 pm

Re: [2.0] Smartifying the backend

Post by Timbalu » Tue Apr 10, 2012 2:50 pm

What a mess. I think it was some sort of leftover and got forgotten by time..., Sorry!
I just fixed the $data['call_tasks'] in 2.0. (Hopefully) Please try again, YL.
There may still be the version change necessary, Garvin noted.
Regards,
Ian

Serendipity Styx Edition and additional_plugins @ https://ophian.github.io/ @ https://github.com/ophian

User avatar
yellowled
Regular
Posts: 7002
Joined: Fri Jan 13, 2006 12:46 pm
Location: Eutin, Germany
Contact:

Re: [2.0] Smartifying the backend

Post by yellowled » Tue Apr 10, 2012 4:32 pm

Timbalu wrote:There may still be the version change necessary, Garvin noted.
No, the version number is correct now – 2.0-alpha1, but I still get the "need to upgrade" screen.

Oh, and …

Code: Select all

Fatal error: Uncaught exception 'SmartyCompilerException' with message 'Syntax Error in template "/var/www/virtual/user/foo.bar.tld/include/admin/tpl/upgrader.inc.tpl" on line 125 "{if}" missing if condition' in /var/www/virtual/user/foo.bar.tld/bundled-libs/Smarty/libs/sysplugins/smarty_internal_templatecompilerbase.php:627 Stack trace: #0 /var/www/virtual/user/foo.bar.tld/bundled-libs/Smarty/libs/sysplugins/smarty_internal_compile_if.php(37): Smarty_Internal_TemplateCompilerBase->trigger_template_error('missing if cond...', 125) #1 /var/www/virtual/user/foo.bar.tld/bundled-libs/Smarty/libs/sysplugins/smarty_internal_templatecompilerbase.php(429): Smarty_Internal_Compile_If->compile(Array, Object(Smarty_Internal_SmartyTemplateCompiler), Array, NULL, NULL) #2 /var/www/virtual/user/foo.bar.tld/bundled-libs/Smarty/libs/sysplugins/smarty_internal_templatecompilerbase.php(227): Smarty_Internal_TemplateCompilerBase->callTagCompiler('if', Array, Array) #3 /var/www/virtual/user/foo.bar.tld/bundled- in /var/www/virtual/user/foo.bar.tld/bundled-libs/Smarty/libs/sysplugins/smarty_internal_templatecompilerbase.php on line 627
YL
amazon Wishlist - Serendipity-Podcast (German only, sorry)

User avatar
Timbalu
Regular
Posts: 4598
Joined: Sun May 02, 2004 3:04 pm

Re: [2.0] Smartifying the backend

Post by Timbalu » Tue Apr 10, 2012 4:41 pm

Please add yourself the missing / to {/if} instead.
Also fixed in 2.0.

You have to describe better which procedure happened, while getting this "need to upgrade" screen. Which part of the tpl, btw?
Regards,
Ian

Serendipity Styx Edition and additional_plugins @ https://ophian.github.io/ @ https://github.com/ophian

User avatar
yellowled
Regular
Posts: 7002
Joined: Fri Jan 13, 2006 12:46 pm
Location: Eutin, Germany
Contact:

Re: [2.0] Smartifying the backend

Post by yellowled » Tue Apr 10, 2012 5:23 pm

Timbalu wrote:You have to describe better which procedure happened, while getting this "need to upgrade" screen. Which part of the tpl, btw?
No idea what you mean by "part of the tpl".

After completing the installation, there's a "visit your new blog" link which usually takes you to the newly installed blog's frontpage. Instead, I get (German):
Serendipity hat entdeckt, dass derzeit Version 1.6 verwendet wird. Jedoch wurde Version 2.0-alpha1 installiert, daher müssen Sie die Installation aktualisieren!
After that, I now get the usual update screen telling me that all directories are writeable and no modifications are necessary. After that, I get another confirmation screen (which has a falsely escaped "back to the blog" link with a href of http://foo.bar.de/%7B$serendipityHTTPPath%7D

… and apparently, my productive blog on yellowled.de is now running s9y 2.0-alpha1. Great. :roll:

YL
amazon Wishlist - Serendipity-Podcast (German only, sorry)

User avatar
Timbalu
Regular
Posts: 4598
Joined: Sun May 02, 2004 3:04 pm

Re: [2.0] Smartifying the backend

Post by Timbalu » Tue Apr 10, 2012 6:27 pm

I solved the upgrader_return_here path message now, please check GIT.
(or use

Code: Select all

<div align="center">{$CONST.SERENDIPITY_UPGRADER_RETURN_HERE|sprintf:"<a href='{$serendipityHTTPPath}'>":'</a>'}</div>
instead)

I am not sure about this bad version message, as this is in serendipity_config.inc.php, I think.
I did update the version to 2.0-alpha1 there, see on GIT some 2 commits ago. But this shouldn't harm your official blog! This might be still the uberspace issue again...?!?
Or the upgrading process got dizzy because we changed the version while not starting from scratch.
Maybe we have to move L239 and L240 (where the versions get set to data->smarty) in upgrader.inc.php to be set later on? Garvin could you please have a look on this too?
Regards,
Ian

Serendipity Styx Edition and additional_plugins @ https://ophian.github.io/ @ https://github.com/ophian

User avatar
yellowled
Regular
Posts: 7002
Joined: Fri Jan 13, 2006 12:46 pm
Location: Eutin, Germany
Contact:

Re: [2.0] Smartifying the backend

Post by yellowled » Tue Apr 10, 2012 7:39 pm

Timbalu wrote:But this shouldn't harm your official blog! This might be still the uberspace issue again...?!?
Yes, but this is why we're doing all this in the first place, isn't it?

Anyway, it's no biggie because Uberspace has a kick-ass backup system. Takes me about 10 seconds to restore a working backup of my official blog. However, I won't try again today because I want to make sure the backup system doesn't get confused. Also, I'm kind of fed up with installing over and over again.

This is frustrating. I realize it's more or less due to the special setup with this particular hoster, but we have special settings for other hosters as well …

YL
amazon Wishlist - Serendipity-Podcast (German only, sorry)

User avatar
garvinhicking
Core Developer
Posts: 30014
Joined: Tue Sep 16, 2003 9:45 pm
Location: Cologne, Germany
Contact:

Re: [2.0] Smartifying the backend

Post by garvinhicking » Tue Apr 10, 2012 10:28 pm

Hi!

Can you ask the Ubernauten what their specific reason is for not making DOCUMENT_ROOT point to the directory which serves as "/" of the subdomain?

Thanks,
Garvin
# Garvin Hicking (s9y Developer)
# Did I help you? Consider making me happy: http://wishes.garv.in/
# or use my PayPal account "paypal {at} supergarv (dot) de"
# My "other" hobby: http://flickr.garv.in/

Locked