Weather Plugin Pear Problem

Hier können Probleme und alles andere in Deutscher Sprache gelöst werden.
Post Reply
commanderx
Regular
Posts: 59
Joined: Mon Apr 18, 2005 8:18 am
Contact:

Weather Plugin Pear Problem

Post by commanderx » Thu Apr 19, 2007 11:25 am

So, nach über einem Jahr ohne s9y mal wieder ein Problemchen :).
Ich habe das Wetter Plugin installiert und auf der Console 'pear install Services_Weather' ausgeführt.
Ein 'pear list' zeigt mir die Komponente auch als installiert an.
Aber das Weather Plugin ist trotzdem der Meinung das es nicht installiert ist.
Wenn ich die Komponente direkt in 'bundled-libs' schiebe, wird die Sidebar gar nicht erst geladen.

Was könnte denn da schief laufen?

Grüssle...

PS: s9y ist die aktuelle Version, das Weather Plugin hat die Version 1.5

User avatar
garvinhicking
Core Developer
Posts: 30020
Joined: Tue Sep 16, 2003 9:45 pm
Location: Cologne, Germany
Contact:

Re: Weather Plugin Pear Problem

Post by garvinhicking » Thu Apr 19, 2007 11:46 am

Hi!

Wenn das plugin meldet dass es nicht installiert ist, scheint es als wäre dein PEAR-Pfad nicht im include_path setting von der php.ini, und s9y kann nur PEAR-Pakete erkennen die darin liegen.

Es in bundled-libs zu packen sollte eigentlich klappen. Wenn die Sidebar dann garnicht geladen wird sollte ein PHP-Error vorlieren, da müsstest du mal die php error logs schauen oder display_errors aktivieren.

Viele GRüße,
Garvin
# Garvin Hicking (s9y Developer)
# Did I help you? Consider making me happy: http://wishes.garv.in/
# or use my PayPal account "paypal {at} supergarv (dot) de"
# My "other" hobby: http://flickr.garv.in/

commanderx
Regular
Posts: 59
Joined: Mon Apr 18, 2005 8:18 am
Contact:

Post by commanderx » Thu Apr 19, 2007 1:48 pm

Tja,PEAR war nicht im include Pfad...sehr dümmlich.
Ich habe jetzt 'error_reporting = E_ALL' und 'display_errors = On' in der php.ini aktiviert, aber eine Fehlerausgabe kommt komischerweise immer noch nicht.
Das seltsame ist, das das Plugin nun auch nicht mehr in der Auflistung der aktiven Plugins der Seitenleiste auftaucht, erst wenn ich Services_Weather entferne taucht es wieder auf.

PS: nicht nur das Weather Plugin fehlt in der Auflistung, es geht einfach nicht weiter, wie bei der Sidebar hört die Seite einfach auf.

der_kaepten
Regular
Posts: 14
Joined: Fri Oct 19, 2007 10:39 pm
Location: near Hamburg/Germany

... immer noch Weather-plugin ...

Post by der_kaepten » Sun Dec 09, 2007 1:26 pm

Moin, moin zusammen,

ich muß leider diesen uralten Thread nochmal aufwärmen :-(
Aber ich bekomme dieses Weather-plugin nicht zum Laufen :-( habe schon alles (meiner Meinung nach) aus dem Forum durchgespielt.
Bei meiner lokalen Installation (WinXP mit xampp) keine Probleme, nachdem ich den include_Pfad in der php.ini aktualisiert habe.
Auf dem Webserver (ich habe root-Zugriff) habe ich den Eintrag auch in der php.ini durchgeführt, bekomme ich die Meldung "...keine Rechte zum Zugriff dorthin..."

+++++++++++++++++++++++++
[09-Dez-2007 13:20:02] PHP Warning: generate_content() [<a href='function.generate-content'>function.generate-content</a>]: open_basedir restriction in effect. File(/usr/share/psa-horde/pear/Services/Weather.php) is not within the allowed path(s): (/srv/www/vhosts/xxxx/httpdocs:/tmp) in /srv/www/vhosts/xxxx/httpdocs/serendipity/plugins/serendipity_plugin_weather/serendipity_plugin_weather.php on line 130
+++++++++++++++++++++++++

Dann den Vorschlag aufgenommen 'Services/Weather' unter bundled-libs zu packen.
Jetzt weden gar keine Plugins mehr angezeigt (wie ja hier auch schon erwähnt). Es wird aber auch kein Eintrag in der
php error.log erzeugt.
Also irgendwie weiss ich jetzt überhaupt nicht mehr weiter ... hat noch jemand Ideen? :(

Vielen Dank + Gruß
Jürgen

User avatar
garvinhicking
Core Developer
Posts: 30020
Joined: Tue Sep 16, 2003 9:45 pm
Location: Cologne, Germany
Contact:

Re: ... immer noch Weather-plugin ...

Post by garvinhicking » Sun Dec 09, 2007 1:36 pm

Hi!

Inwiefern werden denn garkeine Plugins mehr angezeigt? Im Frontend? Hast DU mal in den HTML Quelltext geguckt, ob das evtl mittendrin aufhört?

Scheinbar bietet dein provider PEAR an, hat's auch im include_path, aber open_basedir erlaubts nicht. Daher sollte der provider da seine konfig aktualisieren und entweder PEAR in basedir aufnehmen, oder include_path ohne PEAR Pfad setzen.

Grüße,
Garvin
# Garvin Hicking (s9y Developer)
# Did I help you? Consider making me happy: http://wishes.garv.in/
# or use my PayPal account "paypal {at} supergarv (dot) de"
# My "other" hobby: http://flickr.garv.in/

der_kaepten
Regular
Posts: 14
Joined: Fri Oct 19, 2007 10:39 pm
Location: near Hamburg/Germany

Post by der_kaepten » Sun Dec 09, 2007 2:00 pm

Moin Garvin,

vielen Dank für die schnelle Reaktion!

- der code ist richtig, denn wenn ich Services aus den bundled-libs wieder lösche, bekomme ich alle plugins angezeigt und das weather mit dem Fehler, das Pear wohl nicht da ist.

- open_basedir ist in der php.ini auskommentiert :-(

gibt's da noch eine andere Stelle wo das eingestellt werden kann?

Gruß
Jürgen

User avatar
garvinhicking
Core Developer
Posts: 30020
Joined: Tue Sep 16, 2003 9:45 pm
Location: Cologne, Germany
Contact:

Post by garvinhicking » Mon Dec 10, 2007 10:45 am

Hi!

Ich weiß immer noch nicht was Du mit "bekomme ich alle plugins angezeigt" meinst.

- open_basedir ist in der php.ini auskommentiert :-(


Das wird auch eigentlich in der httpd.conf des webservers eingestellt.

Grüße,
Garvin
# Garvin Hicking (s9y Developer)
# Did I help you? Consider making me happy: http://wishes.garv.in/
# or use my PayPal account "paypal {at} supergarv (dot) de"
# My "other" hobby: http://flickr.garv.in/

der_kaepten
Regular
Posts: 14
Joined: Fri Oct 19, 2007 10:39 pm
Location: near Hamburg/Germany

Post by der_kaepten » Mon Dec 10, 2007 11:23 am

Moin Garvin,


Ich weiß immer noch nicht was Du mit "bekomme ich alle plugins angezeigt" meinst.



ich habe rechts den Kalender, Archive, Admin-login, rss etc. dieses wird alles nicht bzw. doch angezeigt. Das meine ich mit "...Plugins angezeigt..."
(Wenn Du gucken willst www.dino-siggi.de (habe das Wetter aber jetzt rausgenomen))

httpd.conf probiere ich schnellstens aus (bin jetzt auf der Arbeit und habe von hier keinen ssh-Zugang auf den Server - Sicherheitseinstellungen :-( )

Gruß
Jürgen

User avatar
garvinhicking
Core Developer
Posts: 30020
Joined: Tue Sep 16, 2003 9:45 pm
Location: Cologne, Germany
Contact:

Post by garvinhicking » Mon Dec 10, 2007 12:18 pm

Hi!

Wenn alle Plugins verschwinden liegt dies vermutlich daran, dass ein fataler PHP Fehler auftritt. Durchsuch dein PHP errorlog (php.ini: error_log, display_errors) einmal, da müsste ein Hinweis stehen.

Meist liegt das daran dass das Weather-PHP-Plugin auch PEAR.php einbindet, das wiederrum scheitert erneut an deiner open_basedir.

Grüße,
Garvin
# Garvin Hicking (s9y Developer)
# Did I help you? Consider making me happy: http://wishes.garv.in/
# or use my PayPal account "paypal {at} supergarv (dot) de"
# My "other" hobby: http://flickr.garv.in/

der_kaepten
Regular
Posts: 14
Joined: Fri Oct 19, 2007 10:39 pm
Location: near Hamburg/Germany

gelöst!

Post by der_kaepten » Tue Jan 01, 2008 3:46 pm

Moin,

so, habe das Weather-Plugin jetzt zum Laufen bekommen :-)
Aus irgendwelchen Gründen wurde die httpd.include (die wohl der httpd.conf entspricht) nicht gelesen :-(
Nach kompletter Neuinstallation ist jetzt alles im Lot!
Danke dir, Garvin, für die Hilfe.

gruß
Jürgen

Post Reply