Weisse Seite bei Themes und Spartacus Plugins

Hier können Probleme und alles andere in Deutscher Sprache gelöst werden.
Post Reply
Toyo
Regular
Posts: 5
Joined: Sat Nov 16, 2019 9:40 pm

Weisse Seite bei Themes und Spartacus Plugins

Post by Toyo » Sun Nov 17, 2019 3:11 am

So Installation hat gut funktioniert, ich bekomme im Backend aber nur weisse Seiten bei Themes.
Bei Plugins Spartacus ist aktiviert, wenn ich auf "Ereignis Plugin" installieren klicke, weisse Seite.
Seitenleisten Plugins gleiches Ergebnis.
Plugins updaten ebenso.
Warum nur weiss, ein Theme ist doch schon installiert, automatisch.
Ich seh es ja wenn ich den Blog aufrufe.

Ich habe drei Möglichkeiten bei open_basedir zur Verfügung.
1. {DOCROOT}{/}{:}{TMP}{/}
2. {WEBSPACEROOT}{/}{:}{TMP}{/}
3.none
In den Error Logs steht das hier.

Code: Select all

[Sun Nov 17 02:22:45.812116 2019] [proxy_fcgi:error] [pid 25647] [client 109.40.1.57:26786] AH01071: Got error 'PHP message: PHP Warning:  require_once(): open_basedir restr[Sun Nov 17 02:22:45.812116 2019] [proxy_fcgi:error] [pid 25647] [client 109.40.1.57:26786] AH01071: Got error 'PHP message: PHP Warning:  require_once(): open_basedir restriction in effect. File(/opt/plesk/php/7.3/share/pear/PEAR/Exception.php) is not within the allowed path(s): (/var/www/vhosts/domain.info/:/tmp/) in /var/www/vhosts/domain.info/httpdocs/bundled-libs/HTTP/Request2/Exception.php on line 24PHP message: PHP Warning:  require_once(/opt/plesk/php/7.3/share/pear/PEAR/Exception.php): failed to open stream: Operation not permitted in /var/www/vhosts/domain.info/httpdocs/bundled-libs/HTTP/Request2/Exception.php on line 24PHP message: PHP Fatal error:  require_once(): Failed opening required 'PEAR/Exception.php' (include_path='.:/opt/plesk/php/7.3/share/pear:/var/www/vhosts/domain.info/httpdocs/bundled-libs/:/var/www/vhosts/domain.info/httpdocs/bundled-libs/Smarty/libs/:/var/www/vhosts/domain.info/httpdocs/:') in /var/www/vhosts/domain.info/httpdocs/bundled-libs/HTTP/Request2/Exception.php on line 24', referer: https://www.domain.info/serendipity_admin.php?serendipity[adminModule]=plugins
Merkwürdig, ich habe nichts weiter gemacht, nur mal zwischen den 3 open basedir Möglichkeiten hin und her gewechselt, jetzt bekomme ich Themes angezeigt und Seitenleisten Plugins.
Mit genau der {WEBSPACEROOT}{/}{:}{TMP}{/} die vorhin nichts gemacht hat.
Ich werde das nie verstehen, mal sehen wie lange es hält.

User avatar
erAck
Regular
Posts: 116
Joined: Mon Feb 16, 2015 2:20 am

Re: Weisse Seite bei Themes und Spartacus Plugins

Post by erAck » Sun Nov 17, 2019 4:32 am

Wenn in php.ini (oder ggbf. einer der anderen .ini, siehe php -i) open_basedir gesetzt ist, muss dieses den Pfad
/opt/plesk/php/7.3/share/pear
beinhalten, siehe https://www.php.net/manual/en/ini.core. ... en-basedir

Toyo
Regular
Posts: 5
Joined: Sat Nov 16, 2019 9:40 pm

Re: Weisse Seite bei Themes und Spartacus Plugins

Post by Toyo » Sun Nov 17, 2019 7:13 am

Ja jetzt geht es wieder nicht, ich bekomme zwar Plugins angezeigt, bei "Installieren" kommt dann die weisse Seite.
Ich habe keine Ahnung was da eingestellt werden muss und wo.
Ich habe ja Plesk, mit den drei Optionen von oben.
Wird auch ohne den Kram gehen.

Post Reply