Page 1 of 1

[erledigt] endlosschleife beim Upgrade

Posted: Thu Sep 26, 2019 9:24 pm
by der_kaepten
Moin,
mir ist die ehrenvolle :-O Aufgabe zugefallen einen alten Serendipity-Blog wieder zum laufen zu bringen. Will das ganze zuerst lokal ausprobieren und zum Laufen bringen. Habe auch schon einiges hinbekommen, die Datenbank ist (wieder) anzusprechen, PHP 7.3.9 ist installiert. Das ganze läuft über lampp und Linux-Mint, aber das tut ja generell nichts zur Sache.
Die alte Version ist mit 1.6.1 installiert, die läuft aber gar nicht mehr :-( Daher habe ich 2.3.1 runtergeladen, und gemäß den Anweisungen für einen manuellen Update "installiert". Also die Dateien rüberkopiert.
Wenn ich jetzt /serendipity_admin.php starte, sagt er mir bei allen Prüfungen alles OK, jedoch muß die neue Version 2.3.1 installiert werden. Schön - ist erledigt.
Starte ich jetzt den blog bekomme ich immer
Serendipity has detected that your currently installed Serendipity version is 1.6.1. It seems you are attempting to upgrade to version 2.3.1, so you need to click here to continue the upgrade process.
dann "klicke ich here" - und bin in einer Endlosschleife -> /serendipity_admin.php -> "... has detected..." :evil:
Hat evtl. irgendjemand eine Idee und kann mir helfen - ich weiß echt nicht weiter.
Vielen Dank schon mal im Voraus
Gruß
Jürgen

Re: endlosschleife beim Upgrade

Posted: Thu Sep 26, 2019 9:58 pm
by yellowled
der_kaepten wrote:
Thu Sep 26, 2019 9:24 pm
Hat evtl. irgendjemand eine Idee und kann mir helfen - ich weiß echt nicht weiter.
Ich würde für den Anfang mal in die Logdateien des Webservers gucken und zudem prüfen, ob die Dateirechte im Serendipity-Verzeichnis passen.

YL

Re: endlosschleife beim Upgrade

Posted: Sat Sep 28, 2019 2:54 pm
by der_kaepten
Moin,
jo, habe ich schon gemacht, steht nix besonderes, verfängliches drin - jedenfalls nach meiner Meinung - hänge mal beide ran.
Rechte - sollten auch OK sein, apache läuft unter root.

Re: endlosschleife beim Upgrade

Posted: Sat Sep 28, 2019 7:03 pm
by der_kaepten
:D erledigt!
wat bin ich doof :oops: , danke yellowled:-)
Es waren natürlich die Rechte, ich habe immer nur die Rechte vom Apache kontrolliert aber nicht von den Seiten-Verzeichnissen mit serendipity :oops:
Angepasst - jetzt habe ich die Seite wieder - jetzt noch ein paar :P Anpassungen dann läuft hoffentlich alles wieder.