Page 1 of 1

Linklist-Plugin benötigt Update für PHP7.2 und höher mit 2.3-rc1

Posted: Tue Aug 06, 2019 4:40 pm
by mbb
Ich habe mal Serendipity 2.3-rc1 installiert. Mit PHP 7.1 läuft alles. Sobald ich PHP 7.2 oder 7.3 verwende bekomme ich beim laden des Blogs nur eine Seite mit einer Fehlermeldung:

"Fatal error: Uncaught ErrorException: Warning: Use of undefined constant linkcount - assumed 'linkcount' (this will throw an Error in a future version of PHP) in [...]"

Re: Linklist-Plugin benötigt Update für PHP7.2 und höher mit 2.3-rc1

Posted: Fri Aug 09, 2019 8:35 am
by thh

Re: Linklist-Plugin benötigt Update für PHP7.2 und höher mit 2.3-rc1

Posted: Fri Aug 09, 2019 3:52 pm
by mbb
bei github steht, dass der Fehler vor einiger Zeit behoben worden sein soll ... ist der fix schon in der 2.3 rc1 enthalten oder ist ein aktualisiertes Plugin erhältlich. Ich habe eigentlich alles auf dem aktuellen Stand. Derzeit kann ich 2.3 rc1 nur mit PHP 7.1 betreiben.

Re: Linklist-Plugin benötigt Update für PHP7.2 und höher mit 2.3-rc1

Posted: Fri Aug 09, 2019 9:42 pm
by thh
mbb wrote:
Fri Aug 09, 2019 3:52 pm
bei github steht, dass der Fehler vor einiger Zeit behoben worden sein soll ... ist der fix schon in der 2.3 rc1 enthalten oder ist ein aktualisiertes Plugin erhältlich. Ich habe eigentlich alles auf dem aktuellen Stand. Derzeit kann ich 2.3 rc1 nur mit PHP 7.1 betreiben.
Der Fehler ist behoben, aber damals wurde offenbar vergessen, die Versionsnummer des Plugins zu inkrementieren, so dass die Änderung nie ausgerollt wurde. Ich habe das jetzt nachgeholt; mittlerweile sollte ein Update für das Plugin bereitstehen, und mit dem müsste es dann laufen.

Re: Linklist-Plugin benötigt Update für PHP7.2 und höher mit 2.3-rc1

Posted: Sat Aug 10, 2019 3:46 pm
by mbb
Danke ... jetzt läuft alles