Page 1 of 1

Google meldet Sitemap Fehler

Posted: Thu Feb 28, 2019 1:32 am
by smk
Hallo,

serendipity_event_google_sitemap plugin scheint defekt zu sein. Ich bekomme von Google folgende Fehlermeldung.
Die XML-Sitemap kann nicht geparst werden, weil sie mindestens ein ungebundenes Namespace-Präfix enthält. Dieser Fehler wird beispielsweise generiert, wenn in einer Sitemap <xhtml:link> ohne vorangehendes xmlns:xhtml="http://www.w3.org/1999/xhtml" gefunden wird.
Zeile: 9
In meiner Sitemap ist xmlns:xhtml="http://www.w3.org/1999/xhtml" gar nicht vorhanden. Testweise habe ich diese bei mir per Hand eingetragen, aber bisher ohne Erfolg. Bin mir auch nicht sicher ob ich es im XML richtig gemacht habe.

Code: Select all

<?xml version="1.0" encoding="UTF-8"?>
<urlset xmlns="http://www.sitemaps.org/schemas/sitemap/0.9"
        xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
        xsi:schemaLocation="http://www.sitemaps.org/schemas/sitemap/0.9
  http://www.sitemaps.org/schemas/sitemap/0.9/sitemap.xsd"
  xmlns:xhtml="http://www.w3.org/1999/xhtml" >
Für eine bessere Analyse hänge ich meine Sitemap mal an, damit sich das mal jemand mit XML Erfahrung sagen kann, wo in der XML der Fehler sein könnte.

Gruß knasan

Re: Google meldet Sitemap Fehler

Posted: Fri Mar 01, 2019 11:18 am
by ockmonix
Bei mir werden mehrere Fehler angezeigt, dass das Namespace-Präfix news nicht definiert ist.

Deswegen solltest du in jedem Fall auch das Namespace-Präfix 'news' im Header deklarieren:

Code: Select all

<urlset xmlns="http://www.sitemaps.org/schemas/sitemap/0.9"
     xmlns:news="http://www.google.com/schemas/sitemap-news/0.9"
     ...
     

Re: Google meldet Sitemap Fehler

Posted: Fri Mar 01, 2019 4:42 pm
by yellowled
Fehler ist bekannt, Fix ist in Arbeit. viewtopic.php?p=10451459#p10451459

YL

Re: Google meldet Sitemap Fehler

Posted: Fri Mar 01, 2019 9:32 pm
by onli
Das Update von hannob sollte morgen per Spartacus ausgeliefert werden.