Problem bei Update von Plugins

Hier können Probleme und alles andere in Deutscher Sprache gelöst werden.
Post Reply
User avatar
Lux
Regular
Posts: 761
Joined: Fri Aug 12, 2005 4:36 pm
Location: Grüt, Zürich, Switzerland
Contact:

Problem bei Update von Plugins

Post by Lux » Fri Apr 06, 2018 6:14 am

Hi!

Ich bekomme beim Versuch, Plugins zu aktualisieren immer die folgende Fehlermeldung.
Ihr Browser hat keinen gültigen HTTP-Referrer übermittelt. Dies kann entweder daher kommen, dass Ihr Browser/Proxy nicht korrekt konfiguriert ist, oder dass Sie Opfer einer "Cross Site Request Forgery (XSRF)" waren, mit der man Sie zu ungewollten Änderungen zwingen wollte. Die angeforderte Aktion konnte daher nicht durchgeführt werden.
Serendipity 2.2.0-beta2 und PHP 7.0.29

Habt Ihr Ideen?

Gruss

Dirk

MarioH
Regular
Posts: 234
Joined: Mon Jul 20, 2009 10:53 pm
Contact:

Re: Problem bei Update von Plugins

Post by MarioH » Fri Apr 06, 2018 6:13 pm

Hallo Dirk,
ist das eventuell das gleiche Problem wie hier: viewtopic.php?f=3&t=23821

Sprich, hilft es, die Settings des Spartacus-Plugins einmal aufzurufen und zu speichern?

Gruß
Mario

User avatar
Lux
Regular
Posts: 761
Joined: Fri Aug 12, 2005 4:36 pm
Location: Grüt, Zürich, Switzerland
Contact:

Re: Problem bei Update von Plugins

Post by Lux » Sat Apr 07, 2018 6:56 am

MarioH wrote:ist das eventuell das gleiche Problem wie hier: viewtopic.php?f=3&t=23821

Sprich, hilft es, die Settings des Spartacus-Plugins einmal aufzurufen und zu speichern?
Es geht in die gleiche Richtung.

Ich habe die Meldung beim Spartacus-Plugin ebenfalls gehabt und nachdem ich die templates_c/package_* Dateien gelöscht habe, waren die Meldungen bei Spartacus weg.

Allerdings klappt Plugins updaten leider immer noch nicht.

Grüsse

Dirk

User avatar
robert
Regular
Posts: 1042
Joined: Mon May 09, 2005 9:17 pm
Location: Vienna, Austria
Contact:

Re: Problem bei Update von Plugins

Post by robert » Sat Apr 07, 2018 8:34 pm

Detto. Wenn ich den Update Button drücke erscheint eine leere Seite. Ebenso beim Aufruf der Funktion zum installieren von Seitenleisten Plugins.
Nur ein Blog ...auf robertlender.info - natürlich mit S9y betrieben

S9y InfoCamp - der (inoffizielle) S9y-Podcast

User avatar
Lux
Regular
Posts: 761
Joined: Fri Aug 12, 2005 4:36 pm
Location: Grüt, Zürich, Switzerland
Contact:

Re: Problem bei Update von Plugins

Post by Lux » Sun Apr 08, 2018 7:38 am

robert wrote:Detto. Wenn ich den Update Button drücke erscheint eine leere Seite. Ebenso beim Aufruf der Funktion zum installieren von Seitenleisten Plugins.
Leere Seite habe ich tatsächlich nicht. Nur oben eine Box, die mir sagt, dass der Referrer nicht stimmt.

Könnte PHP 7 die Ursache sein?

Gruss

Dirk

thh
Regular
Posts: 324
Joined: Thu Oct 26, 2006 2:38 pm
Location: Stuttgart, Germany
Contact:

Re: Problem bei Update von Plugins

Post by thh » Sun Apr 08, 2018 4:34 pm

Lux wrote:
robert wrote:Könnte PHP 7 die Ursache sein?
Oder die s9y-Version direkt aus git.

Ich habe PHP 7.0.27 (statt 7.0.29) und das Problem nicht, aber eben auch s9y 2.1.2 und nicht 2.2.0-beta.

(Oder deaktiviertes Javascript? Das hier sieht mir jedenfalls nach JS aus: https://www.dropbox.com/s/vhq2nbkpk449i ... 8.png?dl=0)

User avatar
Lux
Regular
Posts: 761
Joined: Fri Aug 12, 2005 4:36 pm
Location: Grüt, Zürich, Switzerland
Contact:

Re: Problem bei Update von Plugins

Post by Lux » Sun Apr 08, 2018 5:14 pm

thh wrote:Oder die s9y-Version direkt aus git.
Ich habe PHP 7.0.27 (statt 7.0.29) und das Problem nicht, aber eben auch s9y 2.1.2 und nicht 2.2.0-beta.
Das wird es auch sein.
thh wrote:(Oder deaktiviertes Javascript? Das hier sieht mir jedenfalls nach JS aus: https://www.dropbox.com/s/vhq2nbkpk449i ... 8.png?dl=0)
Nein, Javascript ist nicht deaktiviert.

Grüsse

Dirk

User avatar
robert
Regular
Posts: 1042
Joined: Mon May 09, 2005 9:17 pm
Location: Vienna, Austria
Contact:

Re: Problem bei Update von Plugins

Post by robert » Sun Apr 08, 2018 8:06 pm

Bei mir läuft "Serendipity 2.1.2 und PHP 7.2.3".

Dh. mit 2.2. sollte das Problem behoben sein? Oder soll ich auf PHP <7 runterschalten?

Liebe Grüße
Robert
Nur ein Blog ...auf robertlender.info - natürlich mit S9y betrieben

S9y InfoCamp - der (inoffizielle) S9y-Podcast

User avatar
Lux
Regular
Posts: 761
Joined: Fri Aug 12, 2005 4:36 pm
Location: Grüt, Zürich, Switzerland
Contact:

Re: Problem bei Update von Plugins

Post by Lux » Mon Apr 09, 2018 5:57 am

robert wrote:Bei mir läuft "Serendipity 2.1.2 und PHP 7.2.3".
Dh. mit 2.2. sollte das Problem behoben sein? Oder soll ich auf PHP <7 runterschalten?
Ich meine, mich erinnern zu können, dass PHP 7.0.x funktionieren sollte und hähere Versionen (noch) nicht.

Bei mir hat in fünf von sieben Blogs geholfen, im Browser alle Cookies zu löschen und den Browser neu zu starten.

Die anderen beiden werfen je eine Exception in unterschiedlichen Plugins.

DeimHart:

Code: Select all

== ERROR-REPORT (BETA/ALPHA-BUILDS) ==

Warning: Declaration of serendipity_event_browsercompatibility::event_hook($event, &$bag, &$eventData) should be compatible with serendipity_event::event_hook($event, &$bag, &$eventData, $addData = NULL) in /srv/www/deimhart.net/plugins/serendipity_event_browsercompatibility/serendipity_event_browsercompatibility.php on line 0.
For more details set $serendipity['production'] = 'debug' in serendipity_config_local.inc.php to receive a stack-trace.



Fatal error:  Uncaught ErrorException: Warning: Declaration of serendipity_event_browsercompatibility::event_hook($event, &$bag, &$eventData) should be compatible with serendipity_event::event_hook($event, &$bag, &$eventData, $addData = NULL) in /srv/www/deimhart.net/plugins/serendipity_event_browsercompatibility/serendipity_event_browsercompatibility.php:0
Stack trace:
#0 /srv/www/deimhart.net/include/plugin_api.inc.php(638): errorToExceptionHandler(2, 'Declaration of ...', '/srv/www/deimha...', 0, Array)
#1 /srv/www/deimhart.net/include/plugin_api.inc.php(638): include()
#2 /srv/www/deimhart.net/include/plugin_api.inc.php(713): serendipity_plugin_api::load_plugin('serendipity_eve...', NULL, 'serendipity_eve...', '/srv/www/deimha...')
#3 /srv/www/deimhart.net/include/admin/plugins.inc.php(187): serendipity_plugin_api::getPluginInfo('/srv/www/deimha...', Array, 'event')
#4 /srv/www/deimhart.net/serendipity_admin.php(127): include('/srv/www/deimha...')
#5 {main}
  thrown in /srv/www/deimhart.net/plugins/serendipity_event_browsercompatibility/serendipity_event_browsercompatibility.php on line 0

 == ERROR-REPORT (BETA/ALPHA-BUILDS) == 

Fatal Error: Uncaught ErrorException: Warning: Declaration of serendipity_event_browsercompatibility::event_hook($event, &$bag, &$eventData) should be compatible with serendipity_event::event_hook($event, &$bag, &$eventData, $addData = NULL) in /srv/www/deimhart.net/plugins/serendipity_event_browsercompatibility/serendipity_event_browsercompatibility.php:0
Stack trace:
#0 /srv/www/deimhart.net/include/plugin_api.inc.php(638): errorToExceptionHandler(2, 'Declaration of ...', '/srv/www/deimha...', 0, Array)
#1 /srv/www/deimhart.net/include/plugin_api.inc.php(638): include()
#2 /srv/www/deimhart.net/include/plugin_api.inc.php(713): serendipity_plugin_api::load_plugin('serendipity_eve...', NULL, 'serendipity_eve...', '/srv/www/deimha...')
#3 /srv/www/deimhart.net/include/admin/plugins.inc.php(187): serendipity_plugin_api::getPluginInfo('/srv/www/deimha...', Array, 'event')
#4 /srv/www/deimhart.net/serendipity_admin.php(127): include('/srv/www/deimha...')
#5 {main}
  thrown in /srv/www/deimhart.net/plugins/serendipity_event_browsercompatibility/serendipity_event_browsercompatibility.php on line 0.
For more details set $serendipity['production'] = 'debug' in serendipity_config_local.inc.php to receive a stack-trace.



Fatal error:  Uncaught ErrorException: Fatal Error: Uncaught ErrorException: Warning: Declaration of serendipity_event_browsercompatibility::event_hook($event, &$bag, &$eventData) should be compatible with serendipity_event::event_hook($event, &$bag, &$eventData, $addData = NULL) in /srv/www/deimhart.net/plugins/serendipity_event_browsercompatibility/serendipity_event_browsercompatibility.php:0
Stack trace:
#0 /srv/www/deimhart.net/include/plugin_api.inc.php(638): errorToExceptionHandler(2, 'Declaration of ...', '/srv/www/deimha...', 0, Array)
#1 /srv/www/deimhart.net/include/plugin_api.inc.php(638): include()
#2 /srv/www/deimhart.net/include/plugin_api.inc.php(713): serendipity_plugin_api::load_plugin('serendipity_eve...', NULL, 'serendipity_eve...', '/srv/www/deimha...')
#3 /srv/www/deimhart.net/include/admin/plugins.inc.php(187): serendipity_plugin_api::getPluginInfo('/srv/www/deimha...', Array, 'event')
#4 /srv/www/deimhart.net/serendipity_admin.php(127): include('/srv/www/deimha...')
#5 {main}
  thrown in /srv/www/dei in /srv/www/deimhart.net/plugins/serendipity_event_browsercompatibility/serendipity_event_browsercompatibility.php on line 0
Sandhaut:

Code: Select all

== ERROR-REPORT (BETA/ALPHA-BUILDS) ==

Warning: Declaration of serendipity_event_blogpdf::event_hook($event, &$bag, &$eventData) should be compatible with serendipity_event::event_hook($event, &$bag, &$eventData, $addData = NULL) in /srv/www/sandhaut.net/blog/plugins/serendipity_event_blogpdf/serendipity_event_blogpdf.php on line 0.
For more details set $serendipity['production'] = 'debug' in serendipity_config_local.inc.php to receive a stack-trace.



Fatal error:  Uncaught ErrorException: Warning: Declaration of serendipity_event_blogpdf::event_hook($event, &$bag, &$eventData) should be compatible with serendipity_event::event_hook($event, &$bag, &$eventData, $addData = NULL) in /srv/www/sandhaut.net/blog/plugins/serendipity_event_blogpdf/serendipity_event_blogpdf.php:0
Stack trace:
#0 /srv/www/sandhaut.net/blog/include/plugin_api.inc.php(638): errorToExceptionHandler(2, 'Declaration of ...', '/srv/www/sandha...', 0, Array)
#1 /srv/www/sandhaut.net/blog/include/plugin_api.inc.php(638): include()
#2 /srv/www/sandhaut.net/blog/include/plugin_api.inc.php(713): serendipity_plugin_api::load_plugin('serendipity_eve...', NULL, 'serendipity_eve...', '/srv/www/sandha...')
#3 /srv/www/sandhaut.net/blog/include/admin/plugins.inc.php(187): serendipity_plugin_api::getPluginInfo('/srv/www/sandha...', Array, 'event')
#4 /srv/www/sandhaut.net/blog/serendipity_admin.php(127): include('/srv/www/sandha...')
#5 {main}
  thrown in /srv/www/sandhaut.net/blog/plugins/serendipity_event_blogpdf/serendipity_event_blogpdf.php on line 0

 == ERROR-REPORT (BETA/ALPHA-BUILDS) == 

Fatal Error: Uncaught ErrorException: Warning: Declaration of serendipity_event_blogpdf::event_hook($event, &$bag, &$eventData) should be compatible with serendipity_event::event_hook($event, &$bag, &$eventData, $addData = NULL) in /srv/www/sandhaut.net/blog/plugins/serendipity_event_blogpdf/serendipity_event_blogpdf.php:0
Stack trace:
#0 /srv/www/sandhaut.net/blog/include/plugin_api.inc.php(638): errorToExceptionHandler(2, 'Declaration of ...', '/srv/www/sandha...', 0, Array)
#1 /srv/www/sandhaut.net/blog/include/plugin_api.inc.php(638): include()
#2 /srv/www/sandhaut.net/blog/include/plugin_api.inc.php(713): serendipity_plugin_api::load_plugin('serendipity_eve...', NULL, 'serendipity_eve...', '/srv/www/sandha...')
#3 /srv/www/sandhaut.net/blog/include/admin/plugins.inc.php(187): serendipity_plugin_api::getPluginInfo('/srv/www/sandha...', Array, 'event')
#4 /srv/www/sandhaut.net/blog/serendipity_admin.php(127): include('/srv/www/sandha...')
#5 {main}
  thrown in /srv/www/sandhaut.net/blog/plugins/serendipity_event_blogpdf/serendipity_event_blogpdf.php on line 0.
For more details set $serendipity['production'] = 'debug' in serendipity_config_local.inc.php to receive a stack-trace.



Fatal error:  Uncaught ErrorException: Fatal Error: Uncaught ErrorException: Warning: Declaration of serendipity_event_blogpdf::event_hook($event, &$bag, &$eventData) should be compatible with serendipity_event::event_hook($event, &$bag, &$eventData, $addData = NULL) in /srv/www/sandhaut.net/blog/plugins/serendipity_event_blogpdf/serendipity_event_blogpdf.php:0
Stack trace:
#0 /srv/www/sandhaut.net/blog/include/plugin_api.inc.php(638): errorToExceptionHandler(2, 'Declaration of ...', '/srv/www/sandha...', 0, Array)
#1 /srv/www/sandhaut.net/blog/include/plugin_api.inc.php(638): include()
#2 /srv/www/sandhaut.net/blog/include/plugin_api.inc.php(713): serendipity_plugin_api::load_plugin('serendipity_eve...', NULL, 'serendipity_eve...', '/srv/www/sandha...')
#3 /srv/www/sandhaut.net/blog/include/admin/plugins.inc.php(187): serendipity_plugin_api::getPluginInfo('/srv/www/sandha...', Array, 'event')
#4 /srv/www/sandhaut.net/blog/serendipity_admin.php(127): include('/srv/www/sandha...')
#5 {main}
  thrown in /srv/www/sandhaut.net in /srv/www/sandhaut.net/blog/plugins/serendipity_event_blogpdf/serendipity_event_blogpdf.php on line 0
Gruss

Dirk

User avatar
Lux
Regular
Posts: 761
Joined: Fri Aug 12, 2005 4:36 pm
Location: Grüt, Zürich, Switzerland
Contact:

Re: Problem bei Update von Plugins

Post by Lux » Mon Apr 09, 2018 6:03 am

Lux wrote:Die anderen beiden werfen je eine Exception in unterschiedlichen Plugins.
Interessant ist, dass die Plugins gar nicht aktiv sind und nach dem Löschen werfen wieder andere eine Exception.

Gruss

Dirk

User avatar
Lux
Regular
Posts: 761
Joined: Fri Aug 12, 2005 4:36 pm
Location: Grüt, Zürich, Switzerland
Contact:

Re: Problem bei Update von Plugins

Post by Lux » Mon Apr 09, 2018 6:07 am

Lux wrote:
Lux wrote:Die anderen beiden werfen je eine Exception in unterschiedlichen Plugins.
Interessant ist, dass die Plugins gar nicht aktiv sind und nach dem Löschen werfen wieder andere eine Exception.
Letzter Nachtrag: Nach dem Löschen aller angemahnten Plugins funktioniert alles so wie es soll.

Wir kommen wieder zurück zu meinem Vorschlag, einen Cleaning-Job zu erstellen, der nicht mehr benutzte Plugins anmahnt und Tabellen in der Datenbank, die zu gelöschten Plugins gehören.

Gruss

Dirk

User avatar
robert
Regular
Posts: 1042
Joined: Mon May 09, 2005 9:17 pm
Location: Vienna, Austria
Contact:

Re: Problem bei Update von Plugins

Post by robert » Mon Apr 09, 2018 9:43 pm

Lux wrote: Wir kommen wieder zurück zu meinem Vorschlag, einen Cleaning-Job zu erstellen, der nicht mehr benutzte Plugins anmahnt und Tabellen in der Datenbank, die zu gelöschten Plugins gehören.
Interessant, dass inaktive Plugins hier mitwirken. Und ja, so ein Cleaning-Job wäre praktisch. Aber es ist so oder so ein guter Hinweis, mal in der DB nach ungebrauchten Tabellen zu suchen (soweit ich das als Laie dann beurteilen kann).
Nur ein Blog ...auf robertlender.info - natürlich mit S9y betrieben

S9y InfoCamp - der (inoffizielle) S9y-Podcast

User avatar
yellowled
Regular
Posts: 7056
Joined: Fri Jan 13, 2006 12:46 pm
Location: Eutin, Germany
Contact:

Re: Problem bei Update von Plugins

Post by yellowled » Mon Apr 09, 2018 9:58 pm

Lux wrote:Ich meine, mich erinnern zu können, dass PHP 7.0.x funktionieren sollte und hähere Versionen (noch) nicht.
7.0.x müsste, 7.1.x könnte (bin mir nicht sicher), von 7.2.x muss man definitiv noch abraten. Da ist Einiges in PHP deprecated worden, was wir noch benutzen.
Lux wrote:Warning: Declaration of serendipity_event_browsercompatibility
Nanu, wo kommt das denn her?

Code: Select all

* Upgrader will now remove/delete the browsercompatibility plugin
(Das hätte im Update auf 1.7.1 passieren sollen.)

YL
amazon Wishlist - Serendipity-Podcast (German only, sorry)

Post Reply