[SOLVED] Fehler nach 2.1.1 Update bei Plugins Updaten

Hier können Probleme und alles andere in Deutscher Sprache gelöst werden.
Post Reply
mbb
Regular
Posts: 57
Joined: Sun Jul 22, 2007 3:06 pm

[SOLVED] Fehler nach 2.1.1 Update bei Plugins Updaten

Post by mbb » Mon Apr 10, 2017 5:10 pm

Habe ein kleines problem nach dem Update von 2.0.5 auf 2.1.1 (Nutze noch das 2k11 theme)
wenn ich z.B. die Funktion "PLUGINS UPDATEN" starte möchte erscheint folgende Fehlermeldung:

Fatal error: require_once(): Failed opening required 'PEAR/Exception.php' (include_path='.:/usr/local/lib/php:/kunden/[...]/webseiten/beckmann/serendipity/bundled-libs/:/kunden/[...]/webseiten/beckmann/serendipity/bundled-libs/Smarty/libs/:/kunden/[...]/webseiten/beckmann/serendipity/:') in /kunden[...]/webseiten/beckmann/serendipity/bundled-libs/HTTP/Request2/Exception.php on line 24

Ähnlich Fehlermeldungen bei "Themes" und "Wartung". Würde mich über ein wenig Hilfe freuen.
Last edited by mbb on Wed Apr 12, 2017 5:42 pm, edited 1 time in total.

User avatar
yellowled
Regular
Posts: 7007
Joined: Fri Jan 13, 2006 12:46 pm
Location: Eutin, Germany
Contact:

Re: Fehler nach 2.1.1 Update bei Plugins Updaten und Themes

Post by yellowled » Mon Apr 10, 2017 5:14 pm

mbb wrote:Fatal error: require_once(): Failed opening required 'PEAR/Exception.php'
Da würde ich als Erstes mal gucken, ob die Datei /serendipity/bundled-libs/PEAR/Exception.php a) existiert und b) für den Webserver oder PHP-Nutzer (das ist von Hoster zu Hoster verschieden) lesbar ist, also ob die berüchtigten Permissions stimmen (ggf. hilft der Support des Hosters da weiter).
mbb wrote:Ähnlich Fehlermeldungen bei "Themes" und "Wartung".
Was heißt denn da „ähnliche“? Ist die gleiche Datei (Exception.php) betroffen oder sehen die Fehlermeldungen da gar ganz anders aus?

YL
amazon Wishlist - Serendipity-Podcast (German only, sorry)

mbb
Regular
Posts: 57
Joined: Sun Jul 22, 2007 3:06 pm

Re: Fehler nach 2.1.1 Update bei Plugins Updaten und Themes

Post by mbb » Mon Apr 10, 2017 5:28 pm

Vielen Dank für die schnelle Rückmeldung.
yellowled wrote:
mbb wrote:Fatal error: require_once(): Failed opening required 'PEAR/Exception.php'
Da würde ich als Erstes mal gucken, ob die Datei /serendipity/bundled-libs/PEAR/Exception.php a) existiert und b) für den Webserver oder PHP-Nutzer (das ist von Hoster zu Hoster verschieden) lesbar ist, also ob die berüchtigten Permissions stimmen (ggf. hilft der Support des Hosters da weiter).YL
Die Datei existiert. Die Permissions stehen für den Benutzer auf Lesen/Schreiben/Ausführen. Wie gesagt habe ich nur 2.1.1 über die bestehende Installation drüberinstalliert.
mbb wrote:Ähnlich Fehlermeldungen bei "Themes" und "Wartung".
Was heißt denn da „ähnliche“? Ist die gleiche Datei (Exception.php) betroffen oder sehen die Fehlermeldungen da gar ganz anders aus? YL[/quote]
Ja gleiche Fehlermeldung ...

User avatar
u1amo01
Regular
Posts: 267
Joined: Fri Sep 28, 2007 3:55 pm
Location: Kurpfalz, Germany
Contact:

Re: Fehler nach 2.1.1 Update bei Plugins Updaten und Themes

Post by u1amo01 » Mon Apr 10, 2017 7:03 pm

Bei mir gibts folgendes Problem: wenn ich den Menüpunkt "Themes" aufrufen will oder "Plugins updaten" erscheint
"Die URL http://netmirror.org/mirror/serendipity ... bar_de.xml (IP 188.40.113.17) konnte nicht geöffnet werden. Möglicherweise existieren Server- oder Netzwerkprobleme."

User avatar
yellowled
Regular
Posts: 7007
Joined: Fri Jan 13, 2006 12:46 pm
Location: Eutin, Germany
Contact:

Re: Fehler nach 2.1.1 Update bei Plugins Updaten und Themes

Post by yellowled » Mon Apr 10, 2017 9:05 pm

mbb wrote:Die Datei existiert. Die Permissions stehen für den Benutzer auf Lesen/Schreiben/Ausführen. Wie gesagt habe ich nur 2.1.1 über die bestehende Installation drüberinstalliert.
Dann bin ich leider überfragt, vielleicht lese ich die Fehlermeldung auch falsch. Vielleicht können Garvin oder onli mehr dazu sagen.

YL
amazon Wishlist - Serendipity-Podcast (German only, sorry)

User avatar
yellowled
Regular
Posts: 7007
Joined: Fri Jan 13, 2006 12:46 pm
Location: Eutin, Germany
Contact:

Re: Fehler nach 2.1.1 Update bei Plugins Updaten und Themes

Post by yellowled » Mon Apr 10, 2017 9:07 pm

u1amo01 wrote:"Die URL http://netmirror.org/mirror/serendipity ... bar_de.xml (IP 188.40.113.17) konnte nicht geöffnet werden. Möglicherweise existieren Server- oder Netzwerkprobleme."
Joah, Netmirror ist wohl etwas längerfristiger spazieren gegangen. Einfach in den Optionen des Spartacus-Plugins beide Werte für „Datei/Mirror Speicherort“ auf github.com zu setzen sollte das beheben.

YL
amazon Wishlist - Serendipity-Podcast (German only, sorry)

User avatar
u1amo01
Regular
Posts: 267
Joined: Fri Sep 28, 2007 3:55 pm
Location: Kurpfalz, Germany
Contact:

Re: Fehler nach 2.1.1 Update bei Plugins Updaten und Themes

Post by u1amo01 » Mon Apr 10, 2017 10:00 pm

Das wars. Danke :-)

Boah, ich hab echt schon lange nicht mehr am System geschraubt. Ich hab glatt vergessen, dass das dort eingestellt wird. Läuft halt immer einfach alles :-)

mbb
Regular
Posts: 57
Joined: Sun Jul 22, 2007 3:06 pm

Re: Fehler nach 2.1.1 Update bei Plugins Updaten und Themes

Post by mbb » Tue Apr 11, 2017 8:21 am

yellowled wrote:
mbb wrote:Die Datei existiert. Die Permissions stehen für den Benutzer auf Lesen/Schreiben/Ausführen. Wie gesagt habe ich nur 2.1.1 über die bestehende Installation drüberinstalliert.
Dann bin ich leider überfragt, vielleicht lese ich die Fehlermeldung auch falsch. Vielleicht können Garvin oder onli mehr dazu sagen.

YL
Na dann warte ich mal ab ... habe leider auch keine Ahnung woran es liegen könnte. Hängt dies vielleicht mit dem 2k11-Theme zusammen ?

User avatar
onli
Regular
Posts: 2220
Joined: Tue Sep 09, 2008 10:04 pm
Contact:

Re: Fehler nach 2.1.1 Update bei Plugins Updaten und Themes

Post by onli » Tue Apr 11, 2017 11:52 am

mbb, dein Problem ist wahrscheinlich ein Fehler des Hosters. Bist du bei Manitu? Dort bin ich da auch schon reingerannt. 'PEAR/Exception.php' liegt aus irgendwelchen Gründen in einem Ordner, der nicht im allowed_path der PHP-Konfiguration bei manchen Hostern ist, ist aber im System vorhanden. Und liegt ja auch in unseren bundled-libs, warum das hier nicht einfach genutzt wird verstehe ich auch nicht ganz.

Wende dich bitte an deinen Hoster, der soll das fixen. Wenn er meint der Fehler liegt bei uns, dann soll er dir bitte die komplette Fehlermeldung samt stacktrace zeigen, und du dann uns.

mbb
Regular
Posts: 57
Joined: Sun Jul 22, 2007 3:06 pm

Re: Fehler nach 2.1.1 Update bei Plugins Updaten und Themes

Post by mbb » Tue Apr 11, 2017 2:04 pm

onli wrote:mbb, dein Problem ist wahrscheinlich ein Fehler des Hosters. Bist du bei Manitu? Dort bin ich da auch schon reingerannt. 'PEAR/Exception.php' liegt aus irgendwelchen Gründen in einem Ordner, der nicht im allowed_path der PHP-Konfiguration bei manchen Hostern ist, ist aber im System vorhanden. Und liegt ja auch in unseren bundled-libs, warum das hier nicht einfach genutzt wird verstehe ich auch nicht ganz.

Wende dich bitte an deinen Hoster, der soll das fixen. Wenn er meint der Fehler liegt bei uns, dann soll er dir bitte die komplette Fehlermeldung samt stacktrace zeigen, und du dann uns.
Bin bei Domainfactory ... und der Fehler trat erstmals mit dem Update auf. Ich werde mal bei df nachfragen.

User avatar
onli
Regular
Posts: 2220
Joined: Tue Sep 09, 2008 10:04 pm
Contact:

Re: Fehler nach 2.1.1 Update bei Plugins Updaten und Themes

Post by onli » Tue Apr 11, 2017 2:20 pm

Wir haben mit dem Update für PHP 7 eben die verwendeten Libraries ausgewechselt (z.B. HTTP/Request zu HTTP/Request2), deswegen kann es erst jetzt auftreten :) Das passt zusammen.

mbb
Regular
Posts: 57
Joined: Sun Jul 22, 2007 3:06 pm

Re: Fehler nach 2.1.1 Update bei Plugins Updaten und Themes

Post by mbb » Tue Apr 11, 2017 2:49 pm

Ticket wurde von DF behoben.

mbb
Regular
Posts: 57
Joined: Sun Jul 22, 2007 3:06 pm

Re: Fehler nach 2.1.1 Update bei Plugins Updaten und Themes

Post by mbb » Wed Apr 12, 2017 4:34 pm

Domainfactory hat den Fehler behoben. In der Tat fehlte es serverseitig an der Leseberechtigung, so dass der Fehler von DF behoben werden musste.

Herzlichen Dank für die schnelle Hilfe und Unterstützung.

TerraH
Posts: 2
Joined: Thu Jan 04, 2018 12:41 am

Re: [SOLVED] Fehler nach 2.1.1 Update bei Plugins Updaten

Post by TerraH » Thu Jan 04, 2018 2:19 am

Hallo mbb,

ich habe die selbe Fehlermeldung und ich bin bei Domainfactory. Ich hatte ein Ticket aufgemacht und habe auch diesen Beitrag zu dem Techniker gelinkt. Sie sagen, sie haben etwas angepasst, aber der Fehler kommt immer noch.
Domainfactory hat den Fehler behoben. In der Tat fehlte es serverseitig an der Leseberechtigung, so dass der Fehler von DF behoben werden musste.
Wissen Sie was genau gemacht wurde, damit ich das dem Support mitteilen kann?

Viele Grüße
Terra

Post Reply