einige Probleme nach Umstellung auf 2.1

Hier können Probleme und alles andere in Deutscher Sprache gelöst werden.
User avatar
u1amo01
Regular
Posts: 267
Joined: Fri Sep 28, 2007 3:55 pm
Location: Kurpfalz, Germany
Contact:

Re: einige Probleme nach Umstellung auf 2.1

Post by u1amo01 » Mon Feb 13, 2017 10:26 pm

Hmm, kann es sein, dass die Funktion "Cache" unter Umständen Ärger bereitet?

User avatar
onli
Regular
Posts: 2243
Joined: Tue Sep 09, 2008 10:04 pm
Contact:

Re: einige Probleme nach Umstellung auf 2.1

Post by onli » Tue Feb 14, 2017 12:58 am

Ich habe keine Probleme damit bemerkt, aber sie ist neu. Das ist also durchaus noch möglich. Worum genau gehts?

User avatar
u1amo01
Regular
Posts: 267
Joined: Fri Sep 28, 2007 3:55 pm
Location: Kurpfalz, Germany
Contact:

Re: einige Probleme nach Umstellung auf 2.1

Post by u1amo01 » Tue Feb 14, 2017 9:09 pm

Ganz merkwürdiger Effekt: wenn der Cache aktiviert ist, kann ich die in meiner Navigation enthaltene Kategorie http://u1amo01.de/blog/categories/15-Fotos nicht mehr aufrufen. Statt dessen wird die Startseite gezeigt.

Und wenn ich auf die ebenfalls in der Navigation eingetragenen statischen Seiten wie z. B. http://u1amo01.de/blog/pages/lieblinks.html klicke, wird zwar der richtige Inhalt der statischen Seite angezeigt, unterhalb davon erscheint allerdings der Inhalt der Startseite.

Deaktiviere ich den Cache, wird alles richtig angezeigt.

Very strange.

sparrk
Posts: 3
Joined: Wed Dec 12, 2007 5:30 pm
Contact:

Re: einige Probleme nach Umstellung auf 2.1

Post by sparrk » Wed Feb 15, 2017 5:42 pm

Moin

ich würde mich gerade hier mit reinhängen mit den Fehlermeldungen zum RC für 2.1.

Bei mir hat es den Feed zerschossen.
Ich erhalte beim Aufruf:
Parse error: syntax error, unexpected '[' in /PFAD/blog/rss.php on line 25
Live zu sehen unter https://www.die-antwort-auf-alle-fragen ... =2.0&all=1

Auf Anhieb sehe ich den Fehler? in Zeile 25 nicht.

Code: Select all

    $allowed_versions = ['opml1.0', '0.91', '1.0',  '2.0', 'atom0.3', 'atom1.0'];

User avatar
onli
Regular
Posts: 2243
Joined: Tue Sep 09, 2008 10:04 pm
Contact:

Re: einige Probleme nach Umstellung auf 2.1

Post by onli » Wed Feb 15, 2017 8:15 pm

The PHP version on that blog seems to be 5.3.28. That is ancient, and not secure. Please update at least to 5.6, better to PHP 7. That will support the []-syntax to create an array.

sparrk
Posts: 3
Joined: Wed Dec 12, 2007 5:30 pm
Contact:

Re: einige Probleme nach Umstellung auf 2.1

Post by sparrk » Wed Feb 15, 2017 11:00 pm

Danke,
Vor Urzeiten habe ich wohl mal

Code: Select all

AddHandler php53-cgi .php
in die htaccess gepackt. Jetzt gehts. :D

Post Reply