Trackback richtig einrichten

Hier können Probleme und alles andere in Deutscher Sprache gelöst werden.
Post Reply
xoxyss
Regular
Posts: 91
Joined: Wed May 27, 2015 12:13 am
Location: Baden-Württemberg
Contact:

Trackback richtig einrichten

Post by xoxyss » Tue Jun 21, 2016 12:07 pm

Hi zusammen,

ich habe vor kurzem auf meinem Blog einen Artikel geschrieben und in diesem auf einen anderen bloginternen Artikel verlinkt. Beim Speichern wurde mir auch mitgeteilt, dass ein Trackback gesendet wurde, auf der Seite des verlinkten Artikels steht aber weiterhin "Keine Trackbacks".

Muss ich da noch irgend was einstellen oder sollte das out-of-the-box funktionieren? Eventuell habe ich auch in meinen Theme was vergessen? Ich hoffe ihr könnt mich in die richtige Richtung lenken :-)

Vielen Dank im voraus.

User avatar
yellowled
Regular
Posts: 7090
Joined: Fri Jan 13, 2006 12:46 pm
Location: Eutin, Germany
Contact:

Re: Trackback richtig einrichten

Post by yellowled » Tue Jun 21, 2016 1:10 pm

xoxyss wrote:Muss ich da noch irgend was einstellen oder sollte das out-of-the-box funktionieren? Eventuell habe ich auch in meinen Theme was vergessen?
Zunächst mal solltest Du im Backend gucken, ob das Trackback dort angekommen ist. Eventuell hast Du in den Blog- und/oder Spamschutz-Einstellungen (kommt drauf an, ob und welche Spamschutz-Plugins Du verwendest) Trackbacks auf moderieren gesetzt oder sie werden durch irgendwelche Spamschutz-Mechanismen moderiert oder gar abgewiesen. (Es kann die Fehlersuche sehr erleichtern, wenn man die Spamschutz-Plugins Logfiles schreiben lässt.)

YL
amazon Wishlist - Serendipity-Podcast (German only, sorry)

User avatar
yellowled
Regular
Posts: 7090
Joined: Fri Jan 13, 2006 12:46 pm
Location: Eutin, Germany
Contact:

Re: Trackback richtig einrichten

Post by yellowled » Tue Jun 21, 2016 1:11 pm

xoxyss wrote:Eventuell habe ich auch in meinen Theme was vergessen?
Ach so, das ist natürlich superleicht zu testen – einfach mal auf 2k11 umschalten und prüfen. :)

YL
amazon Wishlist - Serendipity-Podcast (German only, sorry)

xoxyss
Regular
Posts: 91
Joined: Wed May 27, 2015 12:13 am
Location: Baden-Württemberg
Contact:

Re: Trackback richtig einrichten

Post by xoxyss » Tue Jun 21, 2016 1:17 pm

Danke für die schnelle Antwort. Also am Theme scheint es schonmal nicht zu liegen :-)
yellowled wrote:Zunächst mal solltest Du im Backend gucken, ob das Trackback dort angekommen ist.
Blöde Frage, aber wie prüfe ich das?

Trackbackeinstellungen sehen für mich gut aus, einige stehen auf "Moderieren" aber da sollte ich dann ja ne Mail wie bei Kommentaren auch bekommen. Logfiles muss ich mir heute abend mal anschauen.

xoxyss
Regular
Posts: 91
Joined: Wed May 27, 2015 12:13 am
Location: Baden-Württemberg
Contact:

Re: Trackback richtig einrichten

Post by xoxyss » Tue Jun 21, 2016 1:31 pm

Verdammt... ich habs gefunden. Ich hab $_SERVER['REMOTE_ADDR'] überschrieben...

Code: Select all

    $_SERVER['REMOTE_ADDR'] = preg_replace('#(?:\.\d+){2}$#', '.0.0', $_SERVER['REMOTE_ADDR']);
Hauptsächlich war das für die Anonymisierung von Kommentaren gedacht. Ich hatte in den Trackback-Einstellungen noch "Trackbacks/Pingbacks: IP Validierung" auf abweisen gestellt und deswegen auch keine Mail bekommen. Ich habs jetzt mal auf moderieren und jetzt kommt auch die Mail.

Nicht ganz optimal die Lösung aber was solls...

Danke nochmal

User avatar
yellowled
Regular
Posts: 7090
Joined: Fri Jan 13, 2006 12:46 pm
Location: Eutin, Germany
Contact:

Re: Trackback richtig einrichten

Post by yellowled » Tue Jun 21, 2016 1:51 pm

xoxyss wrote:Blöde Frage, aber wie prüfe ich das?
Für die Akten: unter Aktivität/Kommentare, und dort ggf. dann noch einen Typ-Filter auf Trackbacks setzen. Gemeint war, einfach nur zu gucken, ob vielleicht Trackbacks angekommen sind, aber im Frontend nicht ausgegeben werden. (Aber das Problem hat sich ja quasi erledigt, wenn ich das richtig verstehe.)

YL
amazon Wishlist - Serendipity-Podcast (German only, sorry)

xoxyss
Regular
Posts: 91
Joined: Wed May 27, 2015 12:13 am
Location: Baden-Württemberg
Contact:

Re: Trackback richtig einrichten

Post by xoxyss » Tue Jun 21, 2016 7:28 pm

Danke für den Hinweis. Ja soweit funktioniert alles. Allerdings habe ich über dem Trackback-Link einen weiteren a-Tag:

Code: Select all

<a id="c271"></a>
Wo kommt der denn her und was macht der da?

Danke für deine Hilfe :-)

Edit: Wo auch immer es herkommt, ich hab trackbacks.tpl mal so wie in 2k11 angelegt, da taucht dieser a-Tag nicht auf.

User avatar
yellowled
Regular
Posts: 7090
Joined: Fri Jan 13, 2006 12:46 pm
Location: Eutin, Germany
Contact:

Re: Trackback richtig einrichten

Post by yellowled » Tue Jun 21, 2016 8:40 pm

xoxyss wrote:

Code: Select all

<a id="c271"></a>
Wo kommt der denn her und was macht der da?
Aus der trackbacks.tpl. Ich würde mal vermuten, dass Du entweder keine eigene oder die aus /templates/default/ übernommen hattest. Dort steht (in Zeile 3):

Code: Select all

<a id="c{$trackback.id}"></a>
Ähnliches findet sich in /templates/default/comments.tpl. Es dient dazu, auf einzelne Trackbacks oder Kommentare linken zu können, ist aber so – weil es ein inhaltsleeres Element und damit (normalerweise) grober Unfug ist – natürlich Blödsinn. In 2k11 habe ich es dann so gelöst, dass diese ids eben den Container-Elementen des jeweiligen Trackbacks oder Kommentars zugewiesen werden (was die einzig sinnvolle Lösung ist).

YL
amazon Wishlist - Serendipity-Podcast (German only, sorry)

xoxyss
Regular
Posts: 91
Joined: Wed May 27, 2015 12:13 am
Location: Baden-Württemberg
Contact:

Re: Trackback richtig einrichten

Post by xoxyss » Tue Jun 21, 2016 8:48 pm

Ich hab deine Lösung schon entdeckt. Jetzt funktioniert alles wie es soll. Vielen Dank für die, wie immer, kompetente und schnelle Antwort ;-)

Post Reply