[gelöst]: Popfetcher: Keine Bilder im Eintrag

Hier können Probleme und alles andere in Deutscher Sprache gelöst werden.
Post Reply
User avatar
snafu
Regular
Posts: 108
Joined: Sat Dec 17, 2005 7:34 am

[gelöst]: Popfetcher: Keine Bilder im Eintrag

Post by snafu » Wed Jun 24, 2015 11:22 am

Hallo zusammen!

Mail mit Text im Body und gewünschtem Bild im Anhang => Posting nur mit Text, ohne Bild.

- Serendipity 1.7.8 und PHP 5.5.5
- Popfetcher Version: 1.45
- Popfetcher Einstellungen : http://flipdot.org/blog/uploads/popfetcher_2.png
- Popfetcher Antwort beim Aufruf der Poll-Url im Anhang

Vorschau-Erzeugung beim manuellen Posten geht einwandfrei.

In der Popfetcher Antwort steht:

MESSAGE PART -- Anhang gefunden: sl1-150x150.jpg
Scanning for inlinepic: (and [attach:1])
Inlinepic result: false
Saving attachment seperately.

Hat jemand eine Ahnung, was ich tun kann?

Herzlichen Dank und liebe Grüße!
Attachments
popfetcher_output.txt
(2.24 KiB) Downloaded 113 times
Last edited by snafu on Fri Jun 26, 2015 5:17 pm, edited 1 time in total.

bernd_d
Regular
Posts: 468
Joined: Thu Jun 03, 2010 9:28 am
Contact:

Re: Popfetcher: Keine Bilder im Eintrag

Post by bernd_d » Wed Jun 24, 2015 7:58 pm

Schau dir mal http://board.s9y.org/viewtopic.php?f=3& ... p=10437598 an, es könnte an der bei dir aktivierten Option "Entferne HTML" liegen, war bei mir damals so.

User avatar
snafu
Regular
Posts: 108
Joined: Sat Dec 17, 2005 7:34 am

Re: Popfetcher: Keine Bilder im Eintrag

Post by snafu » Wed Jun 24, 2015 10:06 pm

bernd_d wrote:es könnte an der bei dir aktivierten Option "Entferne HTML" liegen, war bei mir damals so.
Danke für die Idee, hat leider nicht geholfen. Ich habe auch schon alle Mailclients, Webmailer und Geräte durchprobiert... Hm...

Schönen Abend!

User avatar
garvinhicking
Core Developer
Posts: 30020
Joined: Tue Sep 16, 2003 9:45 pm
Location: Cologne, Germany
Contact:

Re: Popfetcher: Keine Bilder im Eintrag

Post by garvinhicking » Thu Jun 25, 2015 12:50 pm

Die Option "View Thumbnail in Entry Body" solltest du aktivieren, wenn Du das Bild als Vorschau sehen möchtest?
# Garvin Hicking (s9y Developer)
# Did I help you? Consider making me happy: http://wishes.garv.in/
# or use my PayPal account "paypal {at} supergarv (dot) de"
# My "other" hobby: http://flickr.garv.in/

User avatar
snafu
Regular
Posts: 108
Joined: Sat Dec 17, 2005 7:34 am

Re: Popfetcher: Keine Bilder im Eintrag

Post by snafu » Thu Jun 25, 2015 1:09 pm

garvinhicking wrote:"View Thumbnail in Entry Body"
Hatte ich schon durchprobiert, grade nochmal, die Antwort bleibt:

Scanning for inlinepic: (and [attach:1])
Inlinepic result: false
Saving attachment seperately.

Also: Das Bild wird einwandfrei übertragen / runtergeladen, aber nur im Medienverzeichnis abgelegt. Weder mit noch ohne diesen Schalter gelangt es in den Eintrag.

Worüber ich mich wundere (vielleicht hift das etwas):

In der Meldung vom Popfetcher wird von einem Anhang gesprochen, aber dann steht da:
"[body] => ����JFIF��;CREATOR: gd-jpeg v1.0" (mehr siehe unten)

so als ob das Bild im Bodytext eingefügt wäre!? Vielleicht doch ein Problem des Senders?

Viele Grüße
snafu



[1] => stdClass Object
(
[headers] => Array
(
[content-type] => image/jpeg; name="aj0rKxx_700b_v1.jpg"
[content-transfer-encoding] => base64
[content-disposition] => attachment; filename="aj0rKxx_700b_v1.jpg"
)

[ctype_primary] => image
[ctype_secondary] => jpeg
[ctype_parameters] => Array
(
[name] => aj0rKxx_700b_v1.jpg
)

[disposition] => attachment
[d_parameters] => Array
(
[filename] => aj0rKxx_700b_v1.jpg
)

[body] => ����JFIF��;CREATOR: gd-jpeg v1.0 (using IJG JPEG v80), quality = 92
��,Optimized by JPEGmini 3.11.4.3 0xb475e1d3��C






User avatar
garvinhicking
Core Developer
Posts: 30020
Joined: Tue Sep 16, 2003 9:45 pm
Location: Cologne, Germany
Contact:

Re: Popfetcher: Keine Bilder im Eintrag

Post by garvinhicking » Thu Jun 25, 2015 1:42 pm

Hi!

Hast Du mal den Eintrag im s9y Backend editiert und geschaut ob im erweiterten Eintrag der Link enthalten ist? Könnte sein dass er dort landet. So wie ich den Code lese müsste das Bild eigentlich verlinkt werden.

Das mit dem "body" ist normal. In E-Mails werden die verschiedenen Daten immer bei Binärdateien auch im "body" gespeichert, obwohl es ja Attachmentcode ist...

LG,
Garvin
# Garvin Hicking (s9y Developer)
# Did I help you? Consider making me happy: http://wishes.garv.in/
# or use my PayPal account "paypal {at} supergarv (dot) de"
# My "other" hobby: http://flickr.garv.in/

User avatar
snafu
Regular
Posts: 108
Joined: Sat Dec 17, 2005 7:34 am

Re: Popfetcher: Keine Bilder im Eintrag

Post by snafu » Thu Jun 25, 2015 3:40 pm

garvinhicking wrote:Hast Du mal den Eintrag im s9y Backend editiert und geschaut ob im erweiterten Eintrag der Link enthalten ist?
Ja, nichts drin. Bodytext steht im Eintrag, erweiterter Eintrag völlig leer, kein IMG link, nada.

Ich freue mich über deine Hilfsbereitschaft - wir brauchen die Funktion für "nicht-Nerd-Mitglieder" ;)

User avatar
Timbalu
Regular
Posts: 4598
Joined: Sun May 02, 2004 3:04 pm

Re: Popfetcher: Keine Bilder im Eintrag

Post by Timbalu » Thu Jun 25, 2015 4:25 pm

Das können zB zwei Dinge sein. Ein bug im Plugin, da der link möglicherweise nicht korrekt übertragen (returned) wird, siehe https://github.com/s9y/additional_plugi ... r.php#L834, oder
Is your jpeg file a CMYK-jpeg? If so, GD will not work. They need to be RGB-based.
Probiere es mal mit einem anderen image.
Regards,
Ian

Serendipity Styx Edition and additional_plugins @ https://ophian.github.io/ @ https://github.com/ophian

User avatar
snafu
Regular
Posts: 108
Joined: Sat Dec 17, 2005 7:34 am

Re: Popfetcher: Keine Bilder im Eintrag

Post by snafu » Fri Jun 26, 2015 6:20 am

Timbalu wrote:Das können zB zwei Dinge sein. Ein bug im Plugin,
Hm, ok, den kann /ich/ aber nicht fixen. Könnte eine Neuinstallation sinnvoll sein? Bei einem Bug in der Quelle ja nicht, aber..?
Is your jpeg file a CMYK-jpeg? If so, GD will not work. They need to be RGB-based.
Das habe ich probiert - geht auch nicht.

Danke für deine Anregungen!

User avatar
garvinhicking
Core Developer
Posts: 30020
Joined: Tue Sep 16, 2003 9:45 pm
Location: Cologne, Germany
Contact:

Re: Popfetcher: Keine Bilder im Eintrag

Post by garvinhicking » Fri Jun 26, 2015 11:59 am

Hi!

Die Lösung ist, dass Du die Option "Use plaintextd attachments as entry body" auf "JA" stelen musst. Nur dann kann das Plugin erkennen dass es die Attachment-Links auch nicht nur speichern soll, sondern in den Inhalt einfügen.

Ist zugegebenermaßen etwas krude, aber das Plugin ist mit der Zeit für so viele Rand- und Sonderfälle gewachsen, dass die ganzen Einstellungen mitunter etwas komisch wirken. Es ist aber eigentlich standardmäßig aktiviert, so dass es erst beim Deaktivieren Probleme machen würde.

Ich habe gerade dennoch mal auch die Version 1.46 committed, in der die ganzen englischen Begriffe auch korrekt übersetzt werden. Die Option heißt jetzt "Plain-Text-Attachments als Blog-Eintrag benutzen?".

VG,
Garvin
# Garvin Hicking (s9y Developer)
# Did I help you? Consider making me happy: http://wishes.garv.in/
# or use my PayPal account "paypal {at} supergarv (dot) de"
# My "other" hobby: http://flickr.garv.in/

User avatar
snafu
Regular
Posts: 108
Joined: Sat Dec 17, 2005 7:34 am

Re: Popfetcher: Keine Bilder im Eintrag

Post by snafu » Fri Jun 26, 2015 5:13 pm

garvinhicking wrote:Die Lösung ist, dass Du die Option "Use plaintextd attachments as entry body" auf "JA" stelen musst.

HURRA! Es geht!

Ich bin ja einer von den oberschlauen Usern, die versuchen mitzudenken: Ich habe jede Option durchgelesen und zu verstehen versucht, und darum diese abgeschaltet ;)

Egal, jetzt klappts! Danke für deine Mühe, da wär ich nie drauf gekommen!

Viele grüße
snafu

Post Reply