Wochentagsnamen im Kalender komisch

Hier können Probleme und alles andere in Deutscher Sprache gelöst werden.
Post Reply
ICE
Regular
Posts: 239
Joined: Tue Jun 28, 2005 11:15 pm

Wochentagsnamen im Kalender komisch

Post by ICE » Tue Jun 28, 2005 11:25 pm

Hallo Forum!

Ich habe ein Problem mit den Wochentagsnamen im Kalender.

Auf meinem Heimserver stehen in Deutsch ganz normal die Wochentage mit "Mo Di Mi Do Fr Sa So" ...

In meinem Blog auf einem 1und1.de Hosting Paket werden die Wochentage folgendermaßen angezeigt: "Mon Die Mit Don Fre Sam Son" ...
Das sieht einfach unschön aus und verbreitert den Kalender unnötigerweise.

Habe schon in der serendipity_lang_de.inc.php Datei geschaut, kann da aber nix finden ...

Habt ihr eine Idee, wie ich die Wochentage mit nur jeweils zwei Buchstaben anzeigen lassen?

Danke
ICE

User avatar
winkiller
Regular
Posts: 77
Joined: Tue May 17, 2005 7:52 pm
Location: Munich, Germany
Contact:

Post by winkiller » Wed Jun 29, 2005 12:35 am

hm, ich glaub das hängt an date/setlocale von PHP
hab selber auch MoDiMiDo und grad online ein Blog mit MonDieMit gefunden, ich weiss aber leider im Moment auch keine abhilfe

ICE
Regular
Posts: 239
Joined: Tue Jun 28, 2005 11:15 pm

Post by ICE » Wed Jun 29, 2005 1:09 am

Hey, trotzdem danke für die Antwort!

Sonst hätte ich womöglich nie die weatherpixies kennen gelernt ... --> direkt eingebaut ... aber ich habe die Doll:Blonde genommen ... steh ja mehr auf blond ;-)

User avatar
winkiller
Regular
Posts: 77
Joined: Tue May 17, 2005 7:52 pm
Location: Munich, Germany
Contact:

Post by winkiller » Wed Jun 29, 2005 9:43 am

I think so, I'll try to come up with something.

User avatar
garvinhicking
Core Developer
Posts: 30020
Joined: Tue Sep 16, 2003 9:45 pm
Location: Cologne, Germany
Contact:

Post by garvinhicking » Wed Jun 29, 2005 10:47 am

Man kann die Monatsnamen auch recht leicht in der Templatedatei auf 2 Zeichen stutzen.

Datei "templates/.../plugin_calendar.tpl" öffnen und:

Code: Select all

{$dow.date|@formatTime:"%a":false} 


ersetzen durch:

Code: Select all

{$dow.date|@formatTime:"%a":false|@truncate:2:'':true} 


Grüße,
Garvin
# Garvin Hicking (s9y Developer)
# Did I help you? Consider making me happy: http://wishes.garv.in/
# or use my PayPal account "paypal {at} supergarv (dot) de"
# My "other" hobby: http://flickr.garv.in/

ICE
Regular
Posts: 239
Joined: Tue Jun 28, 2005 11:15 pm

Post by ICE » Wed Jun 29, 2005 10:56 am

Danke! Hat funktioniert!

Gast

Post by Gast » Fri Jul 15, 2005 1:46 am

ein glück gibt es noch welche, die so ähnliche kleine problemchen habe wie ich. danke für die antwort. uahc bei mir hats geklappt mit den tagen :)

Col. Kurtz
Regular
Posts: 450
Joined: Thu May 26, 2005 10:43 am
Location: Bonn, Germany
Contact:

Post by Col. Kurtz » Sun Sep 04, 2005 8:40 pm

Gleiches Problem, nur nicht im Kalender sondern im Gästebuch. Wo muss ich hier editieren?
Marc

User avatar
garvinhicking
Core Developer
Posts: 30020
Joined: Tue Sep 16, 2003 9:45 pm
Location: Cologne, Germany
Contact:

Post by garvinhicking » Mon Sep 05, 2005 12:26 pm

Col. Kurtz: Du kannst das Plugin konfigurieren und die Option "dateformat" umändern. Zwei-Tages-Kürzel kannst Du so leider nicht einrichten, Du müsstest also das Format umstellen und Tagesnamen weglassen.

Oder die Datumsausgabe im Plugin komplett umändern. Such da mal nach 'dateformat'...

Grüße,
Garvin
# Garvin Hicking (s9y Developer)
# Did I help you? Consider making me happy: http://wishes.garv.in/
# or use my PayPal account "paypal {at} supergarv (dot) de"
# My "other" hobby: http://flickr.garv.in/

Post Reply