Update 1.7.8 > 2.0b2 Klappt nicht

Hier können Probleme und alles andere in Deutscher Sprache gelöst werden.
Post Reply
theborg
Regular
Posts: 37
Joined: Thu Jan 18, 2007 11:57 am
Contact:

Update 1.7.8 > 2.0b2 Klappt nicht

Post by theborg » Mon Jun 09, 2014 9:14 pm

Hi wolte auf die 2.0 Beta updaten leider klappt das nicht ich werde aus der Fehlermeldung auch nicht wirklich schlau.

== TESTING ERROR MODE ==
Fatal error: Uncaught exception 'ErrorException' with message 'constant(): Couldn't find constant NAV_DEFAULT_4' in .../include/compat.inc.php:126
Stack trace:
#0 [internal function]: errorToExceptionHandler(2, 'constant(): Cou...', '.../grauti...', 58, Array)
#1 .../templates/grautierneu/config.inc.php(58): constant('NAV_DEFAULT_4')
#2 .../include/functions_smarty.inc.php(1027): include_once('.../grauti...')
#3 .../include/admin/upgrader.inc.php(422): serendipity_smarty_init()
#4 .../serendipity_admin.php(264): require('.../grauti...')
#5 {main}
thrown in .../include/compat.inc.php on line 126

User avatar
Timbalu
Regular
Posts: 4598
Joined: Sun May 02, 2004 3:04 pm

Re: Update 1.7.8 > 2.0b2 Klappt nicht

Post by Timbalu » Tue Jun 10, 2014 8:21 am

That hints to a/your templates config.inc.php file including a navigation configuration. (*)
Did you take the official beta zip from http://www.s9y.org/12.html ?
It might be better to take this pre beta3 zip https://github.com/s9y/Serendipity/archive/2.0.zip, since we have changed and fixed a lot concerning templating fallback mode and config checks.
Or downgrade to 1.7.8 and wait for the official beta3 or even the RC phase.

(*) I remember long time ago having had something similar, which was based to a wrong index key, which assigning the wrong NAV_DEFAULT_n constant smarty var.
Regards,
Ian

Serendipity Styx Edition and additional_plugins @ https://ophian.github.io/ @ https://github.com/ophian

Post Reply